Results 1 to 9 of 9

Thread: Disabling desktop effects in 11.04

  1. #1
    Join Date
    Feb 2011
    Beans
    492
    Distro
    Ubuntu

    Disabling desktop effects in 11.04

    I've just upgraded to 11.04, but Unity is unfortunately not my cup of tea.
    I use the classic desktop but I cannot find a way to disable a certain
    graphical desktop effect... I'm thinking of how the current workspace
    quickly slides into the next when I choose a different workspace.

    If my recollection is correct, you could turn effects like that
    off in 10.10. This makes me dizzy, does any of know how to turn this off?
    Last edited by Dry Lips; April 28th, 2011 at 11:11 PM.

  2. #2
    Join Date
    Apr 2007
    Location
    Miami FL USA
    Beans
    1,244
    Distro
    Ubuntu Development Release

    Re: Disabling desktop effects in 11.04

    Quote Originally Posted by Dry Lips View Post
    I've just upgraded to 11.04, but Unity is unfortunately not my cup of tea.
    I use the classic desktop but I cannot find a way to disable a certain
    graphical desktop effect... I'm thinking of how the current workspace
    quickly slides into the next when I choose a different workspace.

    If my recollection is correct, you could turn effects like that
    off in 10.10. This makes me dizzy, does any of know how to turn this off?
    Open a terminal window and type ccsm, then look at Desktop>Desktop Wall, see if it disables the slider.

  3. #3
    Join Date
    Feb 2011
    Beans
    492
    Distro
    Ubuntu

    Re: Disabling desktop effects in 11.04

    I had to install
    Code:
    sudo apt-get install compizconfig-settings-manager
    Really nice program, btw! I'm definitively going to have a closer look at it!

    I went to Desktop>Desktop Wall>Viewport Switching
    and set “Wall sliding duration” to 0.

    at Desktop>Desktop Wall>Viewport Switch preview
    I also set “Switch target preview visibility time” to 0.

    Voila! Thanks a lot. My head has stopped spinning now!

  4. #4
    Join Date
    Apr 2007
    Location
    Miami FL USA
    Beans
    1,244
    Distro
    Ubuntu Development Release

    Re: Disabling desktop effects in 11.04

    Quote Originally Posted by Dry Lips View Post
    I had to install
    Code:
    sudo apt-get install compizconfig-settings-manager
    Really nice program, btw! I'm definitively going to have a closer look at it!

    I went to Desktop>Desktop Wall>Viewport Switching
    and set “Wall sliding duration” to 0.

    at Desktop>Desktop Wall>Viewport Switch preview
    I also set “Switch target preview visibility time” to 0.

    Voila! Thanks a lot. My head has stopped spinning now!
    Glad it worked out, I like the cube but its hard to get it going without a lot of editing files and I'm not to lucky sometimes !

  5. #5
    Join Date
    Nov 2010
    Location
    Berlin, Germany
    Beans
    4,534
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Disabling desktop effects in 11.04

    Quote Originally Posted by Dry Lips View Post
    I went to Desktop>Desktop Wall>Viewport Switching
    and set “Wall sliding duration” to 0.
    Thanks for that tip, I didn't notice that setting before. I regularly switch workspaces, and disabling those feature makes that indeed much snappier. =)
    Quote Originally Posted by Dry Lips View Post
    at Desktop>Desktop Wall>Viewport Switch preview
    I also set “Switch target preview visibility time” to 0.
    You can disable those feature completely by unticking "Show Viewport Switcher Preview".

  6. #6
    Join Date
    Nov 2010
    Location
    Berlin, Germany
    Beans
    4,534
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Disabling desktop effects in 11.04

    Quote Originally Posted by Dry Lips View Post
    I went to Desktop>Desktop Wall>Viewport Switching
    and set “Wall sliding duration” to 0.
    And you can disable those feature completely by setting "Non Sliding Windows" to "any".

  7. #7
    Join Date
    Feb 2011
    Beans
    492
    Distro
    Ubuntu

    Re: Disabling desktop effects in 11.04

    Quote Originally Posted by Krytarik View Post
    And you can disable those feature completely by setting "Non Sliding Windows" to "any".
    Thanks Krytarik! This made it even snappier.

    However I'm having another problem. When a window is minimised, and you click on it again, it makes this jumping motion, if you know what I mean... Does any of you know how to disable this?
    Last edited by Dry Lips; May 3rd, 2011 at 12:01 AM.

  8. #8
    Join Date
    Nov 2010
    Location
    Berlin, Germany
    Beans
    4,534
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Disabling desktop effects in 11.04

    Quote Originally Posted by Dry Lips View Post
    When a window is minimised, and you click on it again, it make this jumping motion, if you know what I mean... Does any of you know how to disable this?
    I guess your are meaning "CompizConfig Settings Manager -> Animations -> Minimize Animation", there is by default a single rule, which is set to "Zoom", just set it to "None".

  9. #9
    Join Date
    Feb 2011
    Beans
    492
    Distro
    Ubuntu

    Re: Disabling desktop effects in 11.04

    Yep! That's the one. Thanks again!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •