Results 1 to 7 of 7

Thread: slow wireless with ath9k

  1. #1
    Join Date
    Oct 2010
    Beans
    78

    slow wireless with ath9k (Solved)

    I install Kubuntu 11.04 on a laptop but the wireless connexion is so slow. It use the integrate wifi ath9k driver, is there any solution?

    Thank you
    Last edited by granul; May 5th, 2011 at 03:49 PM.

  2. #2
    Join Date
    Nov 2008
    Beans
    555
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: slow wireless with ath9k

    Try to turn off power save mode. sudo iwconfig wlan0 power off
    I assume your card is wlan0.
    Get the power Don't dig any deeper.Fight the evil.

  3. #3
    Join Date
    Oct 2010
    Beans
    78

    Re: slow wireless with ath9k

    Quote Originally Posted by uncaspi View Post
    Try to turn off power save mode. sudo iwconfig wlan0 power off
    I assume your card is wlan0.

    I tried this but it does not work, I think the problem is with the driver ATH9K of my laptop integrate wifi

  4. #4
    Join Date
    Feb 2007
    Location
    Prince Edward Island
    Beans
    9
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: slow wireless with ath9k

    After I finished the upgrade to 11.04, my Ath9k wireless driver gave me downloads of 0.90 Mbps where I was previously getting 30.0 Mbps. The solution below worked for me in Ubuntu 11.04... Good Luck!

    Enter the following Code in a terminal session:

    sudo -s

    echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf

    reboot

  5. #5
    Join Date
    May 2011
    Beans
    1

    Talking Re: slow wireless with ath9k

    Quote Originally Posted by wburden View Post
    After I finished the upgrade to 11.04, my Ath9k wireless driver gave me downloads of 0.90 Mbps where I was previously getting 30.0 Mbps. The solution below worked for me in Ubuntu 11.04... Good Luck!

    Enter the following Code in a terminal session:

    sudo -s

    echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf

    reboot
    I have altogether about 5 hours experience in Ubuntu and not all that familiar with a unix environment. After reading at least 20 pages of people's not so successful attempts at rebuilding the driver from source I'm glad to have found a simple solution that just works. I'm back up from 50 KB/s to my usual 1.2MB/s.

    Thank you Thank you Thank you!!!!!

    Aaron

  6. #6
    Join Date
    Oct 2010
    Beans
    78

    Re: slow wireless with ath9k

    Thank you it works

  7. #7
    Join Date
    Mar 2007
    Location
    Carmona, Cavite, PH
    Beans
    822
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: slow wireless with ath9k

    Quote Originally Posted by wburden View Post
    After I finished the upgrade to 11.04, my Ath9k wireless driver gave me downloads of 0.90 Mbps where I was previously getting 30.0 Mbps. The solution below worked for me in Ubuntu 11.04... Good Luck!

    Enter the following Code in a terminal session:

    sudo -s

    echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf

    reboot
    I have to say this WORKS!!!! but wireless card still goes to sleep. I still have to try uncaspi's advice.
    Linux Registered User # 462237
    Ubuntu User # 20080

    eMachines D725 (Intel® Pentium® Dual-core T4300, 2GB RAM, 320GB HDD)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •