Results 1 to 8 of 8

Thread: Unlock the 'default' keyring at startup

  1. #1
    Join Date
    Apr 2011
    Location
    United Kingdom
    Beans
    17
    Distro
    Ubuntu 11.04 Natty Narwhal

    Wink Unlock the 'default' keyring at startup

    Hello,

    At each startup, Ubuntu asks me for the password for the keyring.
    Code:
    An application wants access to the keyring 'Default', but it is locked. 
    Enter password for keyring 'Default' to unlock
    Even if I choose:
    Code:
    Automatically unlock this keyring whenever I'm logged in
    it keeps asking it to me at each startup and the connection does not establish if I don't do it. I don't see anything special in the settings for "Passwords and Encryption keys"

    Is there a way to remove this?

    Thanks for your help

  2. #2
    Join Date
    May 2009
    Location
    Land of Lincoln
    Beans
    1,369
    Distro
    Ubuntu Development Release

    Re: Unlock the 'default' keyring at startup

    Hi!

    You could try:

    system...preferences..startup programs and uncheck the gnome keyrings.

    KegHead

  3. #3
    Join Date
    Apr 2011
    Beans
    18

    Re: Unlock the 'default' keyring at startup

    Yeah, same here, very annoying to have to enter my pass every time i want to connect to the net.

  4. #4
    Join Date
    Apr 2011
    Location
    United Kingdom
    Beans
    17
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Unlock the 'default' keyring at startup

    Quote Originally Posted by KegHead View Post
    Hi!

    You could try:

    system...preferences..startup programs and uncheck the gnome keyrings.

    KegHead
    I tried to uncheck the 2 startup programs called "Secret Storage Service" and "SSH Key Agent" as you suggested, but it still asks for the password it after reboot!

    thanks for your help

  5. #5
    Join Date
    Oct 2007
    Location
    Europe
    Beans
    3,564
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Unlock the 'default' keyring at startup

    if the keyring is just for the wireless internet connection then put a check mark in the for all users box on the wireless connection setup, it wont ask you again for the password.
    another way is to remove the existing keyring in Passwords and Encryption keys (clean up everything there) then next time it asks to set up the keyring password just set a blank password and the keyring will never show up again.
    Intel Atom Dual Core D525 @ 1.80GHz, 1,0GB RAM, Intel Graphics Media Accelator 3150
    Linux User # 478860 Ubuntu User # 24004

  6. #6
    Join Date
    Apr 2011
    Location
    United Kingdom
    Beans
    17
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Unlock the 'default' keyring at startup

    It works now.

    For the other user following this thread, what I did was to remove the "Default" keyring from the system settings. At the next startup, it prompted me for the WPA password which I entered, and then if I wanted to save the keyring. I then clicked OK, it asked me if I was sure to accept the "unsafe storage" of my passwords. Done!

    Thanks KegHead, gandaran.

  7. #7
    Join Date
    Mar 2009
    Beans
    14
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Unlock the 'default' keyring at startup

    Setting empty passwords for keyrings or storing passwords outside of keyrings is inherently insecure: anyone, that can access the machine, can get to the info. If that's OK, just skip the rest of this post.

    The login keyring is unlocked when you log in. Unfortunately, gnome uses the default keyring to store passwords. The default keyring is named 'Default'. This can be fixed in the 'Passwords and Encryption Keys' applet.

    1. right-click on the 'login' keyring and set it as default.
    2. unlock the 'Default' keyring and make sure you have a record of all the passwords in there; note each application that needs these passwords. In my case there are passwords for wireless networks and the Ubuntu Software Center (because I left a comment on a package, which requires an identity).
    3. Right-click the 'Default' keyring and delete it.
    4. Go into each app, that had a password stored, and get it to ask you to enter the password. It will be stored in the new default keyring - the one named 'login'.

    Done. Now your login keyring is also the gnome keyring. Sorry, there appears to be no support in Seahorse (that's the applet) to export/import or copy/paste passwords between keyrings - corresponding menu entries are disabled.

    Hope this works for you as well as it did for me.

  8. #8
    Join Date
    Apr 2010
    Beans
    53
    Distro
    Ubuntu

    Re: Unlock the 'default' keyring at startup

    Quote Originally Posted by SirGe View Post
    Setting empty passwords for keyrings or storing passwords outside of keyrings is inherently insecure: anyone, that can access the machine, can get to the info. If that's OK, just skip the rest of this post.

    The login keyring is unlocked when you log in. Unfortunately, gnome uses the default keyring to store passwords. The default keyring is named 'Default'. This can be fixed in the 'Passwords and Encryption Keys' applet.

    1. right-click on the 'login' keyring and set it as default.
    2. unlock the 'Default' keyring and make sure you have a record of all the passwords in there; note each application that needs these passwords. In my case there are passwords for wireless networks and the Ubuntu Software Center (because I left a comment on a package, which requires an identity).
    3. Right-click the 'Default' keyring and delete it.
    4. Go into each app, that had a password stored, and get it to ask you to enter the password. It will be stored in the new default keyring - the one named 'login'.

    Done. Now your login keyring is also the gnome keyring. Sorry, there appears to be no support in Seahorse (that's the applet) to export/import or copy/paste passwords between keyrings - corresponding menu entries are disabled.

    Hope this works for you as well as it did for me.
    Very thorough answer! Fixed my annoyance, thanks!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •