Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: NVIDIA proprietary driver won't work on my PC

  1. #11
    Join Date
    Jun 2006
    Location
    Toronto, Canada
    Beans
    242
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: NVIDIA proprietary driver won't work on my PC

    Thank you for your responses.
    I ran
    sudo nvidia-xconfig
    and rebooted and it still says "This driver is activated but not currently in use". As well, unfortunately, I'm not getting any compiz effects.
    It would be nice to try out the Unity desktop but I automatically get booted into the classic desktop.
    Thanks,
    Erik.

  2. #12
    Join Date
    Jul 2010
    Location
    Finland
    Beans
    2,455
    Distro
    Ubuntu

    Re: NVIDIA proprietary driver won't work on my PC

    Quote Originally Posted by groovomata View Post
    Thank you for your responses.
    I ran and rebooted and it still says "This driver is activated but not currently in use". As well, unfortunately, I'm not getting any compiz effects.
    It would be nice to try out the Unity desktop but I automatically get booted into the classic desktop.
    Thanks,
    Erik.
    Please run it again and post here all the verbous info you get from terminal.

  3. #13
    Join Date
    May 2008
    Location
    London, UK
    Beans
    250
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: NVIDIA proprietary driver won't work on my PC

    Quote Originally Posted by mc4man View Post
    Then there may be an issue with the integrated graphics..

    At least here I've always needed some sort of xorg.conf w/ nvidia-current though it didn't have to be the big nvidia created one, ex. my current one (at this point maybe better than the nvidia created one which has a lot of unneeded sections


    It's possible your bug may be marked incomplete due to almost no add. added info - may have been better to file like
    Code:
    ubuntu-bug nvidia-current
    That xorg.conf file isn't really needed, it's there to stop the nvidia splash screen appearing when the driver is loaded.
    Join giffgaff, the mobile network run by you! Click here for free sim with £5 credit http://giffgaff.com/orders/affiliate/matthewbpt
    Get a dropbox account! http://db.tt/6pxH9mf

  4. #14
    Join Date
    Jun 2006
    Location
    Toronto, Canada
    Beans
    242
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: NVIDIA proprietary driver won't work on my PC

    Thank you, here it is:
    erik@erik-laptop:~$ sudo nvidia-xconfig

    Using X configuration file: "/etc/X11/xorg.conf".
    Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
    New X configuration file written to '/etc/X11/xorg.conf'

    erik@erik-laptop:~$

  5. #15
    Join Date
    Jun 2006
    Location
    Toronto, Canada
    Beans
    242
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: NVIDIA proprietary driver won't work on my PC

    I also checked out /etc/modprobe.d/ and noted that the nouveau driver is blacklisted in the file "nvidia-graphics-drivers.conf".

  6. #16
    Join Date
    Jul 2010
    Location
    Finland
    Beans
    2,455
    Distro
    Ubuntu

    Re: NVIDIA proprietary driver won't work on my PC

    Quote Originally Posted by matthewbpt View Post
    That xorg.conf file isn't really needed, it's there to stop the nvidia splash screen appearing when the driver is loaded.
    Nope,
    without the file /ect/X11/xorg.conf nvidia drivers are not loaded.
    There must be this line in the "Section Device":
    Code:
        Driver         "nvidia"
    Even if you have the xorg.conf file, the nvidia splash screen (logo) will get loaded.
    To prevent it, you need to put these lines in the "Section Screen":
    Code:
        Option         "NoLogo" "True"

  7. #17
    Join Date
    Jun 2006
    Location
    Toronto, Canada
    Beans
    242
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: NVIDIA proprietary driver won't work on my PC

    Quote Originally Posted by Harry33 View Post
    Nope,
    without the file /ect/X11/xorg.conf nvidia drivers are not loaded.
    There must be this line in the "Section Device":
    Code:
        Driver         "nvidia"
    Even if you have the xorg.conf file, the nvidia splash screen (logo) will get loaded.
    To prevent it, you need to put these lines in the "Section Screen":
    Code:
        Option         "NoLogo" "True"
    I looked in the /etc/X11/xorg.conf file and there is indeed a line in the Section "Device" for
    Driver "nvidia"
    I'm not sure what to do next. Perhaps I'll burn the official 11.04 release and see if that fixes the problem.
    Anyone have any ideas?

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •