Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: usb hard drive not mounting

  1. #1
    Join Date
    Apr 2011
    Beans
    10

    usb hard drive not mounting

    Hello all

    First time using the Forums but it dose not feel that way. Can't wait for 11.04

    I hope this is the best place for this post.

    For a while I have had a usb hard drive that has not mounted at all. Everything I have come across that may help requires the drive to mount on the system. There is a light on the drive so it appears to be working. Hose anyone have any ideas about how I can get the system to reconnoitre the drive.

    Thanks

    Dan

  2. #2
    Join Date
    Feb 2011
    Location
    Maryland
    Beans
    2,251

    Re: usb hard drive not mounting

    open terminal, unplug your flash drive, plug back in.

    type dmesg

    do you see output about the drive being connected?

    do lsusb (LSUSB) and see if it lists your drive.

    Try running System, Administration, Disk utility

    Do you see your drive there? It may have a broken partition and thats why it wont mount.

  3. #3
    Join Date
    Apr 2011
    Beans
    10

    Re: usb hard drive not mounting

    thanks for the quick reply

    dmesg has output that a high speed drivce was detected.
    [10847.892120] usb 2-1: new high speed USB device using ehci_hcd and address 7

    But lsusb dose not list the drive

    Dan

  4. #4
    Join Date
    Aug 2005
    Beans
    795

    Re: usb hard drive not mounting

    I am having the same problem in ubuntu 11.04 its occurred since I switched over in alpha3. The drive worked fine in ubuntu 10.10 on the same computer and still works on xp machines.

    The only usb reference in dmesg is similar to digitalrealm's.
    lsusb does not have it it all.

    Any idea what else we can do to try and figure this out?

  5. #5
    Join Date
    Dec 2009
    Beans
    8

    Re: usb hard drive not mounting

    I am having the same problem in natty. I too did not have any trouble in maverick. With lsusb command it does not show any usb hdd (and takes very long time to show the result). When I tried dmesg it shows "new high speed USB device using ehci_hcd".

    I can use an usb stick stick with no problem, the usb hardrive seems to be the only affected with this problem.

  6. #6
    Join Date
    Aug 2005
    Beans
    795

    Re: usb hard drive not mounting

    Ive posted a question on launchpad answers here https://answers.launchpad.net/ubuntu/+question/155446 no response as of yet. Hopefully we can get to the bottom of this.

  7. #7
    Join Date
    Nov 2007
    Beans
    25

    Re: usb hard drive not mounting

    Have found my HTC Desire phone won't mount. It worked a few weeks ago and assume 11.04 has somehow broken usb detection. At least for my phone. Posting this so I can follow any developments.

  8. #8
    Join Date
    Feb 2011
    Location
    Bergamo, Italy
    Beans
    9
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: usb hard drive not mounting

    My Archos mp3 player has the same problem, it doesn't show up with lsusb since i uprgraded to natty (and the same thing with the live version)

  9. #9
    Join Date
    Aug 2005
    Beans
    795

    Re: usb hard drive not mounting

    Ok I got this fixed on my computer, through my question here https://answers.launchpad.net/ubuntu/+question/155446

    Basically install and open mountmanager then use the usb wizard to add your drive. Now your usb drive should automount and you can remove mountmanager.

  10. #10
    Join Date
    Dec 2009
    Beans
    8

    Re: usb hard drive not mounting

    I tried to follow the instructions, but I could not get it to work on my computer. I will try to keep searching for a solution. Thank you anyway.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •