Results 1 to 8 of 8

Thread: Fix internal mic for use with Skype

  1. #1
    Join Date
    Nov 2010
    Location
    Virginia
    Beans
    37
    Distro
    Ubuntu Development Release

    Talking Fix internal mic for use with Skype

    Well, those of you that have installed Skype on your favourite Ubuntu family distro may have run into this problem:

    I have all of my audio devices up and running, but my microphone captures no sound input!

    Thankfully, the solution is only one package and a slider drag away!

    NOTE: I have only experienced this problem with built in microphones, but if your internal mic has a left and right channel, like on the Dell Studio laptop I own, you shouldn't have to worry about any of the contents of this guide. External mics should work without problems in Skype as long as you have chosen them as your default input device on your distro, not on Skype because if you have PulseAudio, it is the only choice on Skype.

    Using the package manager for your Ubuntu distro, find the package 'PulseAudio Volume Control,' and install it.

    If you are more familiar with the Terminal, you can run this instead:

    sudo apt-get install pavucontrol

    Next run that program. It should be under Menu->Multimedia-> Volume Control. (That is where it is on Kubuntu, I believe Ubuntu calls it 'Pulse Audio Volume Control' under the gnome menu. I switched to Kubuntu this year from Ubuntu, so I know where it is, but my main knowledge is KDE.)

    Choose the 'Input Devices' tab. My netbook has the mic labeled as 'Internal Audio Analog Stereo, and yours may be different.

    Now make sure the option 'Lock Channels Together' is not chosen. Drag the 'Front Left' slider all the way to the left. If the little bar below it doesn't move to indicate sound input, drag the 'Front Right' slider to the left instead.

    There you go! Now you can log in to Skype and ring up the nice Echo Sound Test Service lady to see if it's working!

    TROUBLESHOOTING F.A.Q.:

    -Problem: My device is not shown under the 'Input Devices' tab!
    -Solution: at the bottom, click on the dropdown box next to 'Show:' and select 'Hardware Devices'

    -Problem: The Left and Right Front sliders move together!
    -Solution: You did not disable the 'Lock Channels Together' option like I said to earlier.

    -Problem: I am under the 'Input Devices' tab, and have chosen to show hardware devices, but there is still nothing there!
    -Solution: Go to the 'Configuration' tab and choose 'Analog Stereo Duplex'

    This is my first 'howto thing.' I've been running Linux for about a year and a half, so it's good for Linux noobies that need a simple fix.

    Feel free to make any comments/suggestions.

    ~Zeke
    Last edited by ZekeGraal; April 20th, 2011 at 04:17 PM.
    Caetro - Level 27 Guardian on the LOTRO server Riddermark

  2. #2
    Join Date
    Jul 2011
    Beans
    2
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Fix internal mic for use with Skype

    I've been banging my head against this one for a couple days with my AO751h and this fixed it. Thanks you! But what bizarre solution.

  3. #3
    Join Date
    Jul 2011
    Beans
    2

    Re: Fix internal mic for use with Skype

    Thanks a lot 4 your help! Works like a charm

  4. #4
    Join Date
    Oct 2008
    Location
    Down Under
    Beans
    1,566
    Distro
    Xubuntu 12.10 Quantal Quetzal

    Re: Fix internal mic for use with Skype

    Thank You So Much !

  5. #5
    Join Date
    Feb 2007
    Beans
    78

    Re: Fix internal mic for use with Skype

    But what are you suppose to do if a program, in this case Google hangout, keeps resetting the audio configuration to how it was by default i.e. locked L and R channels, hence stopping the microphone working every 30 seconds.

  6. #6
    Join Date
    Aug 2011
    Beans
    1

    Re: Fix internal mic for use with Skype

    Quote Originally Posted by danielsbrewer View Post
    But what are you suppose to do if a program, in this case Google hangout, keeps resetting the audio configuration to how it was by default i.e. locked L and R channels, hence stopping the microphone working every 30 seconds.
    Indeed, I have the exact same problem and it's about to drive me bananas. I've tried disabling Echo cancellation (don't really use it anyway since I always use headphones) but that doesn't help. Is there a way to prevent applications from making changes to the sound settings?

  7. #7
    Join Date
    Feb 2007
    Beans
    78

    Re: Fix internal mic for use with Skype

    To turn off autoadjust by google talIk plugin:
    cd ~/.config/google-googletalkplugin # get to google chat's directory
    cp -p options options.bak # make a backup before changing stuff..
    gedit options # edit the config file
    If you don't have file named options in this folder create one..
    Add following line to this file..
    audio-flags=1
    This seems to work for me.

  8. #8
    Join Date
    Jun 2010
    Location
    Kuwait
    Beans
    56
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Fix internal mic for use with Skype

    Thanks, that solved my problem on Acer netbook

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •