Results 1 to 10 of 103

Thread: Canon all-in-one laser printers

Threaded View

  1. #31
    Join Date
    Dec 2007
    Beans
    7

    Smile Re: Canon all-in-one laser printers

    So, after I read all thread and tried different suggested solutions (thank you, guys!) I finally managed to make my Canon I-Sensys MF4140 to work in my Ubuntu 12.04 64-Bit version.

    My steps:

    1. Downloaded the UFR II Printer Driver for Linux Version 2.50 from Canon U.S.A.
    2. Extracted from archive and converted the 64-Bit RPM drivers to DEB:
    Code:
    sudo alien cndrvcups-ufr2-us-2.50-1.x86_64.rpm --scripts
    sudo alien cndrvcups-common-2.50-1.x86_64.rpm --scripts
    3. Renamed existing '/usr/lib64' to '/usr/lib64.old'
    Code:
    sudo mv /usr/lib64 /usr/lib64.old
    4. Created the symbolic link '/usr/lib64' to '/usr/lib':
    Code:
    sudo ln -s /usr/lib /usr/lib64
    5. Installed dependencies (I do not know if I realy needed all of them ):
    Code:
    sudo apt-get install libc6-i386 ia32-libs lib32z1
    6. Installed the .deb packages:
    Code:
    sudo dpkg -i cndrvcups-common_2.50-2_amd64.deb
    sudo dpkg -i cndrvcups-ufr2-us_2.50-2_amd64.deb
    7. Plugged the printer and it worked!
    (I printed a test page and a page from a PDF document).
    Last edited by Iurie; December 4th, 2012 at 11:13 AM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •