Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Vuscan 9 x64 and Unity problem

  1. #11
    Join Date
    Jul 2007
    Beans
    30

    Re: Vuscan 9 x64 and Unity problem

    OK, here is another workaround, although not very good.

    Log in to an Ubuntu Classic session. Open the Compiz Configuration Settings Manager (CCSM) and select the Window Decoration plugin. Replace the "Command", which defaults to '/usr/bin/compiz-decorator' with '/usr/bin/metacity --replace'

    Close the CCSM, log out then log in again to the Ubuntu Classic session. Vuescan 64bit (now at version 9.0.31) should start normally. This is now pretty much the same as the Maverick (Ubu 10.10) desktop.

    I think the only way to actually be able to use Vuescan version 9.x.xx in the full blown Unity interface of Ubu 11.04 would be to put together a launch script that turned Compiz Window Decorations OFF, launched Vuescan, then turned Compiz Window Decorations ON again. This does work manually. The script would probably have to pass the appropriate messages to Compiz via the Dbus, but I don't know how to do this in a script.
    Last edited by myoldhouse; April 14th, 2011 at 01:13 AM. Reason: fix typos

  2. #12
    Join Date
    Jul 2008
    Location
    Maryland
    Beans
    1,536
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Vuscan 9 x64 and Unity problem

    I can start Vuescan nromally in natty without proprietary drivers. I need a workaround in both natty installs with proprietary drivers (ATI, nVidia).
    12.10 Quantal w/grub2/Mint13 installed on raid0, Gigabyte AMD MB, AMD 64x4 CPUs at 3.2GHz, 16 GB ram, HD7770 ATI video, dual boot win7 on 64gb ssd and win8 on 1Tb SATA raid. 13.04 installed on raid0 and ssd

  3. #13
    Join Date
    Apr 2008
    Location
    Southern California, USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Vuscan 9 x64 and Unity problem

    VueScan x64 9.0.28 works on Kubuntu Natty. So its obviously a Unity/Compiz issue. Wanted to make sure its not distro related.
    boot_info_script | AMD64 Athlon X2 Dual-Core - nVidia Geforce 6150 SE - 4GB DDR3

  4. #14
    Join Date
    Jul 2007
    Beans
    30

    Re: Vuscan 9 x64 and Unity problem

    Thanks for that confirmation. I'm going to wait for the final release of Natty before I file a bug on this or raise the issue with the author Ed Hamrick.


    I am beginning to think that Vuescan is the culprit. Earlier 32 bit versions of Vuescan (v 8.6.66 and v 8.5.41) from the Vuescan website work OK in Unity with no window decoration or start up issues. Vuescan 9.0.xx (32bit) throws out all kinds of errors and Vuescan 9.0.xx (64bit) has the window decoration problem.

    Update - November 7, 2011:

    Vuescan 9.0.61 x64 (released Nov 3, 2011) finally fixed this bug with Epson scanners, Unity, Compiz and window decorations on x64 systems. It was a problem with Vuescan not Unity as far as I can tell.
    Last edited by myoldhouse; November 9th, 2011 at 02:09 AM. Reason: Mark as solved

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •