Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Youtube video appears behind any pure black pixels on screen

  1. #11
    Join Date
    Apr 2011
    Beans
    8

    Re: Youtube video appears behind any pure black pixels on screen

    There is no problem with operating system
    adobe flash player is not working well with ubuntu now
    try using other flash players instead of adobe
    that will solve the problem

  2. #12
    Join Date
    Dec 2008
    Location
    Belgium
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Youtube video appears behind any pure black pixels on screen

    Quote Originally Posted by trehanabhinav View Post
    There is no problem with operating system
    adobe flash player is not working well with ubuntu now
    try using other flash players instead of adobe
    that will solve the problem
    What do you suggest then? I need hardware acceleration

    Just found out you can watch youtube in XBMC... works flawless most of the time...
    Last edited by WannabeFantasma; April 29th, 2011 at 12:23 PM.
    Ah Media PC's with Ubuntu rock!

  3. #13
    Join Date
    Jun 2008
    Location
    Gipuzkoa, Spain
    Beans
    732
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Re: Youtube video appears behind any pure black pixels on screen

    I think I have solved this problem but I am not sure how. I have tried the following (some restarts, firefox and session, along the way):

    Disable shockwave flash in firefox (I am using firefox4) in Tools -> Add-ons -> Plugins.

    Add suport to html5 in youtube via http://www.youtube.com/html5

    However, I prefer flash (because of jack audio support which afaik html5 does not have yet), so I disabled html5 and enable shockwave flash again and I am not having this problem anymore (fingers crossed).

    Cheers, Pablo

  4. #14
    Join Date
    Dec 2008
    Location
    Belgium
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Youtube video appears behind any pure black pixels on screen

    seems like 11.04 doesn't have this bug anymore... what has changed from 10.04? using the Same flash version and the same firefox (4)....

    Gonna see if the bug still exists in 10.04... If yes that would be quite sad
    Last edited by WannabeFantasma; May 3rd, 2011 at 10:44 PM.
    Ah Media PC's with Ubuntu rock!

  5. #15
    Join Date
    Mar 2007
    Beans
    1

    Re: Youtube video appears behind any pure black pixels on screen

    I was having this issue on 10.10 for the past week. The problem would occur with any Flash videos.

    The way that I ended up fixing it was by upgrading my nvidia driver. I downloaded the latest driver (as of this time the file is: NVIDIA-Linux-x86_64-270.41.06.run). After rebooting I have no trouble.

  6. #16
    Join Date
    Oct 2007
    Beans
    668
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Youtube video appears behind any pure black pixels on screen

    Quote Originally Posted by strfireblue View Post
    I was having this issue on 10.10 for the past week. The problem would occur with any Flash videos.

    The way that I ended up fixing it was by upgrading my nvidia driver. I downloaded the latest driver (as of this time the file is: NVIDIA-Linux-x86_64-270.41.06.run). After rebooting I have no trouble.
    That did not fix the problem for me. I have Flash version 10.3.181.14, the same Nvidia drivers as you except for being 32-bit (since I run Ubuntu 10.04 32-bit), and Flash videos still show through any solid black parts of the screen "in front of" the Flash video.

    This happens whether I'm viewing Flash in Firefox or Chrome.

    The problem does NOT happen when I watch a Flash video (*.flv) in VLC Media Player.

    I "fixed" the problem by turning off Hardware Acceleration in the Flash plugin settings.

    Not sure how much hardware accel matters. It doesn't seem to help any - CPU use is still excessive (>50%) when playing a 720 HD video, regardless of whether "hardware acceleration" is on or off. So turning it off is no big deal.

    Even though it's sorta-fixed for now, I am tired of the broken junk that is Adobe's Linux browser implementation of Flash. First the Linux version of Flash uses too much CPU, then it crashes a lot, and now this. Is there an alternate plugin I could use?
    Last edited by Objekt; May 20th, 2011 at 06:47 AM.
    Samsung Series 3 15.6" notebook (NP300-V5A-A02US)

  7. #17
    Join Date
    Oct 2009
    Beans
    55
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Youtube video appears behind any pure black pixels on screen

    I have the same problem (on Ubuntu 11.10) except it's pure white pixels instead of pure black pixels and it happens on any flash file, and only if firefox is minimized (if I drag a window with pure white overtop of the firefox window, it will cover up the flash animation, but if I then minimize firefox, it appears overtop of the white window). I'm using the NVIDIA drivers on version-current. Exact same behaviour under post-release updates.

    How is it even POSSIBLE to make it do that accidentally? They must be using some completely ridiculous hack to display video that works "good enough". I get the feeling that when Adobe bought out Macromedia, they had no clue how Flash works, and still don't. At least flash video is slowly dying out to HTML 5. *sigh*
    Last edited by Exüberance; April 17th, 2012 at 09:47 PM.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •