Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: 11.04 dmraid does not activate ufter upgrade

  1. #1
    Join Date
    Apr 2011
    Beans
    5

    11.04 dmraid does not activate ufter upgrade

    After uprading to 11.04 b1 i cannot activate my softraid. It still works if i boot 10.10 live CD


    root@bisley:/home/goblin# dmraid -ay
    RAID set "pdc_dhifadccdc" was not activated
    root@bisley:/home/goblin# dmraid -s
    *** Set
    name : pdc_dhifadccdc
    size : 8201755392
    stride : 128
    type : stripe
    status : ok
    subsets: 0
    devs : 2
    spares : 0
    root@bisley:/home/goblin# dmraid -r
    /dev/sdc: pdc, "pdc_dhifadccdc", stripe, ok, 4100877696 sectors, data@ 0
    /dev/sdb: pdc, "pdc_dhifadccdc", stripe, ok, 4100877696 sectors, data@ 0
    root@bisley:/home/goblin#

    root@bisley:/home/goblin# dmraid -V
    dmraid version: 1.0.0.rc16 (2009.09.16) shared
    dmraid library version: 1.0.0.rc16 (2009.09.16)
    device-mapper version: 4.19.1

    any input would be helpfull.

  2. #2
    Join Date
    Jul 2008
    Location
    Maryland
    Beans
    1,536
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: 11.04 dmraid does not activate ufter upgrade

    I've reported it as a bug but there is no sign yet that anything will be done about it.

    I believe that what you will find is that dmraid is uninstalled in the upgrade. I resurrected mine from a live cd by mounting the partition I installed to to /mnt and using chroot to install dmraid. Everything works fine now but that shouldn't have been necessary.
    12.10 Quantal w/grub2/Mint13 installed on raid0, Gigabyte AMD MB, AMD 64x4 CPUs at 3.2GHz, 16 GB ram, HD7770 ATI video, dual boot win7 on 64gb ssd and win8 on 1Tb SATA raid. 13.04 installed on raid0 and ssd

  3. #3
    Join Date
    Dec 2009
    Beans
    13

    Re: 11.04 dmraid does not activate ufter upgrade

    I can't believe this is happening again. I had exactly the same problem when upgrading to 10.10 and now it seems it does it when upgrading to 11.04.

    There is no way a normal user would be able to sort this out. This is the kind of thing that gets a distro a bad rep.

    Come on Ubuntu, sort it out!

  4. #4
    Join Date
    Jul 2008
    Location
    Maryland
    Beans
    1,536
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: 11.04 dmraid does not activate ufter upgrade

    Come on Ubuntu, sort it out!
    I couldn't agree more. At least the 11.04 b2 seems to install properly to a raid - so things are fine for the time being!
    12.10 Quantal w/grub2/Mint13 installed on raid0, Gigabyte AMD MB, AMD 64x4 CPUs at 3.2GHz, 16 GB ram, HD7770 ATI video, dual boot win7 on 64gb ssd and win8 on 1Tb SATA raid. 13.04 installed on raid0 and ssd

  5. #5
    Join Date
    Apr 2008
    Beans
    1

    Re: 11.04 dmraid does not activate ufter upgrade

    I'm having the same problem with an upgrade from 10.10 I performed today ( 4/23).

    dmraid -r
    /dev/sdd: pdc, "pdc_igjghfjc", mirror, ok, 8201865344 sectors, data@ 0
    /dev/sdc: pdc, "pdc_igjghfjc", mirror, ok, 8201865344 sectors, data@ 0


    dmraid -s -s
    *** Set
    name : pdc_igjghfjc
    size : 8201865344
    stride : 128
    type : mirror
    status : ok
    subsets: 0
    devs : 2
    spares : 0

    dmraid -a yes
    RAID set "pdc_igjghfjc" was not activated


    My old UUID for the disk disappeared in the upgrade any ideas or bug numbers I can track?

    - thanks

  6. #6
    Join Date
    Jan 2006
    Location
    Toronto
    Beans
    70
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: 11.04 dmraid does not activate ufter upgrade

    I'm in the same boat, except pretty much everything (no sound, didn't have permission to mount disks) got fubar'd by the upgrade. I'm forced to backup everything and reinstall.

    Perhaps there is something we have in common, I've noticed that we all have Promise fakeRAID controllers (mine via AMD). The changelog lists some changes that were made to the Promise code, so perhaps something was unintentionally messed up.

    http://changelogs.ubuntu.com/changel...ntu3/changelog

    Edit: For what it's worth, here's the output of dmraid

    $ sudo dmraid -s
    *** Set
    name : pdc_bhgbgdbai
    size : 8201755392
    stride : 128
    type : stripe
    status : ok
    subsets: 0
    devs : 2
    spares : 0

    $ sudo dmraid -r
    /dev/sdb: pdc, "pdc_bhgbgdbai", stripe, ok, 4100877696 sectors, data@ 0
    /dev/sda: pdc, "pdc_bhgbgdbai", stripe, ok, 4100877696 sectors, data@ 0
    Last edited by Rexbron!; April 26th, 2011 at 06:58 AM.

  7. #7
    Join Date
    Jan 2006
    Location
    Toronto
    Beans
    70
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: 11.04 dmraid does not activate ufter upgrade

    Ok, so I booted up a 10.10 livecd, no problems activating the set so the problem is 100% either dmraid's or the kernels.

    I'm going to bite the bullet and back everything up and switch to software raid.

  8. #8
    Join Date
    Jul 2008
    Location
    Maryland
    Beans
    1,536
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: 11.04 dmraid does not activate ufter upgrade

    The problem as you stated it occurred because dmraid wasn't installed. The problem seem to be fixed with updates. Meanwhile I have worked around it by a chroot install of dmraid to a new unresposive Ubuntu install.

    The problem shouldn't occur with an install of the latest 11.04 image.
    12.10 Quantal w/grub2/Mint13 installed on raid0, Gigabyte AMD MB, AMD 64x4 CPUs at 3.2GHz, 16 GB ram, HD7770 ATI video, dual boot win7 on 64gb ssd and win8 on 1Tb SATA raid. 13.04 installed on raid0 and ssd

  9. #9
    Join Date
    Jan 2006
    Location
    Toronto
    Beans
    70
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: 11.04 dmraid does not activate ufter upgrade


  10. #10
    Join Date
    Apr 2011
    Beans
    5

    Unhappy Re: 11.04 dmraid does not activate ufter upgrade

    Booted up with 11.04 final release CD today and still no joy. Was hoping they would have it sorted for the final release. I am very disappointed.

    Running suse 11.4 till a practical fix has been made. Not terribly fond of suse

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •