Results 1 to 5 of 5

Thread: Natty Grub2 Problems

  1. #1
    Join Date
    Nov 2009
    Location
    Lake Wales Florida
    Beans
    607
    Distro
    Ubuntu 12.04 Precise Pangolin

    Natty Grub2 Problems

    I wonder if anyone else is having this problem. The grub2 installed with Natty is hit and miss on seeing and mounting other partitions and drives. I run 10.10 on sda1 and natty on sdb1.
    I let Natty reinstall grub2 and half of the time neither operating system would see or mount drives set up in fstab. By reinstalling grub2 from the 10.10 live CD and updating grub both systems now boot normally and recognize all partitions.
    AMD FX-6200 - MSI 4.1Ghz- Nvidia GTX550Ti -12/GIG - 60GB-SSD/500 Sata - 12.04 - Gnome 3

  2. #2
    Join Date
    Feb 2010
    Location
    /UK/Cambridge
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Natty Grub2 Problems

    The early bird gets the worm. . . But the second mouse gets the cheese, and the early worm gets eaten.
    Unwarranted Self Promotion

  3. #3
    Join Date
    Apr 2006
    Location
    New Hampshire, U.S.A.
    Beans
    2,448
    Distro
    Ubuntu Development Release

    Wink Re: Natty Grub2 Problems

    Quote Originally Posted by Bobhuber View Post
    I wonder if anyone else is having this problem. The grub2 installed with Natty is hit and miss on seeing and mounting other partitions and drives. I run 10.10 on sda1 and natty on sdb1.
    I let Natty reinstall grub2 and half of the time neither operating system would see or mount drives set up in fstab. By reinstalling grub2 from the 10.10 live CD and updating grub both systems now boot normally and recognize all partitions.
    That's why I've got a Maverick or Lucid partition on each of my test systems.

    Once or twice Natty Grub 1.99 made sense, but more frequently it will say I've got a Lucid on /dev/sda6, a Maverick on /dev/sda6, and a Natty also on /dev/sda6. None of which will boot.

    All three on the same partition?!

    So I do my best to find some other Ubuntu that will boot, besides Natty, and then run update-grub and grub-install.

    Jerry

  4. #4
    Join Date
    Nov 2009
    Location
    Lake Wales Florida
    Beans
    607
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Natty Grub2 Problems

    Quote Originally Posted by Helkaluin View Post
    No while that bugs matches the problem exactly I'm using etx4 on 10.10 and 11.04
    AMD FX-6200 - MSI 4.1Ghz- Nvidia GTX550Ti -12/GIG - 60GB-SSD/500 Sata - 12.04 - Gnome 3

  5. #5
    Join Date
    Feb 2010
    Location
    /UK/Cambridge
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Natty Grub2 Problems

    Fire another bug report then? Remember to include the details.
    The early bird gets the worm. . . But the second mouse gets the cheese, and the early worm gets eaten.
    Unwarranted Self Promotion

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •