Results 1 to 7 of 7

Thread: Toshiba fan control

  1. #1
    Join Date
    Jan 2009
    Beans
    26
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Toshiba fan control

    Just picked up a Toshiba Satellite L675D
    dual booting with WUBI.

    I had to turn ACPI=OFF to get the thing to boot

    But....

    There seems to be no fan control, and

    The machine will not shut off when using software shutdown.

    it just tells me "system halted"

    at that point the pwr button will shut it off.

    I have tried the ACPI modifiers that I know and sometimes it will get to the line
    [ 0.365797 NET:Registered protocal family 1

    I everything else SEEMS to be working ok I think, but I need to know if anyone can tell me what else is affected, and if there is a way to get the fan control back with some other ACPI setting??/

    Thanks so much

  2. #2
    Join Date
    Jun 2007
    Beans
    11,525

    Re: Toshiba fan control

    No ACPI = no fan. What happens when you try to boot with ACPI?
    Do you have the latest BIOS? http://www.csd.toshiba.com/cgi-bin/t...ily=1073768663

  3. #3
    Join Date
    Jan 2009
    Beans
    26
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Toshiba fan control

    When I try to boot with ACPI It just goes to black screen flashing cursor.

    I will need to figure out the bios, I am not sure it is the latest

    Thanks

  4. #4
    Join Date
    Nov 2009
    Location
    North Vancouver
    Beans
    Hidden!
    Distro
    Edubuntu 14.04 Trusty Tahr

    Re: Toshiba fan control

    Try acpi=copy_dsdt (as well as the bios)

    https://bugs.launchpad.net/ubuntu/+s...ty/+bug/647358

  5. #5
    Join Date
    Jan 2009
    Beans
    26
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Toshiba fan control

    thanks for the replies so far, but still no joy.

    I have updated the BIOS, and I have perused the logs, and I have found that the next line after it hangs (after the "protocal family 1") is to boot the video.

    The video seems to work ok when I run ACPI=off, but when I use =force, or =ht or =copy_dsdt it gets to that point and hangs.

    The video driver that I am using was scanned by the machine and is the ATI/AMD proprietary FGLRX graphics driver

    Thanks again for any suggestions.

  6. #6
    Join Date
    Feb 2010
    Beans
    21

    Re: Toshiba fan control

    This was almost doing my head in.
    Thought about having to run Windows or sell my new laptop.
    Same fan problems with Fedora, PClinuxOS
    Here is what works for me. Toshiba L500. 64bit Ubuntu 10.04

    first. sudo apt-get install sensors-applet
    next. sudo sensors-detect

    next. answer yes to everything.

    exit then restart computer.

    next. sudo gedit /etc/default/grub and then change

    GRUB_CMLINE_LINUX_DEFAULT="quiet splash"

    to read

    ..."quiet splash acpi_osi="

    next. sudo update-grub to update /boot/grub/grub.cfg

    exit then restart computer.
    "Add the following to your /etc/modules: (sudo gedit /etc/modules)
    battery
    ac
    thermal
    processor
    acpi-cpufreq
    cpufreq-userspace
    Restart after adding."

  7. #7
    Join Date
    Jan 2009
    Beans
    26
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Toshiba fan control

    Thanks MJ,

    everything seems to go well until changing away from acpi=off

    soo as that changes, the machine hangs on trying to boot

    regards,
    Kurt

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •