Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: How do I enable lubuntu hotkeys?

  1. #1
    Join Date
    Dec 2010
    Beans
    Hidden!

    How do I enable lubuntu hotkeys?

    I just switched from Ubuntu to lubuntu a few minutes ago. When I had Ubuntu, if I wanted to increase/decrease my laptop volume, all I had to do was simultaneously press the Fn (function) button on my laptop plus the up/down volume key. Now when I do that nothing happens. So what do I do to enable these hotkeys

  2. #2
    Join Date
    Aug 2011
    Beans
    14

    Re: How do I enable lubuntu hotkeys?

    This thread provided some help for me. It doesn't seem to be a one- or two-step solution, though. Perhaps there's a newer, easier method available in 11.10, however...

    -Trevor

  3. #3
    Join Date
    Oct 2009
    Location
    StartUbuntu
    Beans
    4,241
    Distro
    Ubuntu Gnome Development Release

  4. #4
    Join Date
    Feb 2010
    Beans
    29
    Distro
    Ubuntu

    Re: How do I enable lubuntu hotkeys?

    I've been struggling with this and I'm not sure what I'm getting wrong (sorry! I've checked the One Stop Thread, here http://ubuntuforums.org/showthread.php?t=1422861 and here http://ubuntuforums.org/showthread.php?t=1867907)

    I've tried editing both /home/<user>/.config/openbox/lubuntu-rc.xml and /home/<user>/.config/openbox/lxde-rc.xml to get the volume buttons to work

    They both currently read:

    Code:
    <keybind key="XF86AudioRaiseVolume">
          <action name="Execute">
              <command>amixer -q sset Master 3%+</command>
          </action>
        </keybind>
    
        <keybind key="XF86AudioLowerVolume">
          <action name="Execute">
             <command>amixer -q sset Master 3%-</command>
          </action>
        </keybind>
    
        <keybind key="XF86AudioMute">
          <action name="Execute">
              <command>amixer -q sset Master toggle</command>
          </action>
        </keybind>
    I've tried commenting these sections out and also tried replacing 'Master' with 'PCM' in lubuntu-rc.xml, re-starting after every change - with no success

    To make sure that it wasn't just that the settings weren't taking effect I also tried running 'openbox --configure' but that produced
    Code:
    Openbox-Message: Invalid command line argument "--configure"
    Any help, greatly appreciated.

  5. #5
    Join Date
    Jul 2011
    Location
    Lubuntu One Stop Group
    Beans
    Hidden!
    Distro
    Lubuntu

    Exclamation Re: How do I enable lubuntu hotkeys?

    when you login, do you login with LXDE as your session, Lubuntu, or what?
    Last week I was running the live CD (well usb) on my laptop, those keys were working outta the box

  6. #6
    Join Date
    Nov 2008
    Location
    Sussex, England
    Beans
    871
    Distro
    Lubuntu

    Smile Re: How do I enable lubuntu hotkeys?

    Quote Originally Posted by muppet317 View Post
    ...I've tried editing both /home/<user>/.config/openbox/lubuntu-rc.xml and....
    I don't think the problem is with lubuntu-rc.xml because this is a standard file using standard key descriptors.

    Assuming that amixer is OK then this is a hardware specific problem, probably due to they way the keys are mapped or identified at a lower level in the system. If you trawl through the packages in Synaptic Package Manager you will find some that relate to laptops, and its possible that the solution is in one of these.

  7. #7
    Join Date
    Jul 2011
    Location
    Lubuntu One Stop Group
    Beans
    Hidden!
    Distro
    Lubuntu

    Re: How do I enable lubuntu hotkeys?

    stupid question, but is the mixer working otherwise?

  8. #8
    Join Date
    Feb 2010
    Beans
    29
    Distro
    Ubuntu

    Re: How do I enable lubuntu hotkeys?

    Not a stupid question! Yes, otherwise the mixer works fine.

    I login using lubuntu, though I upgraded from regular ubuntu (gnome) simply by adding lubuntu-dektop and lubuntu-core through synaptic. the volume keys work fine when I login into ubuntu (gnome) just not lubuntu. could it be because I've still got gnome on my system?

    Other function keys, such as brightness, work fine - its just the volume keys that aren't working.

    I'm running lubuntu on an asus eeepc (if that makes any difference)

  9. #9
    Join Date
    Jul 2011
    Location
    Lubuntu One Stop Group
    Beans
    Hidden!
    Distro
    Lubuntu

    Re: How do I enable lubuntu hotkeys?

    do you have the crap at the top of the xml file
    this stuff:
    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <!-- Do not edit this file, it will be overwritten on install.
            Copy the file to $HOME/.config/openbox/ instead. -->
    <openbox_config xmlns="http://openbox.org/3.4/rc">
    I've noticed that it's easy to mess up editing the lubuntu-rc.xml file. In particular, it expects a tag heirarchy, and you can't just paste in code like you can with other configuration files.

  10. #10
    Join Date
    Feb 2010
    Beans
    29
    Distro
    Ubuntu

    Re: How do I enable lubuntu hotkeys?

    After having a few minor issues like this, I tried to remove ubuntu from my system (using the code from here: http://psychocats.net/ubuntu/purelxde ) so that I would have clean lubuntu system to work from. After running the code my computer failed to restart, only reaching the initial lubuntu loading screen, and never getting to the login page.

    I'm now trying out a clean install of xubuntu, so no longer have the lubuntu volume keys issue...

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •