Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: USB boot via GRUB2...but weirder

  1. #11
    Join Date
    Feb 2011
    Beans
    36
    Distro
    Ubuntu 12.04 Precise Pangolin

    Post Re: Yay! A reply!

    Quote Originally Posted by drs305 View Post
    Yes. But how dare you use proper terminology in a support forum!
    Just to clarify...haha!

    Quote Originally Posted by drs305 View Post
    While I build a menuentry in a custom menu, the same commands could be issued from the terminal I expect.
    That's exactly what I did...via the GRUB2 prompt, anyway. I simply copied your commands into a plain text file in Windows, and then used the cat command to view the copied commands, which I then proceeded to type in.

    Quote Originally Posted by drs305 View Post
    ...the installer complains in the steps following the partition designation if /isodevice isn't unmounted. Unmounting it doesn't appear to affect the CD's installer adversely, but it won't continue as long as /isodevice is mounted.
    I guess I'll try both, with and without unmounting the /isodevice point. Just to be sure, would you unmount it before even starting the installer program? Or as you said, after specifying the installation partition?

    Also, I actually haven't tried any of these soultions on my system yet...schoolwork's a pain, and I'm in the UK. Let's hope Sunday's events will be a victory!

  2. #12
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Yay! A reply!

    Quote Originally Posted by NJPinator View Post
    I guess I'll try both, with and without unmounting the /isodevice point. Just to be sure, would you unmount it before even starting the installer program? Or as you said, after specifying the installation partition?
    I believe I have unmounted it just after the installer starts (you have to boot 'Try It' so you can get to a terminal to unmount it later. Then start the installer from the Desktop with the terminal available. I think I've even waited until the installer complained about not being able to unmount everything, at which time I unmounted it and then selected the 'retry' option.
    GRUB2

    Retired.

  3. #13
    Join Date
    Feb 2011
    Beans
    36
    Distro
    Ubuntu 12.04 Precise Pangolin

    Arrow My good, bad, then ugly results

    I followed the instructions in your "ISO Install" tutorial and got a very similar outcome...here's what happened:

    I booted the ISO as told in your "ISO Install" tutorial, omitting the set of "set prefix=..." commands as I was at a working grub prompt (also, the prefix variable was already set to (hd0,3)/boot/grub , which is where my GRUB2 modules are).

    In addition, I added the "nomodeset" setting to the end of the "linux...vmlinuz..." line, as you had suggested would resolve my "video problem". The "nomodeset" option was not required when booting from a CD, and only made a minor difference when following your boot instructions!

    Lubuntu had booted exceptionally fast, and it's desktop was available right away. The only issue was my computer not having much RAM (only 128 MB, this'll be sorted soon -- I told you it was an old PC!). I got an "out of RAM" error message on tty1 (which I accessed by pressing CTRL+ALT+F1), followed by it killing processes to free memory, all to no avail. My Lubuntu dekstop had soon become nothing but a wallpaper on a screen, and I had to power down my machine. It's a shame I don't have more RAM, but I have a question now...!

    Would it be possible to get Lubuntu to access a Linux Swap partition before getting to booting LXDE? (i.e. predefined in a file or something / without using a program like GParted, maybe the terminal will work. It did for a while on the tty's.) My swap partition is located at /dev/sda6 (to GRUB it's (hd0,6) ).

    P.S. I know it's been a while (actuallly, a week), but I simply haven't had time to try things out.

  4. #14
    Join Date
    Feb 2011
    Beans
    36
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: USB boot via GRUB2...but weirder

    It's been a while (over a year now), but I thought I'd give this thread an update and mark it as "SOLVED". I ended up getting some more RAM for the computer, and installed Windows XP on it, as Lubuntu 12.04 failed to work at a decent speed.

  5. #15
    Join Date
    Aug 2011
    Beans
    1

    Re: USB boot via GRUB2...but weirder (solution)

    This solution is for the case where you have a usable grub2 installaiton on your internal hard drive, but are unable to see an external USB drive which has Linux installed on it.

    the short answer is:

    insmod usbms
    insmod ehci
    insmod uhci
    insmod ohci

    Only one of the *hci line is needed (usually ehci), but older machines may need either uhci or ohci Inserting all 3 works fine.

    Those lines should be added to either grub.cfg or custom.cfg (I recommend the latter) in the /boot/grub/ folder on the non-USB drive.

    _______________

    In my case, I was able to solve the problem (and boot Linux off of the USB drive in this way).
    First of all, I installed Linux on the USB drive. I specified installing grub on the USB drive (sdb, in this case). That way, it should be usable for (other) systems that can boot off of the USB drive via the BIOS.

    Then I booted the Linux on my hard drive, mounted the USB root partition (clicked on it in the nautilus sidebar) and did:
    update-grub2
    This placed the menu entries in the bootable grub menu.

    (( If you only have grub and it's modules installed on a minimal partition on your local hard drive, you can get a similar result by booting off of a live CD , mounting the drives and running grub-mkconfig:

    mount /dev/sda5 /mnt/localHD
    mount /dev/sdb1 /mnt/usbHD
    grub-mkconfig -o /mnt/localHD/boot/grub/grub.cfg

    Change the partitions to suit your system setup, of course.
    ))


    testing: I then rebooted to the grub menu
    in the grub command line (ctrl-C) , I tried:
    insmod usbms
    insmod ehci
    ls
    (at this point the usb drive started showing up).
    then I hit 'esc' to go back to the menu, and chose one of the USB linux options.

    Final solution:
    I edited /mnt/localHD/boot/grub/custom.cfg (which is included at the end of grub.cfg in Ubuntu) and added the following lines:
    insmod usbms
    insmod ehci

    At that point, I could boot the usb partitions from grub without any extra work.
    Last edited by darkonc; February 17th, 2013 at 09:07 AM. Reason: typos

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •