Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: xvidcap audio does not work

  1. #1
    Join Date
    Mar 2009
    Beans
    30

    xvidcap audio does not work

    Hello every one,
    after very very long time searching for good screen recorder I found xvidcap and I tried it. It works fine except it does not record sound.

    i issued the command xvidcap --audio yes , I get this message

    Error accessing sound input from /dev/dsp
    Sound disabled!

    any ideas ??

  2. #2
    Join Date
    Mar 2009
    Beans
    30

    Re: xvidcap audio does not work

    First time for me to wait all this time.

    has any one have a solution ???

  3. #3
    Join Date
    Mar 2011
    Beans
    70

    Re: xvidcap audio does not work

    I have the same problem. I've tried xvidcap from months ago in different distros, with different options, ... always withous success with the sound.

    The last unsuccessful ones I've tried:

    Last edited by vezolmi; March 27th, 2011 at 09:13 PM.

  4. #4
    Join Date
    Mar 2011
    Beans
    70

    Re: xvidcap audio does not work

    I've got the solution!!!!: http://ubuntu-cosillas.blogspot.com/...torio-una.html :

    1. Uninstall xvidcap in Synaptic
    2. Install xvidcap from http://sourceforge.net/projects/xvid...6.deb/download
    3. Lock the installed version in Synaptic
    4. Install pavucontrol in Synaptic (Needed in Ubuntu 10.04 but not in Linux Mint 10: already present)
    5. Open the program with padsp xvidcap
    6. Click on the recording button (red circle)
    7. Run pavucontrol, go to the Recording tab and there choose Monitor of Analog Stereo Internal Audio

    Done!!

    To record with sound, the program has always to be run with padsp xvidcap (for example from ALT+F2). To run it always like that from the menu: run alacarte, go to Sound and video, then to XVidCap Screen Capture, Properties and where it says Command put padsp xvidcap.

    [ I would add this: ]

    The stated is to record the system sound, that is, the one coming out of the speakers, that can be of a song or movie of our hard drive or pendrive played by Totem, of a Flash music video of a website played by Firefox, ...

    Nevertheless, sometimes it can be necessary to record the microphone sound, for example if we want to make a videotutorial to explain how a program works. In this case we put xvidcap in recording state, run pavucontrol and in the Recording tab we put Analog Stereo Internal Audio (without "Monitor of" ahead).

    If we only want to record sound (without video) we can run from ALT+F2 gnome-sound-recorder. The first time probably it will be configured to record from the microphone. To record the system sound we run with ALT+F2 gnome-volume-control, go to the Hardware tab and in Profile we put Analog Stereo Output (it's also possible to do this running pavucontrol and using the Configuration tab).

    But when we finish we have to put again Analog Stereo Duplex in the Profile of Hardware of gnome-volume-control (or of Configuration of pavucontrol), so we can still choose the origin of the sound when recording with xvidcap.

    NB: sometimes, to change from Analog Stereo Duplex to Analog Stereo Output it may be necessary to change first to Off, close, open again and then change finally to Analog Stereo Output. The same for the opposite change. If not, the computer may "not notice" that we have applied the change.

  5. #5
    Join Date
    Mar 2011
    Beans
    70

    Re: xvidcap audio does not work

    drdigital: if the solution of my last post works for you (I hope), it would be good that you marked the thread with [SOLVED], to help more people finding the solution. I think you can do it from "Thread Tools" (up-right).

  6. #6
    Join Date
    Mar 2011
    Beans
    70

    Re: xvidcap audio does not work

    I've found a solution for 64 bits. As my Ubuntu is of 32 bits I haven't tested it, but it looks good: http://angel-de-vicente.blogspot.com...untu-1004.html :

    In order to install it in my x86_64 system I just have to use the --force-architecture option to the dpkg -i command.

    user@host:~/Desktop$ sudo dpkg --force-architecture -i xvidcap_1.1.7jaunty_i386.deb

    But when trying to run it I see that there are some i386 libraries missing. In order to easily install them I use the getlibs script.

    user@host:~/Desktop$ padsp xvidcap
    xvidcap: error while loading shared libraries: libtheora.so.0: cannot open shared object file: No such file or directory

    user@host:~/Desktop$ getlibs /usr/bin/xvidcap

    --------------------------------------------

    About getlibs: http://ubuntuforums.org/showthread.php?t=474790

  7. #7
    Join Date
    Mar 2011
    Beans
    70

    another option for gnome-sound-recorder

    Another option, not to have to change once and again between Analog Stereo Duplex and Analog Stereo Output neither limit the sound source for xvidcap, is to leave Analog Stereo Duplex and use also pavucontrol when we want to change the source of the sound for gnome-sound-recorder. Like the stated for padsp xvidcap, to change where we want to record the sound from, we put gnome-sound-recorder recording, open pavucontrol and in the Recording tab we put the desired option. In this case there is no need to use padsp (xvidcap needs it because it was designed for OSS. What padsp does is to connect OSS with PulseAudio, as shown in http://linux.die.net/man/1/padsp).
    Last edited by vezolmi; March 29th, 2011 at 09:07 PM.

  8. #8
    Join Date
    Mar 2011
    Beans
    70

    Re: xvidcap audio does not work

    baumtopf has found a problem in http://ubuntuforums.org/showthread.php?t=1714402 :
    After a video is recorded xvidcap offers to play it immediately. But if you click on the "Play" button the video is not reproduced.

    This problem happens at least in Ubuntu 10.04 because by default it doesn't have installed mplayer, the program that xvidcap uses to play the videos when pressing on the stated button.

    There are 2 solutions:

    a) Install mplayer from Synaptic.
    or
    b) Go to preferences (right clicking on the name of the file, for example test-0000.mpeg, and then cliking on Preferences), then to the Commands tab, and then in the "Multi-Frame Capture Commands"' "Playback Command" replace mplayer with totem and click on OK. Then right click again on the name of the file and click on "Save preferences".

  9. #9
    Join Date
    Nov 2007
    Beans
    1

    Smile Re: xvidcap audio does not work

    Here's simple fix that worked for me.

    In XVidCap edit preferences (by right clicking on test-0000.mpeg button), and under "Multi-Frame" tab change the Audio Settings input device from "/dev/dsp" to "/dev/snd". After clicking OK make sure to save preferences (by right clicking on test-0000.mpeg button again). Restart xvidcap and it should work!

    Cheers!

  10. #10
    Join Date
    Mar 2011
    Beans
    70

    Re: xvidcap audio does not work

    Thanks, burkestar.

    Your proposal doesn't work for me.

    The solution that works for me is explained above, in my second post in this thread.

    Regards

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •