Results 1 to 8 of 8

Thread: Really high ping.

  1. #1
    Join Date
    Jul 2009
    Location
    Somewhere on this planet
    Beans
    31
    Distro
    Ubuntu 11.04 Natty Narwhal

    Really high ping.

    Hi Ubuntu Freaks,

    I had yesterday a irritating problem that my ping to my router was really high. I had some more little problems and I decided to reinstall the whole thing.

    After I reinstall it and i updated the installation, I check the ping again and that was normal like 0.xxx range. Just like my other PCs running Ubuntu. But now I have that high ping again.

    I have a e3000 Linksys router and the laptop i use has a G adapter.



    From the high ping laptop.
    Code:
    jorrit@S1747:~$ ping 192.168.1.1
    PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
    64 bytes from 192.168.1.1: icmp_req=1 ttl=64 time=39.3 ms
    64 bytes from 192.168.1.1: icmp_req=2 ttl=64 time=266 ms
    64 bytes from 192.168.1.1: icmp_req=3 ttl=64 time=186 ms
    64 bytes from 192.168.1.1: icmp_req=4 ttl=64 time=106 ms
    64 bytes from 192.168.1.1: icmp_req=5 ttl=64 time=26.0 ms
    64 bytes from 192.168.1.1: icmp_req=6 ttl=64 time=253 ms
    64 bytes from 192.168.1.1: icmp_req=7 ttl=64 time=173 ms
    64 bytes from 192.168.1.1: icmp_req=8 ttl=64 time=93.0 ms
    64 bytes from 192.168.1.1: icmp_req=9 ttl=64 time=13.3 ms
    64 bytes from 192.168.1.1: icmp_req=10 ttl=64 time=240 ms
    64 bytes from 192.168.1.1: icmp_req=11 ttl=64 time=162 ms
    64 bytes from 192.168.1.1: icmp_req=12 ttl=64 time=79.9 ms
    64 bytes from 192.168.1.1: icmp_req=13 ttl=64 time=307 ms
    64 bytes from 192.168.1.1: icmp_req=14 ttl=64 time=228 ms
    64 bytes from 192.168.1.1: icmp_req=15 ttl=64 time=148 ms
    64 bytes from 192.168.1.1: icmp_req=16 ttl=64 time=68.1 ms
    64 bytes from 192.168.1.1: icmp_req=17 ttl=64 time=398 ms
    64 bytes from 192.168.1.1: icmp_req=18 ttl=64 time=216 ms
    64 bytes from 192.168.1.1: icmp_req=19 ttl=64 time=135 ms
    64 bytes from 192.168.1.1: icmp_req=20 ttl=64 time=55.3 ms
    ^C
    --- 192.168.1.1 ping statistics ---
    20 packets transmitted, 20 received, 0% packet loss, time 19021ms
    rtt min/avg/max/mdev = 13.375/159.889/398.026/100.343 ms
    From a home server that runs wireless and has also a G adapter.
    Code:
    administrator@picard:~$ ping 192.168.1.1
    PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
    64 bytes from 192.168.1.1: icmp_req=1 ttl=64 time=0.586 ms
    64 bytes from 192.168.1.1: icmp_req=2 ttl=64 time=0.573 ms
    64 bytes from 192.168.1.1: icmp_req=3 ttl=64 time=0.583 ms
    64 bytes from 192.168.1.1: icmp_req=4 ttl=64 time=0.828 ms
    64 bytes from 192.168.1.1: icmp_req=5 ttl=64 time=0.729 ms
    64 bytes from 192.168.1.1: icmp_req=6 ttl=64 time=0.691 ms
    64 bytes from 192.168.1.1: icmp_req=7 ttl=64 time=0.590 ms
    64 bytes from 192.168.1.1: icmp_req=8 ttl=64 time=0.586 ms
    64 bytes from 192.168.1.1: icmp_req=9 ttl=64 time=0.587 ms
    64 bytes from 192.168.1.1: icmp_req=10 ttl=64 time=0.587 ms
    64 bytes from 192.168.1.1: icmp_req=11 ttl=64 time=4.16 ms
    64 bytes from 192.168.1.1: icmp_req=12 ttl=64 time=0.577 ms
    64 bytes from 192.168.1.1: icmp_req=13 ttl=64 time=0.484 ms
    64 bytes from 192.168.1.1: icmp_req=14 ttl=64 time=0.588 ms
    64 bytes from 192.168.1.1: icmp_req=15 ttl=64 time=0.569 ms
    64 bytes from 192.168.1.1: icmp_req=16 ttl=64 time=1.16 ms
    64 bytes from 192.168.1.1: icmp_req=17 ttl=64 time=0.596 ms
    64 bytes from 192.168.1.1: icmp_req=18 ttl=64 time=0.582 ms
    64 bytes from 192.168.1.1: icmp_req=19 ttl=64 time=0.578 ms
    64 bytes from 192.168.1.1: icmp_req=20 ttl=64 time=1.38 ms
    ^C
    --- 192.168.1.1 ping statistics ---
    20 packets transmitted, 20 received, 0% packet loss, time 18997ms
    rtt min/avg/max/mdev = 0.484/0.850/4.160/0.789 ms
    “Computers are like bikinis. They save people a lot of guesswork.”
    (Sam Ewing)

    http://ubuntulog.nl

  2. #2
    Join Date
    Jul 2009
    Location
    Somewhere on this planet
    Beans
    31
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Really high ping.

    Update: The problem exist only if I run on battery power. Maybe a power management bug?

    Some other system info:


    Code:
     Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01) 
     Ubuntu 10.10
     2.6.35-22-generic x86_64
    Last edited by gangsterkb; March 22nd, 2011 at 02:22 PM.
    “Computers are like bikinis. They save people a lot of guesswork.”
    (Sam Ewing)

    http://ubuntulog.nl

  3. #3
    Join Date
    Jan 2008
    Beans
    4,326

    Re: Really high ping.

    Perhaps your device has certain power management features when you go on battery such as increasing the amount of time the device is idle. You can run the following command from the terminal to see if power management is enabled or not:
    Code:
    iwconfig
    Look for a line that says something similar to this:
    Code:
    Power Management:off
    You can try this command to disable power management on the device:
    Code:
    sudo iwconfig wlan0 power off
    This will only work once probably until the device state changes (you plug back in/out or reboot). If this works for the fix to be permanent you may have to set up a script of some kind for when your battery is active. (Which is easy but I do not remember how offhand). Also note your device may be wlan1 or etc if you have more than one wireless card.

    Information about the iwconfig command and it's power management function:
    Code:
           power  Used to manipulate power management scheme parameters and mode.
                  To  set  the  period between wake ups, enter period `value'.  To
                  set the timeout  before  going  back  to  sleep,  enter  timeout
                  `value'.  To set the generic level of power saving, enter saving
                  `value'.  You can  also  add  the  min  and  max  modifiers.  By
                  default,  those  values are in seconds, append the suffix m or u
                  to specify values in milliseconds  or  microseconds.  Sometimes,
                  those values are without units (number of beacon periods, dwell,
                  percentage or similar).
                  off and on disable and reenable power management.  Finally,  you
                  may  set the power management mode to all (receive all packets),
                  unicast (receive unicast packets  only,  discard  multicast  and
                  broadcast)  and multicast (receive multicast and broadcast only,
                  discard unicast packets).
    
                  Examples :
                       iwconfig eth0 power period 2
                       iwconfig eth0 power 500m unicast
                       iwconfig eth0 power timeout 300u all
                       iwconfig eth0 power saving 3
                       iwconfig eth0 power off
                       iwconfig eth0 power min period 2 power max period 4
    Last edited by NightwishFan; March 22nd, 2011 at 02:29 PM.

  4. #4
    Join Date
    Jul 2009
    Location
    Somewhere on this planet
    Beans
    31
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Really high ping.

    That did the trick! Many thanks!
    “Computers are like bikinis. They save people a lot of guesswork.”
    (Sam Ewing)

    http://ubuntulog.nl

  5. #5
    Join Date
    Jan 2008
    Beans
    4,326

    Re: Really high ping.

    Glad I could help!

  6. #6
    Join Date
    Oct 2011
    Beans
    33

    Re: Really high ping.

    Same problem here. But:

    Code:
    ---@Home:~$ iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    eth1      IEEE 802.11  Access Point: Not-Associated   
              Link Quality:4  Signal level:194  Noise level:199
              Rx invalid nwid:0  invalid crypt:5  invalid misc:0
    
    ---@Home:~$ sudo iwconfig wlan0 power off
    [sudo] password for ---: 
    Error for wireless request "Set Power Management" (8B2C) :
        SET failed on device wlan0 ; No such device.
    

  7. #7
    Join Date
    May 2009
    Beans
    1

    Post Re: Really high ping.

    Quote Originally Posted by TheNavigator View Post
    Code:
    ---@Home:~$ iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    eth1      IEEE 802.11  Access Point: Not-Associated   
              Link Quality:4  Signal level:194  Noise level:199
              Rx invalid nwid:0  invalid crypt:5  invalid misc:0
    
    ---@Home:~$ sudo iwconfig wlan0 power off
    [sudo] password for ---: 
    Error for wireless request "Set Power Management" (8B2C) :
        SET failed on device wlan0 ; No such device.
    
    Your device seems to be eth1, therefore the command should be

    Code:
    sudo iwconfig eth1 power off

  8. #8
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,446
    Distro
    Ubuntu 12.04 Precise Pangolin

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •