Results 1 to 5 of 5

Thread: Not able to install ZoneMinder

  1. #1
    Join Date
    Jun 2010
    Beans
    65
    Distro
    Kubuntu 10.04 Lucid Lynx

    Not able to install ZoneMinder

    Hi all, I've decided to give ZoneMinder a try with a simple USB webcam that I've had laying around. I installed it in a VMware machine, but I could not get the webcam to "pass trough" to the virtual machine, so figured I would install ZoneMinder on the "regular" server...

    I installed it, got annoyed, and autoremoved it. Now, I'm trying to reinstall it using
    Code:
    apt-get install zoneminder
    and I'm getting a bunch of errors,

    Code:
    Setting up zoneminder (1.24.2-2build3) ...
    Starting ZoneMinder: DBI connect('database=zm;host=localhost','zmuser',...) failed: Unknown database 'zm' at /usr/share/perl5/ZoneMinder/Config.pm line 89
    Can't call method "prepare_cached" on an undefined value at /usr/share/perl5/ZoneMinder/Config.pm line 91.
    BEGIN failed--compilation aborted at /usr/share/perl5/ZoneMinder/Config.pm line 100.
    Compilation failed in require at /usr/share/perl5/ZoneMinder.pm line 33.
    BEGIN failed--compilation aborted at /usr/share/perl5/ZoneMinder.pm line 33.
    Compilation failed in require at /usr/bin/zmpkg.pl line 45.
    BEGIN failed--compilation aborted at /usr/bin/zmpkg.pl line 45.
    failure
    
    invoke-rc.d: initscript zoneminder, action "start" failed.
    dpkg: error processing zoneminder (--configure):
     subprocess installed post-installation script returned error exit status 255
    Processing triggers for libc-bin ...
    ldconfig deferred processing now taking place
    Errors were encountered while processing:
     zoneminder
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    is the output on the screen, I've tried
    Code:
    sudo dpkg --configure -a
    sudo apt-get install -f
    and still get the errors. I'm somewhat new to Linux so any and all help is greatly appreciated.

    Thanks so much,

    -R

    ps this is Ubuntu Server 10.04 - did update and upgrade tonight as well

  2. #2
    Join Date
    Apr 2006
    Beans
    800
    Distro
    Lubuntu 12.04 Precise Pangolin

    Re: Not able to install ZoneMinder

    I can't make any sense of the error output, but did you try to remove the package completetly -- purge and clean -- before reinstalling it? (sudo omitted since you're on server)
    Code:
    apt-get purge zoneminder
    apt-get clean
    apt-get update
    apt-get install zoneminder
    Also the Zoneminder Wiki have install instructions for Ubuntu: http://www.zoneminder.com/wiki/index.php/Ubuntu
    And the Forums seems prestty active also: http://www.zoneminder.com/forums/

    EDIT
    It might have to do something with the database setup. Have you set a password for MySQL server?
    Last edited by lykeion; March 14th, 2011 at 09:42 AM.

  3. #3
    Join Date
    Jun 2010
    Beans
    65
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Not able to install ZoneMinder

    Code:
    apt-get clean
    must have been the trick, I believe that
    Code:
    apt-get purge zoneminder
    is run with
    Code:
    apt-get autoremove zoneminder
    , anyhow, I ran the commands you listed, got more errors on purge, ran clean update, install and success. It's working.... Thanks so much, now will add clean to troubleshooting steps.

    Thanks again,

    -r

  4. #4
    Join Date
    Apr 2006
    Beans
    800
    Distro
    Lubuntu 12.04 Precise Pangolin

    Re: Not able to install ZoneMinder

    No problem, glad it worked out for you.

  5. #5
    Join Date
    Dec 2012
    Beans
    1

    Re: Not able to install ZoneMinder

    Works perfectly. I upgraded from 10 and I was getting very frustrated that the standard install was not working. Tanks.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •