Results 1 to 7 of 7

Thread: CMake can't find GLUT Xi or Xmu

  1. #1
    Join Date
    Aug 2010
    Beans
    97

    CMake can't find GLUT Xi or Xmu

    I'm trying to configure a project with CMake, and set it to find the GLUT package.

    It finds the GLUT library fine, but gives me errors with regards to GLUT Xi and GLUT Xmu:

    Code:
    CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
    Please set them or make sure they are set and tested correctly in the CMake files:
    GLUT_Xi_LIBRARY (ADVANCED)
        linked by target "WindowsTest" in directory /home/me/devl/c++/game/2DGame/src
    GLUT_Xmu_LIBRARY (ADVANCED)
        linked by target "WindowsTest" in directory /home/me/devl/c++/game/2DGame/src
    Can somebody shed some light on this?

  2. #2
    Join Date
    Aug 2010
    Beans
    97

    Re: CMake can't find GLUT Xi or Xmu

    Bamp.

  3. #3
    Join Date
    Jan 2010
    Beans
    1

    Re: CMake can't find GLUT Xi or Xmu

    Just had the same problem, and solved it by installing the corresponding packages

    Code:
    sudo apt-get install libxmu-dev libxi-dev
    Hope it helps!

  4. #4
    Join Date
    Aug 2010
    Beans
    97

    Re: CMake can't find GLUT Xi or Xmu

    Great, thanks!

  5. #5
    Join Date
    Aug 2007
    Location
    India
    Beans
    Hidden!
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: CMake can't find GLUT Xi or Xmu

    Helped me too, thanks!
    Everyone has beauty but not everyone sees it.
    Artha ~ The Open Thesaurus

  6. #6
    Join Date
    Mar 2013
    Beans
    7

    Re: CMake can't find GLUT Xi or Xmu

    It worked.

  7. #7
    Join Date
    Oct 2013
    Beans
    1

    Re: CMake can't find GLUT Xi or Xmu

    Work fine, thanks!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •