Results 1 to 7 of 7

Thread: How to set Radeon to low powerstate if aticonfig doesn't recognize --set-powerstate ?

Threaded View

  1. #1
    Join Date
    Jul 2009
    Location
    The Netherlands
    Beans
    30
    Distro
    Ubuntu 10.10 Maverick Meerkat

    How to set Radeon to low powerstate if aticonfig doesn't recognize --set-powerstate ?

    Hello Forum,

    Short description:
    I am unable to set my ATI Radeon HD 4870 X2 in a lower voltage mode. (fglrx & aticonfig)
    Default clockspeeds are way too high --> card gets hot --> gpu fanspeed too high --> unnecessary/annoying noise !

    More specifically, I would like to lower both the GPU clockspeed (to the min. 507Mhz) and the Memory clockspeed (to the min. 500Mhz) to reduce the unnecessary heat the videocard produces, so the GPU fan can be switched off -- my ubuntu boot will be as quiet as in Windows.

    Per default, my videocard seems to run with high clockspeeds, the so-called "3D mode": the GPU at 750Mhz, Mem at 900 Mhz.
    (I read somewhere this might have to do with Compiz and/or X telling the driver to do so, but I don't believe a few destop effects require these heavy settings, so perhaps someone knows if I can add an exception somewhere?)

    I am using the ATI/AMD propietary FGLRX graphics driver (version 2:8.780-0ubuntu2 according to synaptic)
    Installed using "Additional Drivers" under System>Adminstration in Ubuntu 10.10 Maverick Meerkat 64-bit.

    When I follow the instruction posted over the past years (and stated on http://wiki.cchtml.com/index.php/Con...ct_immediately) I get errors:
    Code:
    $ sudo aticonfig --list-powerstates 
    aticonfig: unrecognized option '--list-powerstates' 
    aticonfig: parsing the command-line failed. 
    
    $ sudo aticonfig --set-powerstate=1 
    aticonfig: unrecognized option '--set-powerstate=1' 
    aticonfig: parsing the command-line failed.
    I noticed that aticonfig --help has some reference to --set-powerstate, but it almost seems like a "leftover" from a previous version of the help. (also mentioned in >post<)

    It almost seems like somewhere in 2010 aticonfig was downgraded...

    --

    Does anyone know how to throttle down my radeon, or have a reference to instructions?
    If you require more system info to help me fix this, pls let me know! (any feedback on how to improve my posts is also welcome)

    Kind regards,
    Paul
    Last edited by MrPok; March 14th, 2011 at 01:47 PM. Reason: typo

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •