Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Respondus Lockdown Browser on Linux (No VM needed)

  1. #11
    Join Date
    May 2013

    Exclamation Re: Respondus Lockdown Browser on Linux (No VM needed)

    I have installed Wine, and set it to run as Windows 7. When I run the setup.exe from /home/username/respondus/ldb-setup/ location,
    the error I get is:

    "Institution ID has not been set correctly for this install. Please see readme.txt for the necessary customization step"

    I obtained the school ID as instructed. I also noted that upon download the first 9 characters are also the same numbers.

    Perhaps what I screwed up was:

    Inside of the archive (LockDownSFX.exe) there are two folders, the "id.txt" file you need will be in a folder like "/tmp/z451214388_26122011-121119-71/". STEP 4: Edit the line that is "<451214388>" for this example, keeping your school's code in between the brackets

    Because when I found id.txt it already had the ID in the file in "<>", so I didn't know what to edit or the purpose of editing.

    So far I have been unable to find my issue anywhere.


    Not sure what I did differently, but now I was able to get the LockDownSFX.exe to run (instead of setup.exe) but....when I try to run

    wine LockDown.exe, I get the error:

    wine: cannot find L"C:\\windows\\system32\\LockDown.exe"

    Perhaps I can fix this by copying it to the hidden drive?
    Last edited by wrkrbee1650; May 12th, 2013 at 01:05 AM. Reason: UPDATE

  2. #12
    Join Date
    Sep 2012

    Re: Respondus Lockdown Browser on Linux (No VM needed)

    Quote Originally Posted by sammyjk View Post
    I installed Respondus through WINE in 12.04, then changed the settings to Windows 7, and fallowed only part of the tutorial above (error message sidetracked me), tried opening it again, just for who-whos and ha-has and it opened no problem. I can still see the unity dock though, and the browser is of course full screen, can still switch between workspaces and even browse the web. Not sure if the winetricks did anything or if just changing the settings did the trick, but it's working and I'm not complaining.
    I've got the program running, and appeared to be working OK, but it ignores clicks on a lot of the school's website. Don't know if that's normal behavior for respondus or not. But the quiz list is trapped in a small space with scrollbars that won't resize and I can only view one line at a time. Also, clicking on "Start Quiz" does nothing as far as I can tell.

    Hmmmph. Will probably just have to borrow my wife's notebook to do the quizzes.

  3. #13
    Join Date
    Sep 2012

    Re: Respondus Lockdown Browser on Linux (No VM needed)

    OK, now it looks to be working almost perfectly.

    One minor glitch: tab key doesn't work to jump from username field to password field, and I have to actually use the mouse to click in the password box. I presume the tab key probably won't work elsewhere in the browser either, but it's not something I'd really ever use while taking quizzes or exams. Other than that, everything appears to be working flawlessly. It did require the use of a windows box to get it set up, though. Or more accurately, a virtualbox running Win7. Whatever.

    What I did:

    Installed through PlayOnLinux. Set to run as Win7 (oddly, when set to run as XP it complains about compatibility mode not being allowed). Program runs at this point, but not well enough to be usable.

    In the Win7 VM, installed Sandboxie. Downloaded the copy of Respondus from the link on my school's website (already has the ID and automatically loads the schools page). Installed Respondus under Sandboxie. Export all files, and copy them into the Repondus folder in the PlayOnLinux drive.

    Won't run in the VM, but works under Wine. Go figure.
    Last edited by jwfox; July 2nd, 2013 at 12:39 AM.

  4. #14
    Join Date
    Sep 2013

    Re: Respondus Lockdown Browser on Linux (No VM needed)

    im glad you guys got lock down browser working, i also seen the blank content of my schools systems. unfortunately my grades were bad enough to be financially ostracised from ferris state university. i had written all of that up for circuits. im pretty sure i lost boblizar from the password leaking thing. i moved over to gentoo then ultimately funtoo, and learned how to edit wiki so i could tutorial in a more proper setting. i promise to return to document installing gentoo and funtoo from ubuntu's excellent live media.

    -three sixes

Page 2 of 2 FirstFirst 12

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts