Results 1 to 5 of 5

Thread: 10.04 eeePC 901 RT2860 WPA problems after Huawei E1752Cu mobile broadband dongle

  1. #1
    Join Date
    May 2008
    Beans
    10
    Distro
    Ubuntu 10.04 Lucid Lynx

    10.04 eeePC 901 RT2860 WPA problems after Huawei E1752Cu mobile broadband dongle

    My eeePC has been running wonderfully with no updates since Summer 2010. This was deliberate because updates have always killed my RT2860 wireless since Hardy!

    I'd ordered a O2-UK PAYG Huawei E1752Cu mobile broadband dongle and thought I should run security updates at least before the install. Wireless worked fine after the updates yesterday and today, I installed the Huawei E1752Cu this afternoon which I expected to be problematic but http://flax.ie/o2-broadband-e1752-do...-ubuntu-10-04/ and usb_modeswitch made it really easy.

    However, now my wireless is broken again. I can see networks and I can see my network (O2 Thomson router WPA) but it times out when trying to connect.

    I've followed http://ubuntuforums.org/showthread.php?t=1481710 and having completed that I found wireless worked However after rebooting, it fails again.

    My hunch is that something was dislodged in the dongle installation and is unsetting things at boot time...perhaps???

  2. #2
    Join Date
    May 2008
    Beans
    10
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 10.04 eeePC 901 RT2860 WPA problems after Huawei E1752Cu mobile broadband dongle

    I have found if I take down the wireless interface, remove the driver from the kernal, refresh the kernal dependencies and bring wireless up again, I can then connect using WPA (until I reboot).

    sudo ifconfig wlan0 down
    sudo rmmod rt2860sta
    sudo depmod -a
    sudo ifconfig wlan0 up

    If 10.10 fixes all the netdiswrapper problems then I might do that next...trepidation approaches!

    Comments welcome!

  3. #3
    Join Date
    May 2008
    Beans
    10
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 10.04 eeePC 901 RT2860 WPA problems after Huawei E1752Cu mobile broadband dongle

    Upgraded to 10.10 and what do you know...problem still exists! Oh and I've got a list of new ones!

  4. #4
    Join Date
    May 2008
    Beans
    10
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 10.04 eeePC 901 RT2860 WPA problems after Huawei E1752Cu mobile broadband dongle

    Amazing how your own company can sometimes find the answers!

    Here's what I did
    Synaptic Package Manager
    1. filter by Upgradable (upstream)
    2. select all packages filtered, right click, reinstall
    3. apply changes

    Took ages and my over-plump distro needs a diet!

    However, kernel is now 2.6.35-27-generic and everything (including wireless problems with WPA) appears to work.

    Tested with a few reboots and seems stable.

  5. #5
    Join Date
    Mar 2011
    Beans
    1

    Re: 10.04 eeePC 901 RT2860 WPA problems after Huawei E1752Cu mobile broadband dongle

    someone who knows exactly what is right?
    is this correct: usb modeswitch.conf

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •