Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Weird flash problem - videos somehow stay in background

  1. #1
    Join Date
    Apr 2006
    Beans
    20
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Weird flash problem - videos somehow stay in background

    Hi,

    after an update on wednesday I got some serious problem with flash. Whenever I watch a video clip on sites like youtube, the video somehow stays in the background and "shines" through any black field in applications. So videos look shattered, but it is even worse for texts - they are almost unreadable on the part of the screen where the video was. This doesn't show on screenshots though.
    I un- and reinstalled flash a couple of times now, tried another video-driver, but it didn't help.

    Any thoughts?

  2. #2
    Join Date
    Feb 2008
    Location
    Planet earth, for now.
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Weird flash problem - videos somehow stay in background

    Tried installing ubuntu-restricted-extras? You will find it in Synaptics Package Manager. That will install latest and appropriate flash if not installed already, some codecs and other things. You might be missing a codec or something may have been killed by your update. This happens with 10.10 and other non-LTS releases from time to time. (Also with LTS releases rarely.)

  3. #3
    Join Date
    Apr 2006
    Beans
    20
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Weird flash problem - videos somehow stay in background

    Thanks, but I got the ubuntu-restricted-extras installed.

  4. #4
    Join Date
    Oct 2010
    Beans
    2

    Re: Weird flash problem - videos somehow stay in background

    Hi there,

    I am experiencing the same issue, and would very much like a solution.

    I have ubuntu-restricted-extras installed like OP, and have very much enjoyed the use of flash on my computer, that is up until now. I guess this means I am using the binary blob flash player from adobe installed with flashplugin-installer, but if you need me to verify this somehow I'd be happy do that, I just don't know how.

    I tried taking screenshots of the issue but they look normal if I reboot or have someone else look at them, so the corruption of the image does not lie in the browser but rather (I guess) in the video buffer. This makes sense as I seem to be getting traces of the image in other gui apps than the browser, and even some artifacts in gnome itself.

    To sum up the issue, basically if I watch a flash video in firefox (like this: http://vimeo.com/moogaloop.swf?clip_id=18150336), stop the video and close the tab, the image of that video stays on any part of the screen that is white, for instance the google front page would be covered in it.

  5. #5
    Join Date
    Feb 2011
    Beans
    4

    Re: Weird flash problem - videos somehow stay in background

    I have similar problem. Some Flash surface somehow remains in background. Some icons and applications on desktop show Flash video (still) image after the Flash-using application is closed. For example, black can become transparent in Gimp showing the video image. The "ghost" image stays in the same place it was during video play, so if I move an application over it, if messes up that part which is over this "ghost" image.

    I have nVidia GT240 video card, with newest possible drivers for VDPAU.

    If someone can tell quick way to reset X/OpenGL/whateverisneeded because now I need to reboot Ubuntu after watching Flash videos?

  6. #6
    Join Date
    Feb 2010
    Beans
    5

    Re: Weird flash problem - videos somehow stay in background

    Disable hardware acceleration for flash (any flash object right-click-settings, it "fix" background problem) and wait for update of flash player.

  7. #7
    Join Date
    Feb 2011
    Beans
    4

    Re: Weird flash problem - videos somehow stay in background

    arrjj: That seems to solve it. I needed to reboot after disabling hardware acceleration. Happily my i5 750 seems to have enough juice to decode Flash without GPU assistance... Or whatever it now does.

    I just hope they fix it properly.

  8. #8
    Join Date
    Feb 2010
    Beans
    5

    Re: Weird flash problem - videos somehow stay in background

    http://www.youtube.com/watch?v=zzesO81u-28 solution to rollback to older version of flashplayer.

  9. #9
    Join Date
    Feb 2008
    Location
    Western Canada
    Beans
    10

    Re: Weird flash problem - videos somehow stay in background

    Quote Originally Posted by arrjj View Post
    Disable hardware acceleration for flash (any flash object right-click-settings, it "fix" background problem) and wait for update of flash player.
    Superb. I had the same problem (Kubuntu Natty with Flash 10.3.181.22) and that fixed it. Thank-you!

  10. #10
    Join Date
    Nov 2009
    Beans
    4

    Re: Weird flash problem - videos somehow stay in background

    I'm having this problem too. Is it possible to get rid of the previous flash image from my screen by refreshing the framebuffer or something like this?

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •