Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Plugging in headphones doesn't mute laptop speakers

  1. #1
    Join Date
    Sep 2009
    Location
    Virginia, USA
    Beans
    50
    Distro
    Ubuntu 10.04 Lucid Lynx

    Question Plugging in headphones doesn't mute laptop speakers

    I'm mostly creating this thread for lidex, because I've already PMed him asking the question, but he asked me to make a public thread to answer the problem, so here it goes.

    I've got an ASUS X52J laptop with Conexant 5069 codec sound card. My problem is that the laptop speakers don't mute when I put my headphones in. I've already upgraded to the newest version of ALSA (1.0.23).

    This is the link to my alsa-info.sh output:

    http://www.alsa-project.org/db/?f=99...57aa5047fd1662

    Thanks for the help in advance.
    Last edited by TheUnwiseman; February 17th, 2011 at 07:14 AM.

  2. #2
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,904
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Plugging in headphones doesn't mute laptop speakers

    How did you update to 1.0.23?
    Try updating your alsa-driver-modules.
    Using a Terminal="Applications->Accessories->Terminal"
    Add the ubuntu-audio-dev ppa:
    Code:
    sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
    sudo apt-get update
    Now install:
    Code:
    sudo apt-get install linux-alsa-driver-modules-$(uname -r)
    Reboot
    Check your levels in alsamixer.
    Code:
     alsamixer
    Press <F6> to select the correct soundcard.
    Press <F3> to show playback levels. <F4> selects capture levels [or use <Tab>]
    Use the left/right arrow keys to select and up/down arrow keys to change levels. <M> to mute/unmute.
    Go to "System ->Preferences ->Sound" and make sure the correct soundcard is default and adjust your profile on the hardware tab.
    On the output tab choose the correct device.

  3. #3
    Join Date
    Sep 2009
    Location
    Virginia, USA
    Beans
    50
    Distro
    Ubuntu 10.04 Lucid Lynx

    Talking Re: Plugging in headphones doesn't mute laptop speakers

    That worked!

    To answer your question, I updated to 1.0.23 by building it from tarballs. I forget where I put the link to the site that walked me through it.

    Thank you very much, lidex!
    Last edited by TheUnwiseman; February 17th, 2011 at 07:14 AM.

  4. #4
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,904
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Plugging in headphones doesn't mute laptop speakers

    And you're welcome!



    k ≠ x

  5. #5
    Join Date
    Sep 2009
    Location
    Virginia, USA
    Beans
    50
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Plugging in headphones doesn't mute laptop speakers

    Oops, sorry. :X

    *lidex

    Edit: Fixed the k->x in other posts now.

  6. #6
    Join Date
    Jul 2011
    Beans
    12

    Re: Plugging in headphones doesn't mute laptop speakers

    hi...
    for the record; i have a lenovo g470 running ubuntu 10.10 and this worked for me.
    thank you

  7. #7
    Join Date
    May 2006
    Beans
    176
    Distro
    Xubuntu 8.04 Hardy Heron

    Re: Plugging in headphones doesn't mute laptop speakers

    Quote Originally Posted by treepete View Post
    hi...
    for the record; i have a lenovo g470 running ubuntu 10.10 and this worked for me.
    thank you


    does the mic also work on g470 ?

    --
    http://rzr.online.fr/q/lenovo
    # http://rzr.online.fr/q/apt # test my deb's please
    # http://rzr.online.fr/q/ubuntu # contribs docs etc
    # http://rzr.online.fr/q/unicorn # works for me
    # http://go.cur.lv/files# files to be shared or email me

  8. #8
    Join Date
    Jul 2011
    Beans
    12

    Re: Plugging in headphones doesn't mute laptop speakers

    sorry to be tardy..
    yes, the mic also works, though it has some static.
    v

  9. #9
    Join Date
    May 2011
    Beans
    2

    Re: Plugging in headphones doesn't mute laptop speakers

    I get up to step two but I get these two errors
    Code:
    bradley@bradley-K52Je:~$ sudo apt-get install linux-alsa-driver-modules-$(uname -r)
    [sudo] password for bradley: 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    E: Unable to locate package linux-alsa-driver-modules-2.6.35-31-generic-pae
    E: Couldn't find any package by regex 'linux-alsa-driver-modules-2.6.35-31-generic-pae'
    bradley@bradley-K52Je:~$

  10. #10
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,904
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Plugging in headphones doesn't mute laptop speakers

    Quote Originally Posted by thelastspud View Post
    I get up to step two but I get these two errors
    Code:
    bradley@bradley-K52Je:~$ sudo apt-get install linux-alsa-driver-modules-$(uname -r)
    [sudo] password for bradley: 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    E: Unable to locate package linux-alsa-driver-modules-2.6.35-31-generic-pae
    E: Couldn't find any package by regex 'linux-alsa-driver-modules-2.6.35-31-generic-pae'
    bradley@bradley-K52Je:~$
    It's not available for that kernel. Use the alsa-info-script to provide detailed information.
    Run this command in a terminal:
    Code:
    wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
    Choose the upload option and provide a link for the output.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •