Results 1 to 9 of 9

Thread: Logitech Z-5 USB speakers not working

  1. #1
    Join Date
    Feb 2011
    Beans
    19

    Logitech Z-5 USB speakers not working

    Hi everyone,

    my Logitech Z-5 USB speakers are recognized as a USB device but aren't available in Sound menu:
    Most of the times they aren't, but sometimes after a reboot or when I turn my computer on they work fine.
    I'm currently on Ubuntu 10.10, but the same thing occurred with Kubuntu, Xubuntu or in the previous Ubuntu installations

    Here is lsusb:

    Code:
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 002: ID 045e:0745 Microsoft Corp. 
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 002: ID 046d:0a13 Logitech, Inc. Z-5 Speakers
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 006: ID 1058:0730 Western Digital Technologies, Inc. 
    Bus 001 Device 003: ID 045e:0761 Microsoft Corp. 
    Bus 001 Device 002: ID 07d1:3c0f D-Link System AirPlus G DWL-G122 Wireless Adapter(rev.E) [Ralink RT2870]
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


    Sound app (when the speakers work they are correctly displayed)




  2. #2
    Join Date
    Feb 2011
    Beans
    19

    Re: Logitech Z-5 USB speakers not working

    Up!

    Does anyone have an idea about this?

  3. #3
    Join Date
    Nov 2009
    Location
    Croatia/Hrvatska
    Beans
    494
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Logitech Z-5 USB speakers not working

    connect speakers on usb, run lsusb to make sure they are recognized and then restart pulseaudio server:
    Code:
    pulseaudio -k
    pulseaudio -D
    maybe that will get the sound going. i assume, that when speakers are connected before computer is turned on, they work normal. right?

  4. #4
    Join Date
    Feb 2011
    Beans
    19

    Re: Logitech Z-5 USB speakers not working

    Thanks marin123, I tried your code but got an error:



    It says that the daemon couldn't be launched

  5. #5
    Join Date
    Nov 2009
    Location
    Croatia/Hrvatska
    Beans
    494
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Logitech Z-5 USB speakers not working

    does the sound work?
    when i restart pulseaudio daemon few times i also get that message but i have audio.
    try killing pulsaudio while playing something (play mp3) and then restart it and see if sound goes off and on.
    maybe you cannot start daemon manually because it starts by itself. just like if you try nautilus -k, it restarts by itself...

  6. #6
    Join Date
    Feb 2008
    Location
    Curretly in MA
    Beans
    20
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Logitech Z-5 USB speakers not working

    I have exactly the same problem, sometimes after reboot they are recognized but many times they aren't and i have to keep rebooting. got ubuntu 10.10 and non of the tutorials i have found about it apply to my problem since my speakers are not even recognized.

  7. #7
    Join Date
    Dec 2010
    Beans
    11

    Re: Logitech Z-5 USB speakers not working

    my logitech USB speaker works after restarting pulseaudio...
    actually not restarting... after killing it, when I write "pulseaudio -D" it shows an error msg...

    output is like that...

    Code:
    user@user-PC:~$ lsusb
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 004: ID 1130:1620 Tenx Technology, Inc. 
    Bus 003 Device 003: ID 04b3:310b IBM Corp. Red Wheel Mouse
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    user@user-PC:~$ pulseaudio -k
    user@user-PC:~$ pulseaudio -D
    E: main.c: Daemon startup failed.



    now the sound output shows the USB speaker...
    here is the attachment of the screenshot of sound preference...
    Attached Images Attached Images

  8. #8
    Join Date
    Nov 2009
    Location
    Croatia/Hrvatska
    Beans
    494
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Logitech Z-5 USB speakers not working

    pulseaudio -D gives you error message because the daemon starts automatically when you kill it...
    if pulseaudio is giving you trouble, you can configure the speakers in alsamixer and tell all your apps to use alsa.. whenever i can, i tend to use alsa because its faster and doesnt have cracking sounds...

  9. #9
    Join Date
    Nov 2009
    Beans
    16

    Re: Logitech Z-5 USB speakers not working

    Some time ago I found this workaround fixed the problem:

    https://bugs.launchpad.net/mythbuntu/+bug/584680

    Good luck!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •