Results 1 to 10 of 10

Thread: 10.10 won't boot after main power failure

  1. #1
    Join Date
    Dec 2009
    Beans
    10

    10.10 won't boot after main power failure

    Hi!
    Running 10.10
    After a main power failure I can't boot.

    It says:
    ...........
    [sdb] Attached SCSI removable disk
    [sdc] Attached SCSI removable disk
    [sdd] Attached SCSI removable disk
    [sde] Attached SCSI removable disk
    and stops.
    I get a (initramfs) prompt and have no idea what to do with it.

    Allready tried to install 10.10 again from a CD. But it also hangs immediately when it starts to install. The liveCD feature works OK and I can access the hard disk. I tried to update the initramfs with the liveCD but it says I can't write since I have only "read-only" access.
    But if I do "sudo nautilus" I have full access to the disk.

    Can someone help me? I'm not very experienced in Linux, but I'm proficient at "copying and pasting" commands!

    Tx
    HumbFig

  2. #2
    Join Date
    Jan 2008
    Location
    Spain
    Beans
    1,185
    Distro
    Ubuntu

    Re: 10.10 won't boot after main power failure

    OK, it seems a task for fsck.
    But first please let's see what disks are on your computer (I miss at least a mention of sda). Please, from live session open a terminal, run
    Code:
    sudo fdisk -l
    and paste back here the output.
    What's even more important than free software? - OPEN FORMATS.

  3. #3
    Join Date
    Dec 2009
    Beans
    10

    Re: 10.10 won't boot after main power failure

    Quote Originally Posted by JC Cheloven View Post
    OK, it seems a task for fsck.
    But first please let's see what disks are on your computer (I miss at least a mention of sda). Please, from live session open a terminal, run
    Code:
    sudo fdisk -l
    and paste back here the output.
    Thanks for your help!
    Maybe I didn't tell all the story. I used to have 5 disks plus 1 DVD. The disk that contains the boot and the /home is IDE, the DVD is also IDE. The other 4 disks are SATA.
    When the booting problem came up I decided to simplify and removed the SATA disks. I would remove the processor if it would increase the odds for successful booting.
    Anyway, there's NO DIFFERENCE in the messages I get when trying to boot, so, I will add the SATA disks again. And using the LiveCD I could access all the disks.
    For now, here is the result of the fdisk with only the booting disk in the system:

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 13 102400 7 HPFS/NTFS
    Partition 1 does not end on cylinder boundary.
    /dev/sda2 13 17653 141692928 7 HPFS/NTFS
    /dev/sda3 17654 30401 102398279+ 5 Extended
    /dev/sda5 17654 17778 1004031 82 Linux swap / Solaris
    /dev/sda6 17779 19030 10056658+ 83 Linux
    /dev/sda7 19031 30401 91337526 83 Linux

    It's a bit messy because I used to run dual boot, until windows stoped booting also. That was a long time ago and I have not missed it that much..... one of these days I'll have to learn how to fix the grub thing......

    again, many thanks!

    HumbFig

  4. #4
    Join Date
    Dec 2009
    Beans
    10

    Re: 10.10 won't boot after main power failure

    Ok, some (maybe) useful pics:






    the sdb, sdc, sdd, sde that appear when the booting hangs are these "Generic Storage devices". USB stuff......
    What is the 693MB USB thing? the ramfs? under USB, firewire???????????

    It's been hard to write this post, cause the computer is very willing to hang for no discernable reason.......

    Tx

    HumbFig

  5. #5
    Join Date
    Jan 2008
    Location
    Spain
    Beans
    1,185
    Distro
    Ubuntu

    Re: 10.10 won't boot after main power failure

    Hi, and sorry for the delay. Didn't had time to come back here since sunday.

    A power failure may have damaged your system at diferent levels. From messing a filesystem what was in use (that's usually either recoverable or "fixed" by a formatting in the worst case), to some more serious permanent damage to the ram or other hardware components.

    Starting by the end: You said the computer hangs frequently? Even from live? This could be a symptom of ram failure. You can boot to memory diagnosis and let it run for a couple of hours or so, to see if something is wrong.

    Different subject: the partition where the grub files are, could be sda6 or sda7. Usually where you installed ubuntu the last time (surely you know better). If it's sda6, you can try to repair errors from that filesystem with
    Code:
    sudo fsck /dev/sda6
    from live.

    Hope this helps
    What's even more important than free software? - OPEN FORMATS.

  6. #6
    Join Date
    Dec 2009
    Beans
    10

    Re: 10.10 won't boot after main power failure

    Quote Originally Posted by JC Cheloven View Post
    Hi, and sorry for the delay. Didn't had time to come back here since sunday.

    A power failure may have damaged your system at diferent levels. From messing a filesystem what was in use (that's usually either recoverable or "fixed" by a formatting in the worst case), to some more serious permanent damage to the ram or other hardware components.

    Starting by the end: You said the computer hangs frequently? Even from live? This could be a symptom of ram failure. You can boot to memory diagnosis and let it run for a couple of hours or so, to see if something is wrong.

    Different subject: the partition where the grub files are, could be sda6 or sda7. Usually where you installed ubuntu the last time (surely you know better). If it's sda6, you can try to repair errors from that filesystem with
    Code:
    sudo fsck /dev/sda6
    from live.

    Hope this helps
    Hi!
    Memory seems good. It hasn't hang lately......
    The partition where I installed ubuntu was indeed /sda6. This partition is the only one I can not access. All the others seem OK.
    If I try to run fsck I get:

    "fsck.ext4: Device or Resource busy while trying to open /dev/sda6"
    "Filesystem mounted or opened exclusively by another program?"

    Actually, it's not mounted, and if I try to mount it, it says /sda6 is not in /etc/fstab or mtab. If I try to mount it using the UI it says:
    "DBus error org.gtk.Private.RemoteVolumeMonitor.Failed:
    An operation is already pending"

    If I check the runing processes, I can see one saying "mount -t ext4 -o uhelper=udisk".
    I tried to kill it but it refuses to die........

    I tried to format /sda6 but I can't either......

    Any ideas left?

    Tx for your effort!

    HumbFig
    Last edited by humbfig; February 16th, 2011 at 08:29 PM.

  7. #7
    Join Date
    Jan 2008
    Location
    Spain
    Beans
    1,185
    Distro
    Ubuntu

    Re: 10.10 won't boot after main power failure

    If fsck doesn't work, I'm out of ideas at the moment, regarding the recovery of the filesystem on this partition.
    Quote Originally Posted by humbfig View Post
    I tried to format /sda6 but I can't either......
    Any ideas left?
    What thingie did you use? Gparted? (if not it's worth to try)
    Did you try mkfs from terminal? Something like:
    Code:
    sudo mkfs -t ext4 -c /dev/sda6
    The -c option will check for damaged blocks in the partition (see man mkfs for details).

    BTW: I guess sda7 is your separate /home partition. If so, congrats. This is a typical case in which life is easier with separate /home.
    Last edited by JC Cheloven; February 18th, 2011 at 03:44 AM.
    What's even more important than free software? - OPEN FORMATS.

  8. #8
    Join Date
    Dec 2009
    Beans
    10

    Re: 10.10 won't boot after main power failure

    Quote Originally Posted by JC Cheloven View Post
    If fsck doesn't work, I'm out of ideas at the moment, regarding the recovery of the filesystem on this partition.

    What thingie did you use? Gparted? (if not it's worth to try)
    Did you try mkfs from terminal? Something like:
    Code:
    sudo mkfs -t ext4 -c /dev/sda6
    The -c option will check for damaged blocks in the partition (see man mkfs for details).

    BTW: I guess sda7 is your separate /home partition. If so, congrats. This is a typical case in which life is easier with separate /home.
    Great news!!!
    mkfs did for me. After I run it I could mount /sda6, delete it, format it, whatever.
    I still don't understand what had happened. If there was an invalid filesystem in /sda6, how could it stop me from deleting the partition?
    /sda6 was messed, but was smart enough not to let me format it or delete it......
    Since I used mkfs exactly like you wrote it (I told you I was good at copying and pasting commands!), didn't use a verbose option, I don't know if mkfs had something special to tell me......

    yes, I had used GParted, and yes my /home is sda7 (learned that the hardway also!)

    Many many thanks for your great help!!!
    If you come around Lisbon, you have a free beer waiting for you!

    HumbFig

  9. #9
    Join Date
    Jan 2008
    Location
    Spain
    Beans
    1,185
    Distro
    Ubuntu

    Re: 10.10 won't boot after main power failure

    Glad it worked A pleasure to give a hand to such a kind person.

    To be honest, I don't understand either what exactly happened. I'd also expect that a formatting action (of any kind) would have wiped the filesystem, whether it contained errors or not, or even if was left marked as "in use" when the power failed. EDIT: ah, don't wory too much about what mkfs would have to say. Probably some bad sectors marked as unusable, and little more.

    Thanks for the beer! Lisboa is very nice, I loved it when I visited it a couple of times in the past. But isn't exactly nearby, I'm afraid I'll have to be content with a virtual beer

    Please don't forget to mark the thread as solved, using the "thread tools" at the top.

    See u in the forums!
    JC
    Last edited by JC Cheloven; February 19th, 2011 at 03:29 AM.
    What's even more important than free software? - OPEN FORMATS.

  10. #10
    Join Date
    Nov 2010
    Location
    Berlin, Germany
    Beans
    4,534
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: 10.10 won't boot after main power failure

    Hi, I followed this thread in the last days, and there was a actually another thread at the same time regarding a similar issue, and the same solution:
    http://ubuntuforums.org/showthread.php?t=1681889

    Greetings.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •