Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Ubuntu 10.10 & SLI GTX470

  1. #1
    Join Date
    Feb 2011
    Beans
    5

    Ubuntu 10.10 & SLI GTX470

    Hi guys!
    I'm a new user and I'm trying to use a SLI configuration on Ubuntu 10.10. I've installed a SLI of two Zotac gtx 470 on windows and works perfectly, but on the same machine with ubuntu installed I think that option is not well configured.
    Let me explain. On Ubuntu I've uninstalled default nVidia drivers.
    System info:
    Code:
    guido@POWA:~$ uname -a
    Linux POWA 2.6.35-25-generic-pae #44-Ubuntu SMP Fri Jan 21 19:01:46 UTC 2011 i686 GNU/Linux
    I wrote in console:
    Code:
    sudo apt-get remove --purge nvidia-*
    also I've blacklisted some drivers that could block nVidia ones. In /etc/modprobe.d/blacklist.conf I added these ones:
    Code:
    blacklist vga16fb
    blacklist nouveau
    blacklist rivafb
    blacklist nvidiafb
    blacklist rivatv
    Then I installed nVidia latest, directly downloading them from the official site. Now I've ( glxinfo | grep version ):
    Code:
    server glx version string: 1.4
    client glx version string: 1.4
    GLX version: 1.4
    OpenGL version string: 4.1.0 NVIDIA 260.19.36
    OpenGL shading language version string: 4.10 NVIDIA via Cg compiler
    My xorg.conf file is this one:
    Code:
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 260.19.36  (buildmeister@swio-display-x86-rhel47-06.nvidia.com)  Tue Jan 18 17:31:39 PST 2011
    
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Unknown"
        HorizSync       28.0 - 33.0
        VertRefresh     43.0 - 72.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "SLI" "on"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    In my opinion the automatic-generated xorg file has a generic nVidia card...problems here?

    I set, as I read on nVidia help driver link, nvidia-xconfig --sli=on. But with nvidia-settings I see only one video card, GPU0.. the other one is not listed.

    With "lspci | grep VGA", I see both video cards:
    Code:
    03:00.0 VGA compatible controller: nVidia Corporation GF100 [GeForce GTX 470] (rev a3)
    04:00.0 VGA compatible controller: nVidia Corporation GF100 [GeForce GTX 470] (rev a3)
    I've tried editing xorg.conf modifying the sections devices with:
    Code:
    Section "Device"
       Identifier "Videocard0"
       Driver "nvidia"
       VendorName "NVIDIA Corporation"
       BoardName "GTX 470"
       BusID "PCI:3:0:0"
    EndSection
    
    Section "Device"
       Identifier "Videocard1"
       Driver "nvidia"
       VendorName "NVIDIA Corporation"
       BoardName "GTX 470"
       BusID "PCI:4:0:0"
    EndSection
    But this editing resulted, after a reboot, in a black screen with X server not starting due to a not accessible nvidia0 file, also X server couldn't start nVidia VGA on pci 3 and on pci 4.
    I've tried editing the same xorg.conf with:
    Code:
    Section “Device”
    Identifier     “Configured Video Device”
    Driver         “nvidia”
    BusID          “03:00:0″
    EndSection
    Section “Device”
    Identifier     “Device0″
    Driver         “nvidia”
    VendorName     “NVIDIA Corporation”
    BoardName      “GeForce GTX 260″
    BusID          “PCI:3:0:0″
    EndSection
    Section “Device”
    Identifier     “Device1″
    Driver         “nvidia”
    VendorName     “NVIDIA Corporation”
    BoardName      “GeForce GTX 260″
    BusID          “PCI:2:0:0″
    EndSection
    but It doesn't work again..same issue.

    So, anyone here has a solution?
    Can anyone help me?

    Sorry for my english, It's not my first language

    Tnx everyone for your attention!

  2. #2
    Join Date
    Sep 2008
    Beans
    5
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Ubuntu 10.10 & SLI GTX470

    Have you tried "On" instead of "on"?

  3. #3
    Join Date
    Feb 2011
    Beans
    5

    Re: Ubuntu 10.10 & SLI GTX470

    Quote Originally Posted by amentajo View Post
    Have you tried "On" instead of "on"?
    Thank for your advice and your interest, but changing it doesn't matter. I tried, with "on" or "On" same result. I see only one video card in nvidia-settings.
    I don't really know where is the problem...

  4. #4
    Join Date
    Feb 2011
    Beans
    5

    Re: Ubuntu 10.10 & SLI GTX470

    Bump!

  5. #5
    Join Date
    Jan 2007
    Beans
    244

    Re: Ubuntu 10.10 & SLI GTX470

    I have never configured SLI before, but read this http://ubuntuforums.org/showthread.php?t=848748. I hope it helps...

  6. #6
    Join Date
    Feb 2011
    Beans
    5

    Re: Ubuntu 10.10 & SLI GTX470

    I tried
    Code:
    sudo nvidia-xconfig --sli=On
    but it adds only the Option "Sli" "On" in the section Monitor, after a reboot I do not see any changes in nvidia-settings control panel

  7. #7
    Join Date
    Feb 2011
    Beans
    173
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Ubuntu 10.10 & SLI GTX470

    Have you tried "sudo nvidia-xconfig -a" and then seeing what your xorg.conf looks like?

  8. #8
    Join Date
    Feb 2011
    Beans
    5

    Re: Ubuntu 10.10 & SLI GTX470

    Quote Originally Posted by jwcalla View Post
    Have you tried "sudo nvidia-xconfig -a" and then seeing what your xorg.conf looks like?
    Code:
    Using X configuration file: "/etc/X11/xorg.conf".
    NVIDIA: could not open the device file /dev/nvidia1 (Input/output error).
    
    WARNING: Unable to use the nvidia-cfg library to query NVIDIA hardware.
    
    
    ERROR: Unable to determine number of GPUs in system; cannot honor
           '--enable-all-gpus' option.
    
    Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
    New X configuration file written to '/etc/X11/xorg.conf'
    but
    Code:
    ls -l /usr/lib/libnvidia*
    lrwxrwxrwx 1 root root       18 2011-02-08 19:55 /usr/lib/libnvidia-cfg.so -> libnvidia-cfg.so.1
    lrwxrwxrwx 1 root root       26 2011-02-08 19:55 /usr/lib/libnvidia-cfg.so.1 -> libnvidia-cfg.so.260.19.36
    -rwxr-xr-x 1 root root   128820 2011-02-08 19:55 /usr/lib/libnvidia-cfg.so.260.19.36
    -rwxr-xr-x 1 root root 20556580 2011-02-08 19:55 /usr/lib/libnvidia-compiler.so.260.19.36
    -rwxr-xr-x 1 root root 23726100 2011-02-08 19:55 /usr/lib/libnvidia-glcore.so.260.19.36
    -rwxr-xr-x 1 root root     4436 2011-02-08 19:55 /usr/lib/libnvidia-tls.so.260.19.36
    I don't understand why I get that message..
    I've also tried:
    Code:
    sudo nvidia-xconfig --query-gpu-info
    but I got:
    Code:
    NVIDIA: could not open the device file /dev/nvidia1 (Input/output error).
    
    WARNING: Unable to use the nvidia-cfg library to query NVIDIA hardware.
    
    
    ERROR: Unable to query GPU information
    I've found the solution!!!!!!!
    YEAH!
    ok let me explain.
    1)
    Code:
    sudo pico /etc/default/grub
    use gedit, nano instead of pico if you want.
    and modify this line
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    in
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vmalloc=256M"
    (if 256M not works, try 192M).

    2)on console type:
    Code:
    sudo update-grub
    and reboot

    3)Now if you try
    Code:
    sudo nvidia-xconfig --query-gpu-info
    you will get something like this
    Code:
    Number of GPUs: 2
    
    GPU #0:
      Name      : GeForce GTX 470
      PCI BusID : PCI:3:0:0
    
      Number of Display Devices: 1
    
      Display Device 0 (DFP-0):
         EDID Name             : Ancor Communications Inc VE248
         Minimum HorizSync     : 30.000 kHz
         Maximum HorizSync     : 83.000 kHz
         Minimum VertRefresh   : 50 Hz
         Maximum VertRefresh   : 76 Hz
         Maximum PixelClock    : 170.000 MHz
         Maximum Width         : 1920 pixels
         Maximum Height        : 1080 pixels
         Preferred Width       : 1920 pixels
         Preferred Height      : 1080 pixels
         Preferred VertRefresh : 60 Hz
         Physical Width        : 530 mm
         Physical Height       : 300 mm
    
    
    GPU #1:
      Name      : GeForce GTX 470
      PCI BusID : PCI:4:0:0
    
      Number of Display Devices: 1
    
      Display Device 0 (DFP-0):
         EDID Name             : Ancor Communications Inc VE248
         Minimum HorizSync     : 30.000 kHz
         Maximum HorizSync     : 83.000 kHz
         Minimum VertRefresh   : 50 Hz
         Maximum VertRefresh   : 76 Hz
         Maximum PixelClock    : 170.000 MHz
         Maximum Width         : 1920 pixels
         Maximum Height        : 1080 pixels
         Preferred Width       : 1920 pixels
         Preferred Height      : 1080 pixels
         Preferred VertRefresh : 60 Hz
         Physical Width        : 530 mm
         Physical Height       : 300 mm
    4) It's time for:
    Code:
    sudo nvidia-xconfig --sli=On
    5) Reboot.
    You will enjoy, finally, SLI on ubuntu.

    So now a little issue..eh eh eh GPU 0 with sli enabled has an higher temperature compared to sli "off"!! :S It's normal with sli on?! ( the other video card it's around 10C° lower :S

    SOLVED you can close.
    Last edited by Jigen90; February 13th, 2011 at 01:02 PM.

  9. #9
    Join Date
    Oct 2011
    Beans
    2

    Lightbulb Re: Ubuntu 10.10 & SLI GTX470

    First, a big thanks Jigen90 for this information, i was kinda despaired after some weeks of searching how to make it work.
    Second, i have some question that i hope, you or anybody else will be able to answer.
    1-Why allocating mem using :
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vmalloc=256M"

    enable the possibility to use two graphic cards???
    2-This memory is allocated to what system, grub, the hardware, the os???
    3-What kind of memory is it, vm- virtual memory???
    4-How you choose 256M as value, what is the base information that make you choose 256M?? Is it related to how many memory the graphic cards have???
    5-Does this memory act as a swap area for the cards???

    I really hope that somebody will be able to answer those questions, as i really hate doing something that work, without knowing why it work. And, as i searched this answer so long, i will use the answer to make a good tutorial directly in the nvidia forum, so next time someone have this problem, he will be able to find a fast and right answer.

  10. #10
    Join Date
    Feb 2011
    Beans
    173
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Ubuntu 10.10 & SLI GTX470

    There is some discussion about it here:

    http://us.download.nvidia.com/XFree8...ownissues.html

    under the heading "Kernel virtual address space exhaustion on the X86 platform". Although this particular document is addressing another problem, it does answer some of those questions.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •