Results 1 to 9 of 9

Thread: Wine Starcraft II dual monitors

  1. #1
    Join Date
    Jan 2008
    Beans
    135

    Wine Starcraft II dual monitors

    Has anyone had any success running Starcraft 2 with dual monitors (twinview)? My mouse won't keep focus on the monitor it's running in, so the only way I can play is by disabling the other monitor at the moment.

    Anyone know any fixes to this?

    Thanks

  2. #2
    Join Date
    Apr 2010
    Location
    Moody, AL
    Beans
    39
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Re: Wine Starcraft II dual monitors

    Bump

    Same Problem. Confine Mouse Cursor not working in windowed or fullscreen mode.

  3. #3
    Join Date
    Aug 2008
    Beans
    302

    Re: Wine Starcraft II dual monitors

    Have you tryied "MouseWarpOverride"? http://wiki.winehq.org/UsefulRegistryKeys

  4. #4
    Join Date
    Apr 2010
    Location
    Moody, AL
    Beans
    39
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Re: Wine Starcraft II dual monitors

    My Registry doesn't look like that could it be because im running an older version of wine?

  5. #5
    Join Date
    Apr 2010
    Location
    Moody, AL
    Beans
    39
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Re: Wine Starcraft II dual monitors

    I added that key in to my registry and have tried all variations of it. The mouse cursor still does not stay confined to the game when I am in it.

  6. #6
    Join Date
    Jan 2008
    Beans
    10

    Re: Wine Starcraft II dual monitors

    Same issue, fresh copy and install of SC2. If I disable one monitor everything works fine but no beans if both monitors are on.

    Maverick 64-bit with nVidia 9500GT driver version 270.41.06 and Wine 1.3.19

  7. #7
    Join Date
    Jan 2008
    Beans
    10

    Re: Wine Starcraft II dual monitors

    I found a fix for this. Add a metamode in xorg.conf that matches the resolution you set for Starcraft. For me, I changed:
    Code:
    Option         "metamodes" "DFP-0: nvidia-auto-select +0+0, DFP-1: nvidia-auto-select +1440+0"
    to this:
    Code:
    Option         "metamodes" "DFP-0: nvidia-auto-select +0+0, DFP-1: nvidia-auto-select +1440+0;DFP-0:1440x900,DFP-1:NULL"
    This makes it so my other monitor automatically disables when Starcraft starts up. There is one issue, however. It stays disabled even after closing Starcraft... I'll see if I can fix that.

  8. #8
    Join Date
    Feb 2008
    Location
    Los Angeles
    Beans
    339
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wine Starcraft II dual monitors

    I had the problem with the wayward mouse using twinview when I first installed SC2, as well as the video resolution was squished into the center of view 1. It went away some where between reinstalling the game, patching and launching with only 1 monitor enabled and later re-enabling twinview after exiting the game. I use windowed full screen mode, and a dedicated wineprefix for sc2.

    Specs: Nvidia latest proprietary drivers on GTX460, wine 1.3.19
    Last edited by Tweak42; May 9th, 2011 at 02:20 AM.
    Dell Latitude D630 - 4GB RAM - 128GB SSD - Nvidia Quadro NVS 135M - Intel 4965 wireless - DVD/CDRW - bluetooth - fingerprint reader

  9. #9
    Join Date
    Oct 2009
    Beans
    13

    Re: Wine Starcraft II dual monitors

    If anyone is still having trouble with this, using "Windowed (Fullscreen)" mode will work. Not sure if it affects frame rates like running games in Windowed mode used to?

    If you edit Variables.txt (it was in my "~/StarCraft II" directory, which was automatically generated when I ran the game):
    displaymode=1

    If you don't see displaymode, you can add a line with it. (My file did not contain displaymode, and the game must default to fullscreen)

    Also, for those who care: Variables.txt appears to be similar to World of Warcraft's config.wtf. Oh, and WoW appears to have the same mouse-mapping bug when fullscreen.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •