Page 20 of 22 FirstFirst ... 101819202122 LastLast
Results 191 to 200 of 219

Thread: ALSA Upgrade Script Redux

  1. #191
    Join Date
    Jul 2012
    Beans
    1

    Unhappy Re: ALSA Upgrade Script Redux

    I get the following error at the second stage (running the .sh script with the -c switch)

    Continue to configure and compile 1.0.25 [y/n]: y


    ************************************************** *************************
    * Alsa packages(drivers/lib/util/firmware/oss) will be compiled
    ************************************************** *************************

    ************************************************** *************************
    * Prepare for compilation and installation...
    ************************************************** *************************

    ************************************************** *************************
    * Compiling drivers...
    ************************************************** *************************
    rm -f .depend *.o snd.map*
    rm -f modules/*.o modules/*.ko
    make: *** include: No such file or directory. Stop.
    make: *** [clean] Error 1
    checking for gcc... gcc
    checking whether the C compiler works... yes
    checking for C compiler default output file name... a.out
    checking for suffix of executables...
    checking whether we are cross compiling... no
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ISO C89... none needed
    checking for ranlib... ranlib
    configure: error: cannot find install-sh, install.sh, or shtool in "." "./.." "./../.."

    ************************************************** *************************
    * alsa-driver-1.0.25 configure failed
    ************************************************** *************************

    Any way I can get the missing files off the web? What exactly is going wrong here?

  2. #192
    Join Date
    Jun 2007
    Beans
    11,137

    Re: ALSA Upgrade Script Redux

    ^If you install shtool package, does that help?

  3. #193
    Join Date
    Nov 2010
    Beans
    8

    Re: ALSA Upgrade Script Redux

    Hi,

    Is there any possibility to revert? I'm not sure if it's because of the upgrade or the new kernel but I have a problem with vlc who doesn't find the alsa output module. Thanks for any help.

    Xubuntu 12.04
    3.2.0-27-generic
    RME 9632
    Last edited by faucon50; July 30th, 2012 at 09:24 PM.

  4. #194
    Join Date
    Jun 2008
    Beans
    42

    Re: ALSA Upgrade Script Redux

    I want to revert to.
    Is that possible? My webcamera's built in mic is not working with alsa version bigger than 1.0.23.

    I try to compile 1.0.23 version on 3.2.0-29 kernel but i get the following error
    Code:
    cc1: fatal error: /lib/modules/3.2.0-29-generic/build/include/linux/modversions.h: No such file or directory

  5. #195
    Join Date
    Mar 2008
    Beans
    9

    Re: ALSA Upgrade Script Redux

    thanks much for that script... I'm on Ubuntu 10.04.4 LTS, running Mythbuntu and I just swapped in a new ASRock motherboard that had Realtek ALC892 audio and I was getting no sound. I'm not a strong linux person, but I followed your instructions for compiling/installing it and after watching many things flash across the screen, it said it was installed, I rebooted and sure enough after Mythtv came back up the audio was working again.

  6. #196
    Join Date
    Oct 2012
    Beans
    1

    Re: ALSA Upgrade Script Redux

    Hi !

    Is this script work on debian ?
    Because i've an error when i compile

    Code:
    /opt/Alsa-1.0.24/alsa-driver-1.0.24/acore/hrtimer.c:172: error: expected ‘{’ at end of input
    make[5]: *** [/opt/Alsa-1.0.24/alsa-driver-1.0.24/acore/hrtimer.o] Error 1
    make[4]: *** [/opt/Alsa-1.0.24/alsa-driver-1.0.24/acore] Error 2
    make[3]: *** [_module_/opt/Alsa-1.0.24/alsa-driver-1.0.24] Error 2
    make[2]: *** [sub-make] Error 2
    make[1]: *** [all] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.32-5-amd64'
    make: *** [compile] Error 2
    
    ***************************************************************************
    *  alsa-driver-1.0.24 make failed
    ***************************************************************************
    same error with 1.0.25....

    any idea ?

    thanks

  7. #197
    Join Date
    Sep 2012
    Beans
    3

    Re: ALSA Upgrade Script Redux

    Anyone has an update on the alsa servers?

    They seem to be down.

    Edit: Changed sources. Works fine for me.

    https://www.dropbox.com/s/qbsv955x24...de-1.0.25-3.sh
    Last edited by binloan; October 23rd, 2012 at 11:46 AM.

  8. #198
    Join Date
    May 2010
    Beans
    5

    Re: ALSA Upgrade Script Redux

    Quote Originally Posted by amanssan View Post
    Hi !

    Is this script work on debian ?
    Because i've an error when i compile

    Code:
    /opt/Alsa-1.0.24/alsa-driver-1.0.24/acore/hrtimer.c:172: error: expected ‘{’ at end of input
    make[5]: *** [/opt/Alsa-1.0.24/alsa-driver-1.0.24/acore/hrtimer.o] Error 1
    make[4]: *** [/opt/Alsa-1.0.24/alsa-driver-1.0.24/acore] Error 2
    make[3]: *** [_module_/opt/Alsa-1.0.24/alsa-driver-1.0.24] Error 2
    make[2]: *** [sub-make] Error 2
    make[1]: *** [all] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.32-5-amd64'
    make: *** [compile] Error 2
    
    ***************************************************************************
    *  alsa-driver-1.0.24 make failed
    ***************************************************************************
    same error with 1.0.25....

    any idea ?

    thanks
    getting the something running ubunt 12.10

  9. #199
    Join Date
    Nov 2010
    Beans
    10

    Re: ALSA Upgrade Script Redux

    Hello Temüjin,

    would you *please* upgrade your script for the latest ALSA 1.0.26? thanks in advance.
    I just tried to replace 1.0.25 with 1.0.26 in your script, but it doesn't work...can't find
    the ALSA Utils your script says then.

    tia.

  10. #200
    Join Date
    Jun 2007
    Beans
    11,137

    Re: ALSA Upgrade Script Redux

    @doomedforever: I've already made a few small edits and have the script ready. I need to test it on my Ubuntu VM's, and the ALSA ftp is still down (will try alternative link). Keep in mind that the ALSA kernel driver is still at 1.0.25 and only the userspace utils/libs have been updated to 1.0.26

Page 20 of 22 FirstFirst ... 101819202122 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •