Page 19 of 22 FirstFirst ... 91718192021 ... LastLast
Results 181 to 190 of 219

Thread: ALSA Upgrade Script Redux

  1. #181
    Join Date
    May 2011
    Beans
    2

    Re: ALSA Upgrade Script Redux

    Lost audio after rebooting . Install this version:
    $ cat /proc/asound/version
    Advanced Linux Sound Architecture Driver Version 1.0.25.
    Compiled on Apr 22 2012 for kernel 2.6.32-40-generic (SMP).

  2. #182
    Join Date
    Jun 2008
    Beans
    10

    Re: ALSA Upgrade Script Redux

    Thank you for your script. On Linuxmint Debian Edition, compiling failed with errors like

    Code:
    /usr/src/linux-headers-3.2.0-2-common/arch/x86/include/asm/bitops.h:59:24: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘void’
    /usr/src/linux-headers-3.2.0-2-common/arch/x86/include/asm/bitops.h:97:24: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘void’
    /usr/src/linux-headers-3.2.0-2-common/arch/x86/include/asm/bitops.h: In function ‘clear_bit_unlock’:
    /usr/src/linux-headers-3.2.0-2-common/arch/x86/include/asm/bitops.h:121:2: error: implicit declaration of function ‘barrier’ [-Werror=implicit-function-declaration]
    But I'm on a 64 bit install. So I modified line 331 in AlsaUpgrade-1.0.25-3.sh

    Code:
    ./configure --with-kernel=/usr/src/linux-headers-$KERNEL --with-cards=$CARDS --with-card-options=all --with-sequencer=yes --with-oss=no --prefix=/usr || die "$DRIVER configure failed"
    and deleted --with-kernel=/usr/src/linux-headers-$KERNEL

    Problem solved.
    Last edited by TimCastle; April 30th, 2012 at 01:44 AM.

  3. #183
    Join Date
    Sep 2011
    Beans
    54
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: ALSA Upgrade Script Redux

    This (1.0.25-3) all worked very well indeed on 12.04 - thanks very much indeed.

    I have a Creative XFi Fatality card, with a front panel (I/O driver panel). This includes a headphone socket, and an SPDIF out socket (as well as sundry others which I use from time to time but haven't tried lately, such as Midi and additional analogue inputs). The SPDIF out works fine now, which is really useful.

    However, I can still find no way to get the headphone socket to work on ubuntu. On Windows (I am dual-booted - for now at least) there is a switch you can set to get the headphone socket to override the speakers. In the past several people have said there is no support for the front panel, but for digital out there now clearly is some, and I had hopes for the headphones.

    I have checked 1.0.25 is installed. Alsamixer shows the rear panel connections but not the front panel ones.

  4. #184
    Join Date
    Dec 2007
    Location
    Virginia
    Beans
    20
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: ALSA Upgrade Script Redux

    Quote Originally Posted by Marcelo Ruiz View Post
    Same thing on mine (Maverick x64):

    Code:
    make[1]: Entering directory `/usr/src/linux-headers-2.6.35-32-generic'
      CC [M]  /opt/Alsa-1.0.25/alsa-driver-1.0.25/acore/hrtimer.o
      CC [M]  /opt/Alsa-1.0.25/alsa-driver-1.0.25/acore/hwdep.o
      CC [M]  /opt/Alsa-1.0.25/alsa-driver-1.0.25/acore/memory_wrapper.o
      CC [M]  /opt/Alsa-1.0.25/alsa-driver-1.0.25/acore/memalloc.o
      CC [M]  /opt/Alsa-1.0.25/alsa-driver-1.0.25/acore/sgbuf.o
      CC [M]  /opt/Alsa-1.0.25/alsa-driver-1.0.25/acore/pcm.o
    In file included from /opt/Alsa-1.0.25/alsa-driver-1.0.25/acore/pcm.c:30:
    /opt/Alsa-1.0.25/alsa-driver-1.0.25/include/sound/pcm.h:434: error: field ‘latency_pm_qos_req’ has incomplete type
    make[3]: *** [/opt/Alsa-1.0.25/alsa-driver-1.0.25/acore/pcm.o] Error 1
    make[2]: *** [/opt/Alsa-1.0.25/alsa-driver-1.0.25/acore] Error 2
    make[1]: *** [_module_/opt/Alsa-1.0.25/alsa-driver-1.0.25] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.35-32-generic'
    make: *** [compile] Error 2
    
    ***************************************************************************
    *  alsa-driver-1.0.25 make failed
    ***************************************************************************
    Any ideas?
    EXACT same error here and the PPA I've found doesn't have a compilation for this kernel. Suggestions on getting past this?

  5. #185
    Join Date
    Jun 2007
    Beans
    10,566

    Re: ALSA Upgrade Script Redux

    Quote Originally Posted by BLKMGK View Post
    EXACT same error here and the PPA I've found doesn't have a compilation for this kernel. Suggestions on getting past this?
    As I said a few posts back:
    Due to kernel changes, you will probably have more luck with the 1.0.24 script. Ubuntu 10.10 is EOL/unsupported anyway.

  6. #186
    Join Date
    Dec 2007
    Location
    Virginia
    Beans
    20
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: ALSA Upgrade Script Redux

    Unfortunately judging from the log errors I'm getting from the software I'm trying to run (XBMC) 1.0.25 ALSA appears to be required for sound playback. I'm attempting to confirm this with the developers now as up until their latest code changes this wasn't required. They have pushed out some changes to their code audio code that I'm compiling now in hopes that this fixes it for now.

    Oh and I have used the 1.0.24 script but updated it for 1.0.25 and gotten the above error. The issue isn't your script I'm afraid but rather ALSA failing to compile on the installed kernel - no PPA version available either. IF I'm required to run the latest stable ALSA I may have to downgrade the kernel and then try your script again. I may also be forced to move to 11.04 at which point I'll be pulling my hair out getting rid of Unity I fear. I'll also likely be having to create, again, an .asoundrc file to get hardware working unless this ALSA performs some magic.

    I gotta' say, and I know it's not your fault, sound on Linux (still) seems to be a real mess! Your script appears to do everything right near as I can tell and for that I thank you. I had just hoped for a solution that doesn't force me to make major changes to my systems (yes multiple machines).

  7. #187
    Join Date
    Dec 2007
    Beans
    82

    Re: ALSA Upgrade Script Redux

    I get choppy audio or no audio at all.

    http://www.alsa-project.org/db/?f=87...54966a3132289c

    Ideally, I want all audio (e.g. from VLC, Flash in chromium, etc.) to come out of pc speaker, except for skype whcih should use my usb headset.

    Sonja

  8. #188
    Join Date
    Feb 2008
    Location
    Venezuela
    Beans
    5
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: ALSA Upgrade Script Redux

    Installed 1.0.25 upgrade on Precise Pangolin and works perfect.

    Thank you for your work!

  9. #189
    Join Date
    Jun 2012
    Beans
    7

    Re: ALSA Upgrade Script Redux

    Hello,

    The script is not working for me .. it fails when using -c and gives me :
    alsa-oss-1.0.25 not found

    I have : Linux deb64 3.2.0-2-amd64

    I have tried the older script .. no luck .. says : alsa-firmware-1.0.24.1 not found though I have downloaded this package from source, compiled it and installed it.
    Any clue ?
    Last edited by amermc; June 24th, 2012 at 08:27 AM.

  10. #190
    Join Date
    Jun 2012
    Beans
    7

    Re: ALSA Upgrade Script Redux

    I have not completed the scrip steps ... my mixer is functioning again and also sound.

    Thanks
    Last edited by amermc; June 24th, 2012 at 09:43 AM.

Page 19 of 22 FirstFirst ... 91718192021 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •