Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: iFolder server & problem with Simias server

  1. #11
    Join Date
    Oct 2006
    Location
    Montreal
    Beans
    228
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: iFolder server & problem with Simias server

    You will find all the post-installation instructions in /usr/share/doc/
    Good luck
    Because things are the way they are, things will not stay the way they are.

  2. #12
    Join Date
    Oct 2010
    Beans
    54
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: iFolder server & problem with Simias server

    Quote Originally Posted by druhboruch View Post
    You will find all the post-installation instructions in /usr/share/doc/
    Good luck
    Great! Many thanks for your help. Everything now works
    Last edited by mr.interested; February 5th, 2011 at 12:05 AM.

  3. #13
    Join Date
    Oct 2010
    Beans
    54
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: iFolder server & problem with Simias server

    The very last question: how can I change admin's password?

    In the file /usr/share/doc/ifolder3-enterprise/README.Debian it states:

    Code:
    $ simias-user modify --url http://localhost --admin-name admin --admin-password simias --user admin --password <NEWPASSWORD>
    And here (http://wiki.inisec.com/index.php/Ifolder-ola#Admin_User), which is referred to in the above file, it states:

    Code:
    mono /usr/lib/simias/bin/UserCmd.exe modify --url http://localhost --admin-name admin --admin-password simias --user admin --password <NEWPASSWORD>
    I've tried both commands and I get the following errors:

    Code:
    -bash: syntax error near unexpected token `newline'
    Is there any other way to change the password?

  4. #14
    Join Date
    Oct 2006
    Location
    Montreal
    Beans
    228
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: iFolder server & problem with Simias server

    The method from /usr/share/doc/ worked for me.
    Because things are the way they are, things will not stay the way they are.

  5. #15
    Join Date
    Oct 2010
    Beans
    54
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: iFolder server & problem with Simias server

    Quote Originally Posted by druhboruch View Post
    The method from /usr/share/doc/ worked for me.
    It worked now. I had to delete brackets (stupid I'm). Thanks for your help.

  6. #16
    Join Date
    Nov 2010
    Beans
    15

    Re: iFolder server & problem with Simias server

    Hey, I've followed the methods in this thread, and I can access the http://myserver.com/admin panel without problem, however, I can *not* log in with the "admin/simias" usrname/pw combo, nor can I change the admin password using the "simias-user modify" command, it spits out a "Failed - Invalid admin credentials" error. What do I do?

  7. #17
    Join Date
    Feb 2011
    Beans
    1

    Re: iFolder server & problem with Simias server

    Quote Originally Posted by Cybertrash View Post
    Hey, I've followed the methods in this thread, and I can access the http://myserver.com/admin panel without problem, however, I can *not* log in with the "admin/simias" usrname/pw combo, nor can I change the admin password using the "simias-user modify" command, it spits out a "Failed - Invalid admin credentials" error. What do I do?
    dafualt user/password is admin/admin. you can find the default configuration at /var/lib/simias/Simias.config

  8. #18
    Join Date
    Mar 2011
    Beans
    4

    Re: iFolder server & problem with Simias server

    Everything seems to work fine using the 'ppa:marceloshima/ifolder' by executing 'apt-get install ifolder3-enterprise'

    And i also did 'ln -sf /etc/ifolder-server/apache/ifolder_apache.conf /etc/apache2/conf.d/'
    and 'a2ensite default-ssl' and '/etc/init.d/apache2 restart'.

    But when I try to access the 'http://my_server_adress/admin/' I get this error:
    Server Error in '/admin' Application

    An exception was thrown by the type initializer for Novell.iFolderWeb.Admin.Global

    Description: HTTP 500. Error processing request.

    Stack Trace:

    System.TypeInitializationException: An exception was thrown by the type initializer for Novell.iFolderWeb.Admin.Global
    at ASP.global_asax..ctor () [0x00000]
    at (wrapper managed-to-native) System.Reflection.MonoCMethod:InternalInvoke (object,object[],System.Exception&)
    at System.Reflection.MonoCMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000]

    Version information: Runtime: Mono 2.4.4; ASP.NET Version: 2.0.50727.1433


    Any clues what this is all about?

    Many thanx in advance
    G

  9. #19
    Join Date
    Mar 2011
    Beans
    4

    Re: iFolder server & problem with Simias server

    Quote Originally Posted by gube View Post
    Everything seems to work fine using the 'ppa:marceloshima/ifolder' by executing 'apt-get install ifolder3-enterprise'

    And i also did 'ln -sf /etc/ifolder-server/apache/ifolder_apache.conf /etc/apache2/conf.d/'
    and 'a2ensite default-ssl' and '/etc/init.d/apache2 restart'.

    But when I try to access the 'http://my_server_adress/admin/' I get this error:
    Server Error in '/admin' Application

    An exception was thrown by the type initializer for Novell.iFolderWeb.Admin.Global

    Description: HTTP 500. Error processing request.

    Stack Trace:

    System.TypeInitializationException: An exception was thrown by the type initializer for Novell.iFolderWeb.Admin.Global
    at ASP.global_asax..ctor () [0x00000]
    at (wrapper managed-to-native) System.Reflection.MonoCMethod:InternalInvoke (object,object[],System.Exception&)
    at System.Reflection.MonoCMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000]

    Version information: Runtime: Mono 2.4.4; ASP.NET Version: 2.0.50727.1433


    Any clues what this is all about?

    Many thanx in advance
    G
    Problem Solved!

    apt-get install liblog4net1.2-cil

    did the trick.

    "Me very happy man"

    /G

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •