Page 44 of 48 FirstFirst ... 344243444546 ... LastLast
Results 431 to 440 of 476

Thread: Asus Eee PC 1015PN - graphic cards: Optimus and ION

  1. #431
    Join Date
    Mar 2013
    Beans
    5

    Re: Asus Eee PC 1015PN - graphic cards: Optimus and ION

    hi I have a problem:
    I have installed mint(mate) and everything worked, installed bumblebee and so on

    but after I installed your script (eee1015pn-acpitools) gdm won't start and if I start display-settings in the console there comes:
    "ERROR: Could not find nvidia.ko kernel module. Adjust the path manually in the Variables section of the display-settings script"
    if i remove your script my netbook the gdm start...but so I get an error

    have I to write in the file like the message says (but which file exactly -> you conf file says nothing about the nvidia.ko file or so) or is Linux Mint 14.1 Mate simply not supportet? :/



    oh and btw: with 12.10 and so i have no problems with your script - but i wanted to use linux mint so i would like to fix this error


    so far ~ panda

  2. #432
    Join Date
    Mar 2013
    Beans
    4

    Re: Asus Eee PC 1015PN - graphic cards: Optimus and ION

    Quote Originally Posted by mtron View Post
    Yes. Here is what i did:

    - default install from usb-stick. no updates during install

    - rebooted

    edited /etc/apt/sources.list (not via gui!)

    Code:
    # See http://help.ubuntu.com/community/UpgradeNotes
    
    ## Ubuntu 12.04.1 LTS main archive
    deb http://archive.ubuntu.com/ubuntu precise main restricted universe multiverse
    
    ## Major bug fix and security updates 
    deb http://archive.ubuntu.com/ubuntu precise-updates main restricted universe multiverse
    deb http://archive.ubuntu.com/ubuntu precise-security main restricted universe multiverse
    
    ## N.B. software from this repository may not have been tested as
    ## extensively as that contained in the main release, although it includes
    ## newer versions of some applications which may provide useful features.
    ## Also, please note that software in backports WILL NOT receive any review
    ## or updates from the Ubuntu security team.
    deb http://archive.ubuntu.com/ubuntu precise-backports main restricted universe multiverse
    
    ## Uncomment the following two lines to add software from Canonical's
    ## 'partner' repository.
    ## This software is not part of Ubuntu, but is offered by Canonical and the
    ## respective vendors as a service to Ubuntu users.
    deb http://archive.canonical.com/ubuntu precise partner
    
    ## This software is not part of Ubuntu, but is offered by third-party
    ## developers who want to ship their latest software.
    deb http://extras.ubuntu.com/ubuntu precise main
    - only syc online repositories, don't actually install updates
    Code:
    sudo apt-get update
    - install the ee1015pn-acpitools package
    Code:
    sudo apt-get install eee1015pn-acpitools
    and i get:

    Code:
    The following NEW packages will be installed:
      acpi acpi-call-dkms acpi-call-source bbswitch-dkms build-essential debhelper
      dh-apparmor dkms dpkg-dev eee1015pn-acpitools fakeroot g++ g++-4.6 gettext
      html2text intltool-debian libalgorithm-diff-perl libalgorithm-diff-xs-perl
      libalgorithm-merge-perl libdpkg-perl libgettextpo0 libgif4 libglade2-0
      libid3tag0 libimlib2 libmail-sendmail-perl libobrender27 libobt0
      libstdc++6-4.6-dev libsys-hostname-long-perl libtimedate-perl libunistring0
      mesa-utils module-assistant nvidia-current nvidia-settings obconf openbox
      openbox-themes po-debconf screen-resolution-extra yad
    the 'nvidia-current' driver comes in this case from the ubuntu "precise-updates" repository and is the nvidia binary blob version 295.40

    install works fine:

    Code:
    Setting up nvidia-current (295.40-0ubuntu1.3) ...
    update-alternatives: using /usr/lib/nvidia-current/ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in auto mode.
    update-alternatives: warning: skip creation of /usr/lib32/libOpenCL.so because associated file /usr/lib32/nvidia-current/libOpenCL.so (of link group i386-linux-gnu_gl_conf) doesn't exist.
    update-alternatives: warning: skip creation of /usr/lib32/vdpau/libvdpau_nvidia.so.1 because associated file /usr/lib32/nvidia-current/vdpau/libvdpau_nvidia.so.1 (of link group i386-linux-gnu_gl_conf) doesn't exist.
    update-alternatives: warning: skip creation of /usr/lib32/libvdpau_nvidia.so because associated file /usr/lib32/nvidia-current/vdpau/libvdpau_nvidia.so (of link group i386-linux-gnu_gl_conf) doesn't exist.
    update-alternatives: using /usr/lib/nvidia-current/alt_ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in auto mode.
    update-initramfs: deferring update (trigger activated)
    INFO:Enable nvidia-current
    DEBUG:Parsing /usr/share/nvidia-common/quirks/dell_latitude
    DEBUG:Parsing /usr/share/nvidia-common/quirks/put_your_quirks_here
    DEBUG:Parsing /usr/share/nvidia-common/quirks/lenovo_thinkpad
    DEBUG:Processing quirk Latitude E6530
    DEBUG:Failure to match ASUSTeK Computer INC. with Dell Inc.
    DEBUG:Quirk doesn't match
    DEBUG:Processing quirk ThinkPad T420s
    DEBUG:Failure to match ASUSTeK Computer INC. with LENOVO
    DEBUG:Quirk doesn't match
    Loading new nvidia-current-295.40 DKMS files...
    First Installation: checking all kernels...
    Building only for 3.2.0-32-generic-pae
    Building for architecture i686
    Building initial module for 3.2.0-32-generic-pae
    Done.
    
    bbswitch:
    Running module version sanity check.
     - Original module
       - No original module exists within this kernel
     - Installation
       - Installing to /lib/modules/3.2.0-32-generic-pae/updates/dkms/
    
    depmod....
    
    DKMS: install completed.
    - also the glx libs are properly created and everything works here.
    Code:
    sudo display-settings fix
    ...
    INFO: mesa glx MD5 sums are
          4f5109cec4bee6e1edfe4cc03c3f3d8c
          4f5109cec4bee6e1edfe4cc03c3f3d8c
    INFO: mesa checksums OK
    INFO: nvidia glx MD5 sums are
          ab5d73191f397fbe120eb63001d5623c
          ab5d73191f397fbe120eb63001d5623c
    INFO: nvidia checksums OK
    ...

    so i cant reproduce this at this stage. i will try to actually install all system updates after initial install but i can't see a reason why it should break then. I need very percise steps to reproduce this bug please.

    EDIT: next try. this time install all upgrades, updated kernel and nvidia drivers via x-swat ppa:
    - basic install usb stick
    - sources.list update as above
    - full system update
    Code:
    sudo apt-get update && sudo apt-get dist-upgrade
    - install latest 3.5 kernel from quantal for precise
    Code:
    sudo apt-get install linux-image-generic-lts-quantal linux-headers-generic-lts-quantal
    - add the x-swat and eee1015pn ppa
    Code:
    sudo add-apt-repository ppa:mtron/eee1015pn 
    sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
    sudo apt-get update && sudo apt-get dist-upgrade
    - reboot into 3.5 kernel
    - install acpitools and nvidia driver
    Code:
    sudo apt-get install eee1015pn-acpitools
    now it's kernel 3.5 with nvidia binary blob 304.84 and again everything works here. No idea what's wrong in your case.

    So tonight I tried a lot of stuff to get it working again. Long story short, none of your suggestions worked. Either I again could not install nvidia-current (when using your first suggestion) or I couldn't get the X server to load (with your second suggestion), so same as before essentially.
    Then I noticed from your sources.list that it says "Ubuntu 12.04.1 LTS". The image I downloaded a couple days ago is 12.04.2 LTS. This one already comes with the 3.5 kernel, so in your second suggestion I didn't have a choice of installing it, it was already there. So I reinstalled everything once again using the installation for 12.04.1, and almost everything works as before, the only exception being that I have to use Intel mode all the time to have a quiet computer (low fan noise). When I switch to optimus mode the temperature shown by Jupiter increases by 10°C and the fan starts working more, on my old installation for some reason optimus mode was quiet as well. But I can live with that.
    So now I use kernel 3.2.0.39, could it be that the kernel 3.5 messes up some stuff which lead to all the errors? I didn't try installing kernel 3.5 manually now, as this is my only computer and I am pretty sick of testing and reinstalling, at the moment I am just relieved it all works again.

  3. #433
    Join Date
    Mar 2013
    Beans
    2

    Re: Asus Eee PC 1015PN - graphic cards: Optimus and ION

    Quote Originally Posted by ebilpanda View Post
    hi I have a problem:

    but after I installed your script (eee1015pn-acpitools) gdm won't start and if I start display-settings in the console there comes:
    "ERROR: Could not find nvidia.ko kernel module. Adjust the path manually in the Variables section of the display-settings script"
    if i remove your script my netbook the gdm start...but so I get an error
    Same problem with my mint 14, but just since last week...

  4. #434
    Join Date
    Mar 2013
    Beans
    2

    Re: Asus Eee PC 1015PN - graphic cards: Optimus and ION

    Hi all, I come and sorry my bad english
    My name is Maurizio and I also have a beautiful 1015PN
    In next week i last week I installed ubuntu 12.04.02 amd64 with new Nvidia driver 310.32 (from PPA xorg-edger) and everything works fine.

    Then I installed the acpitools and I encountered the following problem:
    - If I start
    HTML Code:
    sudo display-settings status
    I have not answer
    - Also on the startup screen (user logon) if I move the mouse the screen goes black and (it is my impression) restarts the xserver

    Can you help me to solve the problem
    Thanks to all
    Maurizio

  5. #435
    Join Date
    Feb 2005
    Location
    EU
    Beans
    549
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Asus Eee PC 1015PN - graphic cards: Optimus and ION

    Quote Originally Posted by talksloudsaysnothing View Post
    Then I noticed from your sources.list that it says "Ubuntu 12.04.1 LTS". The image I downloaded a couple days ago is 12.04.2 LTS. This one already comes with the 3.5 kernel, so in your second suggestion I didn't have a choice of installing it, it was already there.
    As you see i tested both and both work for me.

    Quote Originally Posted by talksloudsaysnothing View Post
    So now I use kernel 3.2.0.39, could it be that the kernel 3.5 messes up some stuff which lead to all the errors?
    Probably. Let's see if all kernel modules are build for all kernels. Post the outout of
    Code:
    dkms status
    Quote Originally Posted by muskelbiber View Post
    Same problem with my mint 14, but just since last week...
    thanks for the bugreport. i have pushed a fix to the bzr repository. Could you please test it? (replace /usr/bin/display-settings with this revision 120. then mark it executeable with chmod +x /usr/bin/display-settings )

    Quote Originally Posted by ebilpanda View Post
    but after I installed your script (eee1015pn-acpitools) gdm won't start and if I start display-settings in the console there comes:
    "ERROR: Could not find nvidia.ko kernel module. Adjust the path manually in the Variables section of the display-settings script"
    hello! this is the same bug as muskelbiber refers to. Fix should be in bzr.

    Quote Originally Posted by ebilpanda View Post
    is Linux Mint 14.1 Mate simply not supportet? :/
    No, Linux Mint support was written by a contributor because i don't use it. There should have been a warning in the debug output that your distro is not supported and that the ubuntu fallback will be used. I have enabled mint 14 support now but i don't want to include mint 14 support without ever testing it. Could you please download the latest version of the /usr/bin/display-settings script from bzr (see the answer to muskelbiber question above) and test it?
    Last edited by mtron; March 27th, 2013 at 02:19 PM.
    Ubuntu for the EeePC-1015PN

  6. #436
    Join Date
    Mar 2013
    Beans
    5

    Re: Asus Eee PC 1015PN - graphic cards: Optimus and ION

    Quote Originally Posted by mtron View Post
    No, Linux Mint support was written by a contributor because i don't use it. There should have been a warning in the debug output that your distro is not supported and that the ubuntu fallback will be used. I have enabled mint 14 support now but i don't want to include mint 14 support without ever testing it. Could you please download the latest version of the /usr/bin/display-settings script from bzr (see the answer to muskelbiber question above) and test it?
    ah thank you!
    with this your script is working with Linux Mint!
    afaik everythink is working (optimus start, nvidia on (on/off handled by bumblebee ), haven't tried the shortcuts (no need for me ) yet

  7. #437
    Join Date
    Feb 2005
    Location
    EU
    Beans
    549
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Asus Eee PC 1015PN - graphic cards: Optimus and ION

    Quote Originally Posted by ebilpanda View Post
    with this your script is working with Linux Mint!
    ok Thanks.I will enable mint 14 support with the next release. one more bugfix related to nvidia mode: Can you please test with the latest revision 120 if glx & vdpau works in nvidia mode? open nvidia-settings and see if Direct Rendering says 'Yes' on the 'GLX Information' tab.

    Cheers!
    Last edited by mtron; March 27th, 2013 at 02:20 PM.
    Ubuntu for the EeePC-1015PN

  8. #438
    Join Date
    Mar 2013
    Beans
    5

    Re: Asus Eee PC 1015PN - graphic cards: Optimus and ION

    Quote Originally Posted by mtron View Post
    ok Thanks.I will enable mint 14 support with the next release. one more bugfix related to nvidia mode: Can you please test with the latest revision 120 if glx & vdpau works in nvidia mode? open nvidia-settings and see if Direct Rendering says 'Yes' on the 'GLX Information' tab.

    hmm i can't get nvidia-settings to get started ^^' it days that i'm not using the nvidia x driver and that I should run "nvidia-xconfig" as root (already done and restarted with only nvidia mode) but the error won't go away :/

    oh and glxspheres is not working in nvidia only mode for me :/

    in optimus mode glxspheres and so on is working
    Last edited by ebilpanda; March 27th, 2013 at 02:53 PM. Reason: added the quote :)

  9. #439
    Join Date
    Feb 2005
    Location
    EU
    Beans
    549
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Asus Eee PC 1015PN - graphic cards: Optimus and ION

    hm. tricky. heres the next try rev 122. if nvidia mode fails again please add the /var/log/Xorg.0.log. (or Xorg.1.log... just use the one with the most recent modification time)

    also check if the right ld.so.conf is linked by update-alternatives.
    Code:
    update-alternatives --get-selections | grep i386-linux-gnu_gl_conf
    this should output a manual link to /usr/lib/nvidia-current/ld.so.conf
    Ubuntu for the EeePC-1015PN

  10. #440
    Join Date
    Mar 2013
    Beans
    5

    Re: Asus Eee PC 1015PN - graphic cards: Optimus and ION

    hm. tricky. heres the next try rev 122. if nvidia mode fails again please add the /var/log/Xorg.0.log. (or Xorg.1.log... just use the one with the most recent modification time)

    also check if the right ld.so.conf is linked by update-alternatives.
    Code:

    update-alternatives --get-selections | grep i386-linux-gnu_gl_conf

    this should output a manual link to /usr/lib/nvidia-current/ld.so.conf
    hmm nvidia-settings are still not working
    i used you display-settings (copied to /usr/bin) and restartet - now the resolution was good and so on but nvidia still fails
    -> i used the command nvidia tells me and relogged -> still xserver error by nvidia
    ->if i user your command:

    Code:
    $ update-alternatives --get-selections | grep i386-linux-gnu_gl_conf
    i386-linux-gnu_gl_conf         manual   /usr/lib/nvidia-current/ld.so.conf


    and here my xorg.0.log:

    http://pastebin.com/QsBYCWNu
    Last edited by ebilpanda; March 27th, 2013 at 04:14 PM.

Page 44 of 48 FirstFirst ... 344243444546 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •