Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Disable Touchpad on Sony Vaio E Series (VPCEC2COE)

  1. #1
    Join Date
    Jan 2008
    Location
    London
    Beans
    111

    Disable Touchpad on Sony Vaio E Series (VPCEC2COE)

    Hi,

    I have a Sony Vaio laptop. Nice machine and works well and fast.

    Only problem came up recently: the touchpad wasn't working at all. Then, when I upgraded to 10.10 it started working all of a sudden, but it's not recognised as a touchpad and I can't easily disable it through the preferences.

    I keep hitting the damn thing while typing too

    Is there a way that I can switch it off the hard way?

    Here is the ixinput output:

    Code:
    ⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
    ⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
    ⎜   ↳ Razer Razer Imperator                   	id=10	[slave  pointer  (2)]
    ⎜   ↳ Razer Razer Imperator                   	id=11	[slave  pointer  (2)]
    ⎜   ↳ ImPS/2 Generic Wheel Mouse              	id=13	[slave  pointer  (2)]
    ⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
        ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
        ↳ Sony Vaio Keys                          	id=6	[slave  keyboard (3)]
        ↳ Video Bus                               	id=7	[slave  keyboard (3)]
        ↳ Power Button                            	id=8	[slave  keyboard (3)]
        ↳ USB 2.0 Camera                          	id=9	[slave  keyboard (3)]
        ↳ AT Translated Set 2 keyboard            	id=12	[slave  keyboard (3)]
    Any help much appreciated.
    I will keep trying and post the output here...

    thanks
    Ubuntu - free and good!

    d3ngar's blog (don't post often)

  2. #2
    Join Date
    Jan 2010
    Location
    65 AD
    Beans
    304
    Distro
    Ubuntu Development Release

    Re: Disable Touchpad on Sony Vaio E Series (VPCEC2COE)

    Place this script to toggle your touchpad in a file:

    Code:
    # toggle synaptic touchpad on/off
    SYNSTATE=$(xinput list-props "ImPS/2 Generic Wheel Mouse" | grep Enabled | grep -Eo '.$')
    if [ $SYNSTATE = 0 ]; then xinput set-int-prop "ImPS/2 Generic Wheel Mouse" "Device Enabled" 8 1
    else xinput set-int-prop "ImPS/2 Generic Wheel Mouse" "Device Enabled" 8 0; fi
    move it to /usr/bin then you can toggle your touchpad by pressing alt/f2 and typing the name of the script.

    you can also go to "gnome-keybinding-properties" and add a new shortcut using the path to the script for the command (/usr/bin/name of script) and make a keyboard shortcut.

    To disable automatically you can add this command to startup applications
    Code:
    xinput set-prop "ImPS/2 Generic Wheel Mouse" "Device Enabled" 0

  3. #3
    Join Date
    Jan 2008
    Location
    London
    Beans
    111

    Re: Disable Touchpad on Sony Vaio E Series (VPCEC2COE)

    Quote Originally Posted by pi/roman View Post
    Place this script to toggle your touchpad in a file:

    Code:
    # toggle synaptic touchpad on/off
    SYNSTATE=$(xinput list-props "ImPS/2 Generic Wheel Mouse" | grep Enabled | grep -Eo '.$')
    if [ $SYNSTATE = 0 ]; then xinput set-int-prop "ImPS/2 Generic Wheel Mouse" "Device Enabled" 8 1
    else xinput set-int-prop "ImPS/2 Generic Wheel Mouse" "Device Enabled" 8 0; fi
    move it to /usr/bin then you can toggle your touchpad by pressing alt/f2 and typing the name of the script.

    you can also go to "gnome-keybinding-properties" and add a new shortcut using the path to the script for the command (/usr/bin/name of script) and make a keyboard shortcut.

    To disable automatically you can add this command to startup applications
    Code:
    xinput set-prop "ImPS/2 Generic Wheel Mouse" "Device Enabled" 0
    Excellent, this really did the trick right away. I couldn't be happier
    Ubuntu - free and good!

    d3ngar's blog (don't post often)

  4. #4
    Join Date
    Aug 2011
    Beans
    1

    Re: Disable Touchpad on Sony Vaio E Series (VPCEC2COE)

    I too have a sony vaio...and I really really need to disable this damn mousepad....h


    how exactly do I place script into the folder you described? I've already bumped into the damn thing eleven times just typing these two sentences. I'm fairly new to ubuntu, and by that virtue...Linux

  5. #5
    Join Date
    Apr 2011
    Location
    Tallahassee, FL
    Beans
    10
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Disable Touchpad on Sony Vaio E Series (VPCEC2COE)

    I also have the same problem with touchpad. Needed to off sometimes. but don't know how to. I am completely new to Ubuntu, so I don't know much. Can you please let me know how to do turn off and on the touch pad? I mean, can you please give me some more additional details like how to write the script file, how to save it (name and extension) etc. Thanks.

  6. #6
    Join Date
    Aug 2011
    Location
    WNY
    Beans
    4
    Distro
    Ubuntu 11.04 Natty Narwhal

    Exclamation Disable Touchpad on Sony Vaio E Series VPC-EH14FM

    Quote Originally Posted by techtabu View Post
    I also have the same problem with touchpad. Needed to off sometimes. but don't know how to. I am completely new to Ubuntu, so I don't know much. Can you please let me know how to do turn off and on the touch pad? I mean, can you please give me some more additional details like how to write the script file, how to save it (name and extension) etc. Thanks.
    This took me a while to figure out, so I hope I can save you some frustration. The above instructions from pi/roman did not work 'out of the box' on my E Series, so I modified them. Thank you for the starting point, pi/roman! Here is how I disable the touchpad:

    - Open a terminal: click the ubuntu symbol, then type "terminal" and hit enter.
    - Create a file: type "pico /usr/bin/touchpad_toggle.script" then hit enter.
    - Paste the following into the file
    Code:
    # toggle synaptic touchpad on/off
    MOUSESTATE=$(xinput list-props "PS/2 Mouse" | grep Enabled | grep -Eo '.$')
    if [ $MOUSESTATE = 0 ]; then xinput set-int-prop "PS/2 Mouse" "Device Enabled" 8 1
    else xinput set-int-prop "PS/2 Mouse" "Device Enabled" 8 0; fi
    - Save the file: type Ctrl-X, type "Y", then hit enter.
    - Open Keyboard Shortcuts: click the ubuntu symbol, then type "Keyboard Shortcuts" and hit enter.
    - Add a new shortcut: Click Add, type "Touchpad Toggle" for the name, hit tab, type "/usr/bin/touchpad_toggle.script" for the command, then click Apply.
    - Allow the file execute mode: In a terminal, issue the following command
    Code:
    chmod +x /usr/bin/touchpad_toggle.script
    - Assign the shortcut to a key: Scroll to the bottom of the list, click on the Shortcut column of the Toggle Touchpad line, hit the ASSIST button on your keyboard, then click Close.
    -Try it out: Hit the ASSIST button on the keyboard. Your touchpad should now be disabled, and you should be able to type without accidentally clicking. Hit the ASSIST button again. Your touchpad should now be enabled.
    - Rejoice: Good work! You've done well.

    hth

    -Stafford
    Last edited by stafford.ritchie; August 12th, 2011 at 12:24 AM. Reason: Allow executing file as program

  7. #7
    Join Date
    Apr 2011
    Location
    Tallahassee, FL
    Beans
    10
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Disable Touchpad on Sony Vaio E Series (VPCEC2COE)

    Thanks stafford.. I will try it soon..

  8. #8
    Join Date
    Apr 2011
    Location
    Tallahassee, FL
    Beans
    10
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Disable Touchpad on Sony Vaio E Series (VPCEC2COE)

    I am sorry, Staffort I did not work for me. I forgot to mention that I use HP dv6-3250us. I think if I could give you the xinput out put, it may help you.

    Virtual core pointer id=2 [master pointer (3)]
    ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
    ⎜ ↳ SynPS/2 Synaptics TouchPad id=9 [slave pointer (2)]
    ⎜ ↳ Microsft Microsoft Wireless Desktop Receiver 3.1 id=15 [slave pointer (2)]
    ⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ HP Webcam id=10 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=11 [slave keyboard (3)]
    ↳ HP WMI hotkeys id=13 [slave keyboard (3)]
    ↳ Microsoft LifeChat LX-3000 id=12 [slave keyboard (3)]
    ↳ Microsft Microsoft Wireless Desktop Receiver 3.1 id=14 [slave keyboard (3)]

    Honestly, I did not understand the code, so I did not try to correct. But I hope it will be okay if I change the name of the mouse. Am I right?

  9. #9
    Join Date
    Aug 2011
    Location
    WNY
    Beans
    4
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Disable Touchpad on Sony Vaio E Series (VPCEC2COE)

    Quote Originally Posted by techtabu View Post
    [...]

    SynPS/2 Synaptics TouchPad

    [...]

    Honestly, I did not understand the code, so I did not try to correct. But I hope it will be okay if I change the name of the mouse. Am I right?
    Try replacing all occurences of "PS/2 Mouse" in your script file with "SynPS/2 Synaptics TouchPad" and let me know what happens. You can use pico or similar from the command line or use the Text Editor from the gdm to edit your existing file.

  10. #10
    Join Date
    Feb 2006
    Location
    West Yorkshire
    Beans
    6

    Re: Disable Touchpad on Sony Vaio E Series (VPCEC2COE)

    Thanks pi/roman and stafford.ritchie, my two-week-old HP Pavillion DM1 is now working 99% perfectly. HP's touchpad is a bugger to control, on that all of the reviews (using windoze 7) of this laptop agreed.
    Now I just need to get right-click tapping to work and I'll be a happy camper.

    HP Pavilion dm1-3101ea (dm1z in USA)
    LinuxMint 10 (Julia)
    Kernel 2.6.35-22 Generic
    Gnome 2.32.0

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •