Results 1 to 3 of 3

Thread: sTunnel problem: SSL3_GET_RECORD:wrong version number

  1. #1
    Join Date
    Jan 2011
    Location
    Moscow, Rusia
    Beans
    10
    Distro
    Ubuntu

    sTunnel problem: SSL3_GET_RECORD:wrong version number

    Hello!

    I'm using last version of Ubuntu in AWS cloud.
    I'm trying to use sTunnel in this system, but there are such errors in log:

    Code:
    2011.01.25 20:43:49 LOG7[6160:1700]: SSL state (connect): before/connect initialization
    2011.01.25 20:43:49 LOG7[6160:1700]: SSL state (connect): SSLv3 write client hello A
    2011.01.25 20:43:49 LOG7[6160:1700]: SSL alert (write): fatal: handshake failure
    2011.01.25 20:43:49 LOG3[6160:1700]: SSL_connect: 1408F10B: error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number
    Could please somebody help me to understand, how to solve this problem?

  2. #2
    Join Date
    Aug 2009
    Location
    Los Angeles, CA USA
    Beans
    6
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: sTunnel problem: SSL3_GET_RECORD:wrong version number

    Did you ever figure this out?

    Thanks

  3. #3
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,691
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: sTunnel problem: SSL3_GET_RECORD:wrong version number

    If a post is older than a year or so and hasn't had a new reply in that time, instead of replying to it, create a new thread. In the software world, a lot can change in a very short time, and doing things this way makes it more likely that you will find the best information. You may link to the original discussion in the new thread if you think it may be helpful.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •