Hi

One way to stop people shutting down (or rebooting) is to change the policies. This is tested on 10.04 not 10.10 but i think it should still work.

Open a terminal and type

Code:
sudo nano /usr/share/polkit-1/actions/org.freedesktop.consolekit.policy
you can change

Code:
<action id="org.freedesktop.consolekit.system.stop">
    <description>Stop the system</description>
    <message>System policy prevents stopping the system</message>
    <defaults>
      <allow_inactive>no</allow_inactive>
      <allow_active>yes</allow_active>
    </defaults>
  </action>
to

Code:
<action id="org.freedesktop.consolekit.system.stop">
    <description>Stop the system</description>
    <message>System policy prevents stopping the system</message>
    <defaults>
      <allow_inactive>no</allow_inactive>
      <allow_active>no</allow_active>
    </defaults>
  </action>
You can do the same for the reboot section. When i change it on my laptop, if i try to shutdown it will just log me out.

You can disable the power button by typing (if i remember correctly)

Code:
sudo chmod 0 /etc/acpi/powerbtn.sh
You might also want to disable shutdown from the logon screen.

Kind regards