Results 1 to 2 of 2

Thread: HUAWEI E1630 HSDPA USB Modem drops connectivity

  1. #1
    Join Date
    Oct 2008
    Beans
    8

    Unhappy HUAWEI E1630 HSDPA USB Modem drops connectivity

    Hi All,

    I recently got a HUAWEI E1630 HSDPA USB Modem and it was working fine until recently. Recently it starts to drop the connection and in /var/log/messages I can see a pppd error "Protocol-Reject for unsupported protocol xxxx". The protocol number is random. Only way to resume is to unplug and replug the device. The happens very frequently and hence the device is not usable.

    To isolate the service provider end, I use the same SIM on a PROLINK HSDPA USB Modem and it works fine. Also I use a different SIM from another service provider in this device and the issue still exists.

    I am on Kubuntu 10.10 with all the updates to date. Should I report a bug?

    Appreciate any support to rectify this.

  2. #2
    Join Date
    Oct 2008
    Beans
    8

    Thumbs up Re: HUAWEI E1630 HSDPA USB Modem drops connectivity

    The issue is discussed here http://forum.huawei.com/jive4/thread...=0&orderStr=26. A circuit like this (http://www.acomelectronics.com/Georg...0fix_foto.html) can be used to fix this issue at hardware level.

    However, I just use a cheap USB hub which gave the required power stability and now the USB Modem works fine.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •