Page 31 of 34 FirstFirst ... 212930313233 ... LastLast
Results 301 to 310 of 336

Thread: HOWTO: Grub Customizer

  1. #301
    Join Date
    Aug 2005
    Beans
    47
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: Grub Customizer

    Unfortunately I was correct. I had already gone down that path, and removed "quiet splash".

    Here is my /etc/default/grub :
    Code:
    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    # For full documentation of the options in this file, see:
    #   info -f grub -n 'Simple configuration'
    
    GRUB_DEFAULT="0"
    #GRUB_HIDDEN_TIMEOUT="0"
    #GRUB_HIDDEN_TIMEOUT_QUIET="true"
    GRUB_TIMEOUT="10"
    GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
    GRUB_CMDLINE_LINUX_DEFAULT=""
    GRUB_CMDLINE_LINUX=""
    
    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"
    
    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL="console"
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    GRUB_GFXMODE="1024x768x32"
    
    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID="true"
    
    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_RECOVERY="true"
    
    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"
    
    GRUB_DISABLE_OS_PROBER="true"
    Is there anything else that you see which I should do? I suppose this is not a Grub Customizer issue, so if you want me to post in a new thread, just let me know...

    Thank you.
    | | | | | | | |
    If they give you lined paper, write sideways.
    Daniel Quinn

  2. #302
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: HOWTO: Grub Customizer

    Quote Originally Posted by beebelo View Post
    Unfortunately I was correct. I had already gone down that path, and removed "quiet splash".
    Is there anything else that you see which I should do? I suppose this is not a Grub Customizer issue, so if you want me to post in a new thread, just let me know...

    Thank you.
    Grub Customizer can alter and move certain Grub configuration files, so making the change to /etc/default/grub may not be the file that GC uses to configure the menu. (It may be, I just don't know.)

    So the next thing would be to look at the Grub menu during boot by the method I described in the last paragraph of my earlier post. See if "quiet splash" exists on the 'linux' line or not. If it is there, try removing it and boot.

    If the 'quiet splash' is in the menu and you ran update-grub earlier, then another GC file may be creating the menu and we'll have to deal with it. If 'quiet splash' is not in the actual Grub menu I'll have to give this more consideration.
    GRUB2

    Retired.

  3. #303
    Join Date
    Aug 2005
    Beans
    47
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: Grub Customizer

    Quote Originally Posted by drs305 View Post
    If 'quiet splash' is not in the actual Grub menu I'll have to give this more consideration.
    ... it's not there in the actual Grub menu

    I also searched the files in /etc/grub.d/ . I found this in 10_linux :
    Code:
      linux_entry "${OS}" "${version}" false \
          "${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_EXTRA} ${GRUB_CMDLINE_LINUX_DEFAULT}" \
          quiet
      if [ "x${GRUB_DISABLE_RECOVERY}" != "xtrue" ]; then
        if [ -x /lib/recovery-mode/recovery-menu ]; then
          linux_entry "${OS}" "${version}" true \
            "recovery nomodeset ${GRUB_CMDLINE_LINUX}"
        else
          linux_entry "${OS}" "${version}" true \
            "single nomodeset ${GRUB_CMDLINE_LINUX}"
        fi
      fi
    Don't know what is happening there exactly... or what the \ means in the line above 'quiet'. Does the \ just mean continued on the next line, like _ in visual basic?
    | | | | | | | |
    If they give you lined paper, write sideways.
    Daniel Quinn

  4. #304
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: HOWTO: Grub Customizer

    Quote Originally Posted by beebelo View Post
    ... it's not there in the actual Grub menu

    Don't know what is happening there exactly... or what the \ means in the line above 'quiet'. Does the \ just mean continued on the next line, like _ in visual basic?
    Yes, that is exactly what it means in this case.

    I always combine "quiet splash" and you said it wasn't in the menu, which is what I asked. Is "quiet" there? From the line in 10_linux it looks like it should be.

    Since Grub Customizer can use some 'proxified' files/folders rather than the default ones, it might be helpful to see your entire setup by running the boot info script. You can run it (see the BIS link in my signature) from within Boot Repair, after installing that useful app.
    GRUB2

    Retired.

  5. #305
    Join Date
    Aug 2005
    Beans
    47
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: Grub Customizer

    'Morning -

    1) The word "quiet" is not shown anywhere in my Grub menu when I press "e"
    2) So I installed BIS as you recommended. The output it gave me is: http://paste.ubuntu.com/1129244/
    Last edited by beebelo; August 4th, 2012 at 06:28 PM. Reason: updated 10_linux to original state, and re-ran BIS after sudo update-grub; updated the link
    | | | | | | | |
    If they give you lined paper, write sideways.
    Daniel Quinn

  6. #306
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: HOWTO: Grub Customizer

    beebelo,

    Thanks for posting the information. I really can't see why you can't get the scrolling text to appear. I can think of two things you can try, but these really shouldn't be necessary and may still not display the messages.

    Both involve editing the GRUB preferences file and changing default settings.
    Code:
    gksu gedit /etc/default/grub
    Uncommenting this line would eliminate graphics from Grub (at least until later):
    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL="console"
    The other thing you could try would be to use the basic graphics resolution:
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    GRUB_GFXMODE="auto"
    GRUB_GFXMODE=640x480
    Make one of the changes, update-grub, and see what happens. If the first one doesn't work, restore the original setting and try the other.

    Background: Not seeing the scrolling text during the boot process really is controlled by the kernel and not by GRUB. The messages are system messages from the OS you are using, not Grub - Grub merely provides a way to pass the parameter (quiet) to the system boot so that the messages are displayed. For some reason it isn't happening on your system. It may have something to do with the kernel you are using but I really don't know.

    The two ideas above take the graphics out of the GRUB process. In theory I don't think this should affect what the kernel does, but let's see.

    The only other thing I can think of at the moment would be to add "text" to the end of the linux options. This boots Ubuntu to the terminal login prompt. It isn't something that you would want to do often, but if you were trying to view the boot messages for troubleshooting purposes it might work.
    Last edited by drs305; August 4th, 2012 at 08:56 PM.
    GRUB2

    Retired.

  7. #307
    Join Date
    Feb 2010
    Location
    Nr BrandsHatch, S'oaks UK
    Beans
    1,241
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: HOWTO: Grub Customizer

    Hi!, drs305 & beebelo.
    Edit: In one of MAFoElffen's 'Blank screen Sticky' Posts he suggested that in some kernal versions 'text' in the linux options did not work. I have found that setting the Grub background in GC can have the same result.

    I do not know if this is relevant to your current 'no text messages' problem, but you may find it interesting.

    On one of my desktops I have two 12.04 installations; A is a direct install of 12.04 -pae, B is an updated version of 12.04 LTS -generic [not -pae] - originally 9.10.

    Both are fully updated to 3.2.0-27 #43 with grub2 & GC controlled from B, so when I boot A to 12.04 pae the Grub background screen only shows for a second or so after pressing 'Enter'.
    Hence If I edit its grub script and put " --verbose text " in place of " quiet splash " I get the full display of system messages before the TTY login prompt. If I then press 'Crtl+Alt+F7' the last messages are displayed with a hanging cursor, ending with "Checking Battery State [OK]".

    With " --verbose text " in place in B, the Grub background screen continues to display for about 30 seconds, goes to a blank black screen for a moment, and then shows the TTY login prompt, but no messages. Pressing 'Crtl+Alt+F7' gives a blank black screen with a flashing cursor top left.

    In other words, in some way Grub Customizer is preventing the 'text' option from giving a display, or it is 'hidden' behind the background.
    Presumably, if the grub background was set to a blank screen, it could have the same effect.

    Chao!, bogan.
    Last edited by bogan; August 5th, 2012 at 04:26 PM. Reason: note added
    "Better Solutions may bring Worsened Problems": After Lao Tse, b. circa 405BC. a contemporary of Confucius, who died circa 600BC.
    They did things differently in those days, apparently!!

  8. #308
    Join Date
    Aug 2005
    Beans
    47
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: Grub Customizer

    Quote Originally Posted by drs305 View Post
    Uncommenting this line would eliminate graphics from Grub (at least until later):
    Right, and that does in fact work. I've done it both from GC and by way of manual edit. It displays all the messages I wanted to see, albeit in a most ugly way (huge text that wraps around, and scrolls too fast to see because of its size). But the important point is that yes, it works.


    Quote Originally Posted by drs305 View Post
    The other thing you could try would be to use the basic graphics resolution:
    I will try it with the 640x480 res as soon as I get a chance (late tonight). The setting "auto" is a recent change I made for trial purposes. Previously I had tried 800x600 and 1024x768, with and without the color depth setting, "x32"

    Thanks for the information about the process itself and where GRUB ends and the kernel picks up. That may be useful. I'm using the low-latency pae stock kernel provided with Ubuntu Studio 12.04. I don't understand how the old framebuffer thing relates to booting with GRUB2 and a modern kernel. It used to be so easy in GRUB-legacy. lol

    So it just occurred to me: The vbeinfo script that I ran previously, is that information just related to the GRUB menu? Not for after the kernel takes over?

    Anyway, I'll try these later tonight and post back ...

    Quote Originally Posted by drs305 View Post
    The only other thing I can think of at the moment would be to add "text" to the end of the linux options. This boots Ubuntu to the terminal login prompt. It isn't something that you would want to do often, but if you were trying to view the boot messages for troubleshooting purposes it might work.
    Right. Well I'm not troubleshooting anything yet, just set in my ways. Going back to my first *nix experiences in the early 2000s, I've always thought watching a workstation boot up is just really cool. And I especially liked the Linux distros that did the colored messages with the green "OK" and the red "FAIL".

    Thanks again. More to come.
    | | | | | | | |
    If they give you lined paper, write sideways.
    Daniel Quinn

  9. #309
    Join Date
    Aug 2005
    Beans
    47
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: Grub Customizer

    Quote Originally Posted by bogan View Post
    In other words, in some way Grub Customizer is preventing the 'text' option from giving a display, or it is 'hidden' behind the background.
    Presumably, if the grub background was set to a blank screen, it could have the same effect.
    bogan,

    Thanks very much for that information. I will digest it and see how I can relate it to my problem. Certainly looks to be valuable info!

    beeb
    | | | | | | | |
    If they give you lined paper, write sideways.
    Daniel Quinn

  10. #310
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: HOWTO: Grub Customizer

    Quote Originally Posted by beebelo View Post
    So it just occurred to me: The vbeinfo script that I ran previously, is that information just related to the GRUB menu? Not for after the kernel takes over?

    Anyway, I'll try these later tonight and post back ...
    The vbeinfo command displays what resolutions are available before the OS boots, so it actually applies only to BIOS and GRUB and not to what resolutions are available after the OS boots.

    "gfxpayload=keep" is supposed to try to keep the same resolution between Grub and the OS, but results are mixed on its implementation.
    GRUB2

    Retired.

Page 31 of 34 FirstFirst ... 212930313233 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •