Results 1 to 9 of 9

Thread: my first problem in ubuntu

  1. #1
    Join Date
    Jan 2011
    Beans
    20

    Question my first problem in ubuntu

    hello every1..i switched to ubuntu 2day n 2day itself i found a problem... i downloaded activeperl 5.12 from a website..please note this perl is for linux and so there is no problem with software...it is a zipped filed extension.. i extracted the contents in my home folder.. installation is by terminal..
    sh install.sh then the option is to enter the top level directory ..please tell what directory should i give so that it is installed properly.. i tried /home/ActivePerl-5.12 but it doesnt work.. please help

  2. #2
    Join Date
    Jul 2007
    Location
    Magic City of the Plains
    Beans
    Hidden!
    Distro
    Kubuntu Development Release

    Re: my first problem in ubuntu

    http://docs.activestate.com/activepe...tml#installing activeperl on linux (x86)

    It says there's a *.deb available; I'd give that a try first (might be easier).

  3. #3
    Join Date
    Oct 2010
    Beans
    659

    Re: my first problem in ubuntu

    % dpkg -i ActivePerl-5.12.2.1203-i686-linux.deb
    Last edited by vivek.pandey; January 8th, 2011 at 07:25 PM.

  4. #4
    Join Date
    Jan 2011
    Beans
    20

    Re: my first problem in ubuntu

    Quote Originally Posted by oldos2er View Post
    http://docs.activestate.com/activepe...tml#installing activeperl on linux (x86)

    It says there's a *.deb available; I'd give that a try first (might be easier).
    thanx for your help

    i went through a similar procedure as given on the page for which you provided the link but problem is same.installation reqiures to enter a top level directory and as given on the page i enterd /home/ActivePerl -5.12/but same error... since i have gone through half way i want to contnue this installation

  5. #5
    Join Date
    Dec 2010
    Beans
    8

    Re: my first problem in ubuntu

    Did you install from the .deb? I don't think so.

    Is this the directory you seek?

    /opt/ActivePerl-5.12

  6. #6
    Join Date
    Jan 2011
    Beans
    20

    Re: my first problem in ubuntu

    Quote Originally Posted by TheTFo View Post
    Did you install from the .deb? I don't think so.

    Is this the directory you seek?

    /opt/ActivePerl-5.12
    yes i see that directory here is the screenshot of wats going on

    Enter top level directory for install? [/opt/ActivePerl-5.12] HERE IS THE PROBLEM

    The ActivePerl documentation is available in HTML format. If installed
    it will be available from file:///opt/ActivePerl-5.12/html/index.html.
    If not installed you will still be able to read all the basic perl and
    module documentation using the man or perldoc utilities.

    Install HTML documentation [yes] y
    Ok.

    The typical ActivePerl software installation requires 200 megabytes.
    Please make sure enough free space is available before continuing.

    Proceed? [yes] y
    Ok.

    Installing ActivePerl...
    Copying files to /opt/ActivePerl-5.12...
    Install of ActivePerl to /opt/ActivePerl-5.12 failed:

    mkdir /opt/ActivePerl-5.12: Permission denied at perl/lib/ActiveState/RelocateTree.pm line 388

    Sorry about the inconvenience. If this looks like a problem with
    the installer please report it to the ActivePerl bug database,
    available online at:

    http://bugs.ActiveState.com/ActivePerl/

    For general questions or comments about ActivePerl, please contact
    us at <support@activestate.com>.

    Thank you for trying to install ActivePerl!

  7. #7
    Join Date
    Jul 2007
    Location
    Magic City of the Plains
    Beans
    Hidden!
    Distro
    Kubuntu Development Release

    Re: my first problem in ubuntu

    To enable write access to /opt, run the install script with sudo. sudo sh ./install.sh

  8. #8
    Join Date
    Jan 2011
    Beans
    20

    Re: my first problem in ubuntu

    Quote Originally Posted by oldos2er View Post
    To enable write access to /opt, run the install script with sudo. sudo sh ./install.sh
    Thanx a lot it worked..but i have a doubt...i was already logged in admin account so y at all i needed sudo there??

  9. #9
    Join Date
    Jul 2007
    Location
    Magic City of the Plains
    Beans
    Hidden!
    Distro
    Kubuntu Development Release

    Re: my first problem in ubuntu

    The root account is locked by default in Ubuntu. Are you saying you enabled the root account, logged into it, and ran the command? If so you wouldn't have received the error "Permission denied...."

    The user account you create when installing Ubuntu is given admin privileges, but you need to use "sudo" (or gksudo for GUI programs) to access them.

    See https://help.ubuntu.com/community/RootSudo
    Last edited by oldos2er; January 8th, 2011 at 09:00 PM. Reason: more info

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •