Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: gtk-window-decorator permanent fix?

  1. #1
    Join Date
    Jan 2010
    Location
    Portland, Oregon
    Beans
    51
    Distro
    Ubuntu 12.04 Precise Pangolin

    gtk-window-decorator permanent fix?

    i turned on my computer today and POOF, no window decorations. i haven't changed ANY display/appearance settings since i installed 10.04 and did my initial setup over a month ago. now when i startup i have to "gtk-window-decorator --replace" in terminal and leave it open to have everything decorated. i had a similar problem when i used compiz but i haven't installed anything other than the nvidia driver this time.

    is there a way to find out what caused this and correct it? if not am i stuck with some sort of autostart launcher?

  2. #2
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: gtk-window-decorator permanent fix?

    So are you now using Compiz or not? ..or actually that's a stupid question, since gnome-window-decorator is a Compiz plugin and doesn't even work without Compiz...

    Anyway, open CompizConfig Settings Manager (install it if you haven't got it already), go to Window Decoration-plugin's settings and make sure the "Command"-filed is set to "/usr/bin/compiz-decorator".

  3. #3
    Join Date
    Jan 2010
    Location
    Portland, Oregon
    Beans
    51
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: gtk-window-decorator permanent fix?

    Quote Originally Posted by mechanizedmedic View Post
    i had a similar problem when i used compiz but i haven't installed anything other than the nvidia driver this time.
    i'm trying to avoid compiz... as much as is possible, i want to use what comes with ubuntu upon install.

  4. #4
    Join Date
    Oct 2005
    Location
    De Kwakel - Holland
    Beans
    3,657

    Re: gtk-window-decorator permanent fix?

    metacity --replace &

  5. #5
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: gtk-window-decorator permanent fix?

    Quote Originally Posted by mechanizedmedic View Post
    i'm trying to avoid compiz... as much as is possible, i want to use what comes with ubuntu upon install.
    Compiz and Metacity are both included in the default install.

    If you use visual effects you are using Compiz, if you turn them off you are using Metacity.

  6. #6
    Join Date
    Jan 2010
    Location
    Portland, Oregon
    Beans
    51
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: gtk-window-decorator permanent fix?

    ...i was just coming back to call myself an idiot...

    is this issue a gconf setting that i can fix?

    also, can i remove compiz and just use metacity like i was before this occured?

  7. #7
    Join Date
    Oct 2005
    Location
    De Kwakel - Holland
    Beans
    3,657

    Re: gtk-window-decorator permanent fix?

    Quote Originally Posted by mechanizedmedic View Post
    ...i was just coming back to call myself an idiot...

    is this issue a gconf setting that i can fix?

    also, can i remove compiz and just use metacity like i was before this occured?
    gconf-editor
    desktop -> gnome -> session -> required-components -> windowmanager = metacity

  8. #8
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: gtk-window-decorator permanent fix?

    The first thing you should try is setting the visual effects to "none" in System/Preferences/Appearance. That really should switch you to Metacity.

    If it doesn't work, for some strange reason I can't think of, you can force Gnome to use Metacity by changing the /desktop/gnome/session/required_components/windowmanager key to "/usr/bin/metacity" in gconf-editor.

  9. #9
    Join Date
    Jan 2010
    Location
    Portland, Oregon
    Beans
    51
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: gtk-window-decorator permanent fix?

    Quote Originally Posted by kellemes View Post
    gconf-editor
    desktop -> gnome -> session -> required-components -> windowmanager = metacity
    this is what gconf-editor already shows.

    Quote Originally Posted by mcduck View Post
    The first thing you should try is setting the visual effects to "none" in System/Preferences/Appearance. That really should switch you to Metacity.

    If it doesn't work, for some strange reason I can't think of, you can force Gnome to use Metacity by changing the /desktop/gnome/session/required_components/windowmanager key to "/usr/bin/metacity" in gconf-editor.
    aside from gtk-window-decorator --replace i haven't used compiz. when i installed 10.04 i enabled the proprietary nvidia driver but left visual effects "none". i double checked and it's still set to none.

    changed the gconf entry to /usr/bin/metacity and nothing changed, even after a restart.

  10. #10
    Join Date
    Jan 2010
    Location
    Portland, Oregon
    Beans
    51
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: gtk-window-decorator permanent fix?

    i tried switching to compiz with the full settings manager and fusion icon. the only way i can get it to work on startup is with the autostart command "fusion-icon --force-compiz"

    ...this is not at all what i wanted to end up with but until i get a real fix this will have to do. if anyone has any ideas please help! i would much rather keep things simple with metacity.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •