Results 1 to 6 of 6

Thread: Toshiba L645 - ACPI problem in 10.10

  1. #1
    Join Date
    Nov 2010
    Location
    Dallas, Tx
    Beans
    0
    Distro
    Ubuntu 10.04 Lucid Lynx

    Toshiba L645 - ACPI problem in 10.10

    Good day everyone. I have found that nearly everything works on my Satellite L645, the RTL8188CE driver had to be installed from the website, but all else is good except for the battery life indicator. I know some of you toshiba fans have had the same problem, but with more modules not working than just the battery life, but I'd like to know some possible fixes or ideas among you guys, to help myself and anyone else with this cool little L645.

    Some things that I've noticed, are that acpi does not notice the battery as being installed, and refers to it as not being present.

    Code:
    root@dustin-Satellite-L645:/proc/acpi/battery/BAT1# cat info
    present:                 no
    Any help would be greatly appreciated. It always believes it is plugged in to AC power. I am also curious if anyone has gotten this to work, apparently, linux kernels 2.6.x have "included" toshiba acpi packages. Not sure about this, this information is found here:

    http://memebeam.org/toys/toshibaacpidriver

    The article describes the directory toshiba that will appear under /proc/acpi.

    I have only begun research into this problem for these L645's, but I will update my own thread when I come across progress or a solution.. Thanks, I hope we can all be helped by this. Let me know if you own similar Toshiba laptop newborns (purchased in 2010), and if you experience any problem with yours, as i have with mine.

  2. #2
    Join Date
    Nov 2010
    Location
    Dallas, Tx
    Beans
    0
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Toshiba L645 - ACPI problem in 10.10

    Another weird notice of mine, is that BAT0 has usually been the first (and only) battery recognised by acpi, in my experience. However my machine is defaulting to BAT1.

    Thanks for reading, just posting any information I can as I delve in to this.

  3. #3
    Join Date
    Mar 2011
    Beans
    1

    Angry Re: Toshiba L645 - ACPI problem in 10.10

    I have same problem...
    do you have solution for that??

  4. #4
    Join Date
    Jun 2009
    Location
    Kansas
    Beans
    13
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Toshiba L645 - ACPI problem in 10.10

    I've got the same problem. Guess there's no fix yet?

  5. #5
    Join Date
    May 2011
    Beans
    4

    Re: Toshiba L645 - ACPI problem in 10.10

    I have the same problem mine is toshiba satellite L655

  6. #6
    Join Date
    Jun 2009
    Location
    Kansas
    Beans
    13
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Toshiba L645 - ACPI problem in 10.10

    Eureka!! I found a solution to this problem and cured my Satellite L645! The instructions found in the link below describe the process of building a custom kernel. The result is that the battery is recognized and appears to be properly controlled (power management, battery meter, etc.). This process takes a while to complete, but if I can figure it out anyone can. Thanks to Faheem and his article at techinterplay.com:

    http://techinterplay.com/fix-toshiba...sue-linux.html

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •