Results 1 to 4 of 4

Thread: Unable to connect to PPTP

  1. #1
    Join Date
    Nov 2008
    Beans
    20
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Unable to connect to PPTP

    I have PPTPD installed and I'm unable to connect to it. My buddy(osx) is able to connect without any problems. I'm connecting from Ubuntu to a Ubuntu server that has PPTPD. Here's the log that server spits out after I try connecting from my Ubuntu machine:

    tail -f /var/log/syslog:

    Code:
    Dec 30 18:41:43 ubuntu pppd[2476]: pppd 2.4.5 started by root, uid 0
    Dec 30 18:41:43 ubuntu pppd[2476]: Using interface ppp0
    Dec 30 18:41:43 ubuntu pppd[2476]: Connect: ppp0 <--> /dev/pts/1
    Dec 30 18:41:43 ubuntu pptpd[2474]: GRE: Bad checksum from pppd.
    Dec 30 18:42:13 ubuntu pppd[2476]: LCP: timeout sending Config-Requests
    Dec 30 18:42:13 ubuntu pppd[2476]: Connection terminated.
    Dec 30 18:42:13 ubuntu pppd[2476]: Modem hangup
    Dec 30 18:42:13 ubuntu pppd[2476]: Exit.
    Dec 30 18:42:13 ubuntu pptpd[2474]: GRE: read(fd=6,buffer=611640,len=8196) from PTY failed: status = -1 error = Input/output error, usually caused by unexpected termination of pppd, check option syntax and pppd logs
    Dec 30 18:42:13 ubuntu pptpd[2474]: CTRL: PTY read or GRE write failed (pty,gre)=(6,7)
    Dec 30 18:42:13 ubuntu pptpd[2474]: CTRL: Reaping child PPP[2476]
    Dec 30 18:42:13 ubuntu pptpd[2474]: CTRL: Client MYIP control connection finished
    Here's the server's Encryption section from /etc/ppp/pptd-options


    Code:
    # Encryption
    # Debian: on systems with a kernel built with the package
    # kernel-patch-mppe >= 2.4.2 and using ppp >= 2.4.2, ...
    # {{{
    refuse-pap
    refuse-chap
    refuse-mschap
    # Require the peer to authenticate itself using MS-CHAPv2 [Microsoft
    # Challenge Handshake Authentication Protocol, Version 2] authentication.
    require-mschap-v2
    #Require MPPE 128-bit encryption
    # (note that MPPE requires the use of MSCHAP-V2 during authentication)
    require-mppe-128
    # }}}
    I've done ton of Googling and no luck. I must be blind. Any help would be more than appreciated. Thanks!!

  2. #2
    Join Date
    Nov 2008
    Beans
    30

    Re: Unable to connect to PPTP

    Hi. Did you ever solve this issue?

    I am also getting the error
    Code:
     GRE: Bad checksum from pppd.
    when I try to connect to my recent attempt to set up a VPN server.

    I followed the instructions here:
    http://www.ubuntugeek.com/howto-pptp...ucid-lynx.html

  3. #3
    Join Date
    Dec 2007
    Location
    Washington
    Beans
    18

    Re: Unable to connect to PPTP

    Quote Originally Posted by kenm_uk View Post
    Hi. Did you ever solve this issue?

    I am also getting the error
    Code:
     GRE: Bad checksum from pppd.
    when I try to connect to my recent attempt to set up a VPN server.

    I followed the instructions here:
    http://www.ubuntugeek.com/howto-pptp...ucid-lynx.html
    I had the same problem. Thought i'd share in-case anyone is looking here for answers.

    Not sure if this was a problem but it seemed to change the results in syslog, only used one tab between columns when configuring users.

    What fixed it for me was enabling MTSE in the client configuration settings. It's disabled by default in Ubuntu's network manager.

  4. #4
    Join Date
    Oct 2011
    Beans
    1

    Re: Unable to connect to PPTP

    Ensure you enable MPPE in the client configuration settings (under Advanced). It's disabled by default in Ubuntu's network manager. Turn verbose debugging on (pptpd --debug) to get a better idea of what is wrong (in syslog).

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •