Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 52

Thread: Internet problem on Eee900

  1. #21
    Join Date
    Dec 2005
    Beans
    63
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Internet problem on Eee900

    Thank you so much for the packages.
    I installed them and was able to do without NetworkManager.
    I couldn't get to connect to the internet yet, though.
    First of all I discovered that my netbook is known to have an electronic problem at the wifi antenna, so that it needs to be out of power (without battery) ever so often to release all the static and do all the necessary antenna yoga.
    So, I let it chill out and lo and behold, wicd can sniff the network.
    Still it can't connect to it. I appreciate wicd's transparent behaviour,as it tells me that the problem is in verifying the ap. I've checked there are no sw/hw blocks on the wifi; but dmesg says something weird: immediately after the link to the ap gets available, there is a line saying "deauthenticating from XX:XX:XX:XX:XX by local choice (reason=3)".
    Now I left it there to chill some more, and I'm going to try and find out about this weird wrong local choice someone is taking against my will.
    This is why I love linux: you get to learn your stuff.
    This is why I hate it too: if you don't have the time you need, you don't get the work done.
    Thank you again for your help... I'm not giving up, are you?

  2. #22
    Join Date
    Dec 2005
    Beans
    63
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Internet problem on Eee900

    Ok, this is the status now.

    I reset the router, no weird stuff from there. Now all 3 computers here have the very same permissions on the router (except of course for their IP's, statically different).

    The Vista and Lucid Notebooks (both HP's with different fillings) had and have no problems whatsoever during this whole nightmare the Lucid Netbook is going through.

    The Lucid Netbook: through wicd I am able to connect both wired and wireless to the router. The icon says so, iwconfig says so, dmesg says so. No sw/hw locks on the wifi (rfkill says so).
    Nevertheless, when I ping the router I get "Destination Host Unreachable". Far less am I able to go beyond the router into the Wild Wild Web.
    I also tried with a Live CD, restoring the system at least temporarily as it was when it worked perfectly, without luck.

    Any ideas?
    Thanks!

  3. #23
    Join Date
    Oct 2009
    Location
    Tucson, AZ
    Beans
    782
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Internet problem on Eee900

    Make sure your connected to the wireless and run these commands and copy/paste the output:
    Code:
    sudo dhclient wlan0
    ifconfig -a
    sudo iwconfig

  4. #24
    Join Date
    Dec 2005
    Beans
    63
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Internet problem on Eee900

    Here they are:

    dhclient:

    Code:
    eelsho@eelsho:~$ sudo dhclient wlan0
    Internet Systems Consortium DHCP Client V3.1.3
    Copyright 2004-2009 Internet Systems Consortium.
    All rights reserved.
    For info, please visit https://www.isc.org/software/dhcp/
    
    Listening on LPF/wlan0/00:15:af:a0:b0:19
    Sending on   LPF/wlan0/00:15:af:a0:b0:19
    Sending on   Socket/fallback
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 15
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 20
    No DHCPOFFERS received.
    No working leases in persistent database - sleeping.
    Note: at the first DHCPDISCOVER the so-called connection is reported lost by wicd.
    Upon re-"connection", through ifdown-ifup and wicd's intervention, ifconfig gives:

    Code:
    eelsho@eelsho:~$ ifconfig -a
    eth0      Link encap:Ethernet  HWaddr 00:22:15:16:2b:38  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:4
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
              Memory:fbfc0000-fc000000 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:54987 errors:0 dropped:0 overruns:0 frame:0
              TX packets:54987 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:5762804 (5.7 MB)  TX bytes:5762804 (5.7 MB)
    
    wlan0     Link encap:Ethernet  HWaddr 00:15:af:a0:b0:19  
              inet addr:192.168.1.10  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::215:afff:fea0:b019/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1360  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:9915 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:675732 (675.7 KB)
    Finally, iwconfig:
    Code:
    eelsho@eelsho:~$ sudo iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    wlan0     IEEE 802.11bg  ESSID:"G604TWIRELESS"  
              Mode:Managed  Frequency:2.462 GHz  Access Point: 00:0F:3D:B2:AA:E4   
              Bit Rate=24 Mb/s   Tx-Power=20 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              Link Quality=52/70  Signal level=-58 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    I now realize that ifconfig gives an ipv6 address, whereas dmesg always remarks that the router has no ipv6 extensions. Could it be something in that line?
    Last edited by Alessandro Allegri; January 9th, 2011 at 03:06 PM. Reason: final question added

  5. #25
    Join Date
    Dec 2005
    Beans
    63
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Internet problem on Eee900

    Ok, I was able to disable ipv6.
    No difference.

  6. #26
    Join Date
    Oct 2009
    Location
    Tucson, AZ
    Beans
    782
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Internet problem on Eee900

    Try running
    Code:
    sudo ip route del defualt dev wlan0
    sudo ip route add default via <router IP address> dev wlan0
    The first line might give you an error, which actually is a good thing. It means the second line should definitely fix your problem.

    If it does, check and make sure the "gateway" in your static IP configuration is correct. If not, copy/paste the output of:
    Code:
    ip route
    in case something else is wrong there.

  7. #27
    Join Date
    Dec 2005
    Beans
    63
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Internet problem on Eee900

    Code:
    sudo ip route del defualt dev wlan0
    sudo ip route add default via <router IP address> dev wlan0
    No error after the first.
    No pinging after the second.

    Code:
    ip route
    192.168.0.1/24 dev wlan0 proto kernel scope link src 192.168.1.10
    169.254.0.0/16 dev wlan0 scope link metric 1000
    default via 192.168.1.1 dev wlan0
    What is this 169.254.0.0 thing?
    Is 192.168.0.1 correct?

    Thx

  8. #28
    Join Date
    Oct 2009
    Location
    Tucson, AZ
    Beans
    782
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Internet problem on Eee900

    Not if you're using 192.168.1.x addresses, as indicated by your ifconfig output.

    Are you using NetworkManager or wicd to configure your wireless connection?

  9. #29
    Join Date
    Dec 2005
    Beans
    63
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Internet problem on Eee900

    Quote Originally Posted by PatchesTheCaveman View Post
    Not if you're using 192.168.1.x addresses, as indicated by your ifconfig output.

    Are you using NetworkManager or wicd to configure your wireless connection?
    I'm using wicd, but it has problems in verifying the ap, so I set a bash script that I run every time with

    -ifdown
    -iwconfig ap
    -iwconfig essid
    -ifup

    which is enough to make the wicd background connect.
    So where do i change those ip's (I've never met them throughout weeks of wanderings!)

    Thanks.

  10. #30
    Join Date
    Oct 2009
    Location
    Tucson, AZ
    Beans
    782
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Internet problem on Eee900

    Give
    Code:
    sudo ifconfig wlan0 <your IP>
    a shot. Also run the route ip command from earlier just in case.

    And do you have WEP or WPA? I need to know to make the above fix permanent and/or try another solution.

Page 3 of 6 FirstFirst 12345 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •