Results 1 to 10 of 10

Thread: Gnome Screensaver Locks-Up Display

  1. #1
    Join Date
    Dec 2009
    Location
    S.E. Michigan, U.S.A.
    Beans
    151
    Distro
    Ubuntu 10.04 Lucid Lynx

    Gnome Screensaver Locks-Up Display

    Hi All,

    Specifications:
    Dell PoweEdge 1600SC
    ATI Radeon HD 2400 Pro 256MB PCI graphics adaptor

    Ubuntu 9.10 "Karmic Koala"
    Linux 2.6.31-22-generic #69-Ubuntu SMP Wed Nov 24 08:51:08 UTC 2010 i686
    ATI fglrx drivers
    Set up for dual-head display using two Princeton 19" monitors

    Using the Gnome desktop and screensaver

    At some point, I suspect since the last kernel upgrade, I've begun experiencing a problem when the screen locks: I tap a key on the keyboard and the monitors wake up, but I get no "unlock" dialog. I can usually Ctrl-Alt-F1, login and gracefully reboot the system, but sometimes I have to hit hard reset.

    Any clues on what's causing this and how I can fix it? For now I've disabled the screensaver in "System -> Preferences -> screensaver" (I assume that'll stop the problem), but that's not an optimal solution.

    Thanks,
    Jim

  2. #2
    Join Date
    Dec 2009
    Location
    S.E. Michigan, U.S.A.
    Beans
    151
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Gnome Screensaver Locks-Up Display

    Nobody has any clues or suggestions?

    Thanks,
    Jim

  3. #3
    Join Date
    Dec 2009
    Beans
    184
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Gnome Screensaver Locks-Up Display

    Have you perused any of the logs from the time of the lockups -- Xorg.log, syslog, etc?

  4. #4
    Join Date
    Aug 2009
    Location
    India
    Beans
    2,110
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Gnome Screensaver Locks-Up Display

    Have you checked the option "Lock screen when screensaver is active" in your screensaver preferences??

  5. #5
    Join Date
    Dec 2009
    Location
    S.E. Michigan, U.S.A.
    Beans
    151
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Gnome Screensaver Locks-Up Display

    Quote Originally Posted by noah++ View Post
    Have you perused any of the logs from the time of the lockups -- Xorg.log, syslog, etc?
    Thanks for the follow-up, Noah.

    Only thing I've found of interest is
    Code:
    gdm-simple-slave[29823]: WARNING: Unable to load file '/etc/gdm/custom.conf': No such file or directory
    in /var/log/syslog, prior to the reboot. I've located that elsewhere in the logs, incl. areas that don't seem to have resulted in me rebooting. There is an Xorg.log.0.old with a timestamp that matches the hour:minute of the syslog entry with the "custom.com" error message timestamp. There's a lot of informational stuff in there. Can't tell what's important and what's not.

    I searched on the warning message. Inconclusive results, incl. the instance by developers that the message has no bearing on anything. Problems that seem related/associated with this continue to be reported by Ubuntu 10.x users.

    The problem has not recurred since I disabled the screen saver/locker.

    Quote Originally Posted by karthick87 View Post
    Have you checked the option "Lock screen when screensaver is active" in your screensaver preferences??
    I think you misread my issue. The problem isn't that screen-locking isn't happening, it's that, sometimes, when it does, I cannot make it un-happen.


    Thanks,
    Jim

  6. #6
    Join Date
    Mar 2008
    Beans
    13

    Re: Gnome Screensaver Locks-Up Display

    check your power management utilities...(open synaptic and search pm-utils) if you are using a laptop with 1.4 installed remove and reinstall 1.3 http://packages.ubuntu.com/de/lucid/...utils/download after installing 1.3 reboot ... fixes alot of power management issues in 10.10...

  7. #7
    Join Date
    Dec 2009
    Location
    S.E. Michigan, U.S.A.
    Beans
    151
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Gnome Screensaver Locks-Up Display

    Thanks for the follow-up and suggestions, spantch101, but I'm not using a laptop.

    Jim

  8. #8
    Join Date
    Jul 2010
    Beans
    27
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Gnome Screensaver Locks-Up Display

    I am having the same issue? has anyone found a resolution? my screen does fine unless I Leave it locked overnight, or for a long period of time. Ive been restarting my computer every day for the past week. !!!!!
    Windows OS: $100-$300, Ubuntu: $0.00
    Windows OS: Closed Source and private, Ubuntu: Community Developed
    now why is windows still around?

  9. #9
    Join Date
    Dec 2009
    Location
    S.E. Michigan, U.S.A.
    Beans
    151
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Gnome Screensaver Locks-Up Display

    Closure, of a sort, to this? After the next kernel update, and there have been one or two more, since then, the problems mysteriously went away.

    Jim

  10. #10
    Join Date
    Feb 2011
    Location
    Antelope Valley
    Beans
    18
    Distro
    Ubuntu 11.04 Natty Narwhal

    Post Re: Gnome Screensaver Locks-Up Display

    Save the headache, and disable it completely with these commands! Ubuntu does not always listen when you tell it to disable the screensaver and power management. You can add this script to your home folder, mark it as executable, and link to it using System > Preferences > Startup Manager:


    #!/bin/bash

    xset -dpms
    xset s off
    xset s noblank

    Your screensaver will never disrupt you again. Not a fix, but an easy solution!!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •