Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Mount usb drive attached to N300 wireless N netgear router

  1. #11
    Join Date
    Nov 2009
    Beans
    15

    Re: Mount usb drive attached to N300 wireless N netgear router

    Thanks for the info.

    Worked for me with a bit of tweaking (N300 DGN2200)

    fstab:
    //192.168.0.1/USB_Storage /media/readyshare cifs _netdev 0 0

    (you have to mkdir /media/readyshare yourself)

    USB drive had to be formatted as FAT

  2. #12
    Join Date
    May 2008
    Beans
    22
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Mount usb drive attached to N300 wireless N netgear router

    I followed the great directions in this thread and everything worked perfectly, except that I can only modify files in my usb drive if I use elevated (root) access to do it.

    Code:
    steve@phoenix:~/nas$ touch foo.txt
    touch: cannot touch `foo.txt': Permission denied
    steve@phoenix:~/nas$ sudo !!
    sudo touch foo.txt
    [sudo] password for steve: 
    steve@phoenix:~/nas$

  3. #13
    Join Date
    Sep 2013
    Beans
    1

    Re: Mount usb drive attached to N300 wireless N netgear router

    Since my last post, the (deprecated) smbmount command was removed from the smbclient package.

    After another long bout of research, I found that I can use the following instead:

    sudo mount -t cifs //192.168.1.1/USB_Storage /media/readyshare -o username=<myUserID>,password=<myPassword>,sec=ntlm

    The mount command would not work without the username/password options, nor would it work with them unless I added the sec=ntlm option.


    Quote Originally Posted by RobCandee View Post
    I have a Netgear WNDR4500, and was able to set up Ubuntu 11.10 to access the ReadyShare USB_Storage directory with just the smbmount command listed by jamie.nicholson above. (I did have to install smbfs.) I decided to use /media/readyshare instead of /media/nas, so my command was

    sudo smbmount //192.168.1.1/USB_Storage /media/readyshare

    The second command jamie listed, the mount command, kept giving me error(16) Device or resource busy, but I tried to list the /media/readyshare directory, and found I had access already! I am now able, for example, to rsync to directories on the USB device attached to my WNDR4500

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •