Results 1 to 2 of 2

Thread: 10.10 No more internet after dualboot windows install

  1. #1
    Join Date
    Dec 2010
    Beans
    1

    10.10 No more internet after dualboot windows install

    Hello,
    I have a Dell XPS 420 with Ubuntu 10.10 (2.6.35-23-generic x86_64).
    My internet used to work (out of the box) without any problems, but after install of Windows Vista (Home Ed. 32bit), I am unable to use the internet in Ubuntu. The network card is a Linksys WMP600N Wireless-N PCI Adapter. In Windows it works without problems.
    In ubuntu, the network manager indicates that I am connected to the network, and I have an IP address in the 192.168.* range. I am able to ping the router, but unable to ping outside addresses. I have not changed anything, but still my wireless connections has stopped working. Does anyone know how to fix this?

    Code:
    jd@JonathanD:~$ lspci -nn | grep "Network"
    00:19.0 Ethernet controller [0200]: Intel Corporation 82566DC-2 Gigabit Network Connection [8086:294c] (rev 02)
    04:04.0 Network controller [0280]: RaLink RT2800 802.11n PCI [1814:0601]
    
    jd@JonathanD:~$ iwconfig wlan0 
    wlan0     IEEE 802.11abgn  ESSID:"SpeedTouchA5CD36"  
              Mode:Managed  Frequency:2.412 GHz  Access Point: 00:11:F5:DC:9B:64   
              Bit Rate=1 Mb/s   Tx-Power=14 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality=70/70  Signal level=43 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    
    jd@JonathanD:~$ lsmod | grep "rt" 
    parport_pc             30086  0 
    rt2860sta             559618  0 
    rt2800pci              10233  0 
    rt2800lib              31970  1 rt2800pci
    rt2x00usb              11316  1 rt2800lib
    rt2x00pci               6993  1 rt2800pci
    crc_ccitt               1699  2 rt2860sta,rt2800pci
    rt2x00lib              31575  4 rt2800pci,rt2800lib,rt2x00usb,rt2x00pci
    led_class               3393  1 rt2x00lib
    mac80211              266657  3 rt2x00usb,rt2x00pci,rt2x00lib
    cfg80211              170293  2 rt2x00lib,mac80211
    eeprom_93cx6            1789  1 rt2800pci
    parport                37032  3 parport_pc,ppdev,lp
    
    jd@JonathanD:~$ dmesg | grep "wlan"
    [   19.593810] ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [   33.360723] wlan0: authenticate with 00:11:f5:dc:9b:64 (try 1)
    [   33.362434] wlan0: authenticated
    [   33.362460] wlan0: associate with 00:11:f5:dc:9b:64 (try 1)
    [   33.365539] wlan0: RX AssocResp from 00:11:f5:dc:9b:64 (capab=0x411 status=0 aid=1)
    [   33.365543] wlan0: associated
    [   33.366302] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    [   43.700035] wlan0: no IPv6 routers present
    
    jd@JonathanD:~$ sudo lshw -C network
      *-network               
           description: Ethernet interface
           product: 82566DC-2 Gigabit Network Connection
           vendor: Intel Corporation
           physical id: 19
           bus info: pci@0000:00:19.0
           logical name: eth0
           version: 02
           serial: 00:1d:09:18:ac:a7
           capacity: 1GB/s
           width: 32 bits
           clock: 33MHz
           capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
           configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=1.0.2-k4 firmware=1.1-1 latency=0 link=no multicast=yes port=twisted pair
           resources: irq:43 memory:fdfe0000-fdffffff memory:fdfdb000-fdfdbfff ioport:eca0(size=32)
      *-network
           description: Wireless interface
           product: RT2800 802.11n PCI
           vendor: RaLink
           physical id: 4
           bus info: pci@0000:04:04.0
           logical name: wlan0
           version: 00
           serial: 00:25:9c:0d:4e:9a
           width: 32 bits
           clock: 33MHz
           capabilities: pm bus_master cap_list ethernet physical wireless
           configuration: broadcast=yes driver=rt2800pci driverversion=2.6.35-23-generic firmware=N/A ip=192.168.1.68 latency=64 link=yes maxlatency=4 mingnt=2 multicast=yes wireless=IEEE 802.11abgn
           resources: irq:16 memory:f9ef0000-f9efffff
    
    jd@JonathanD:~$ iwlist scan
    lo        Interface doesn't support scanning.
    
    eth0      Interface doesn't support scanning.
    
    wlan0     Scan completed :
              Cell 01 - Address: 00:11:F5:DC:9B:64
                        Channel:1
                        Frequency:2.412 GHz (Channel 1)
                        Quality=70/70  Signal level=43 dBm  
                        Encryption key:on
                        ESSID:"SpeedTouchA5CD36"
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                                  24 Mb/s; 36 Mb/s; 54 Mb/s
                        Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                        Mode:Master
                        Extra:tsf=000003ae575fdbc7
                        Extra: Last beacon: 40130ms ago
                        IE: Unknown: 00105370656564546F756368413543443336
                        IE: Unknown: 010882848B962430486C
                        IE: Unknown: 030101
                        IE: Unknown: 2A0100
                        IE: Unknown: 2F0100
                        IE: Unknown: 32040C121860
                        IE: Unknown: DD06001018020000
    
    
    jd@JonathanD:~$ sudo /etc/init.d/networking restart wlan0
     * Reconfiguring network interfaces...    
    
    jd@JonathanD:~$ nm-tool 
    NetworkManager Tool
    
    State: connected
    
    - Device: eth0 -----------------------------------------------------------------
      Type:              Wired
      Driver:            e1000e
      State:             unavailable
      Default:           no
      HW Address:        00:1D:09:18:AC:A7
    
      Capabilities:
        Carrier Detect:  yes
    
      Wired Properties
        Carrier:         off
    
    
    - Device: wlan0  [Auto SpeedTouchA5CD36] ---------------------------------------
      Type:              802.11 WiFi
      Driver:            rt2800pci
      State:             connected
      Default:           no
      HW Address:        00:25:9C:0D:4E:9A
    
      Capabilities:
        Speed:           24 Mb/s
    
      Wireless Properties
        WEP Encryption:  yes
        WPA Encryption:  yes
        WPA2 Encryption: yes
    
      Wireless Access Points (* = current AP)
        SpeedTouch2AEC96:Infra, 00:90:D0:DE:AE:E7, Freq 2462 MHz, Rate 54 Mb/s, Strength 100 WPA WPA2
        *SpeedTouchA5CD36: Infra, 00:11:F5:DC:9B:64, Freq 2412 MHz, Rate 54 Mb/s, Strength 100 WEP
        print server 2CE210: Ad-Hoc, 02:48:B7:E0:0E:B9, Freq 2462 MHz, Rate 11 Mb/s, Strength 100
        Some more...
        
      IPv4 Settings:
        Address:         192.168.1.68
        Prefix:          24 (255.255.255.0)
        Gateway:         0.0.0.0
    
        DNS:             192.168.1.254
    
    jd@JonathanD:~$ ping 147.83.195.55
    connect: Network is unreachable
    
    jd@JonathanD:~$ cat /etc/resolv.conf 
    nameserver 192.168.1.254
    domain lan
    search lan
    
    jd@JonathanD:~$ ping -c 3 192.168.1.254
    PING 192.168.1.254 (192.168.1.254) 56(84) bytes of data.
    64 bytes from 192.168.1.254: icmp_req=1 ttl=64 time=1.68 ms
    64 bytes from 192.168.1.254: icmp_req=2 ttl=64 time=0.764 ms
    64 bytes from 192.168.1.254: icmp_req=3 ttl=64 time=0.802 ms
    
    --- 192.168.1.254 ping statistics ---
    3 packets transmitted, 3 received, 0% packet loss, time 2000ms
    rtt min/avg/max/mdev = 0.764/1.084/1.687/0.427 ms
    
    jd@JonathanD:~$ route -n 
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 wlan0

  2. #2
    Join Date
    Dec 2010
    Beans
    1

    Re: 10.10 No more internet after dualboot windows install

    It looks like your missing gateway addy should be '192.168.1.0'. I don't think you'll get outside the LAN without it, which appears to be what is happening.

    Also, check that auto-connect is not picking the 'wrong' AP. It looks like there are two in close proximity since they are both showing 100% signal.

    I would also recommend WPA2 security if possible. WEP has been compromised for quite some time now.

    There is some kind of a problem with RaLink that I glanced when I stumbled into your post, but you'll have to search and see if it is relevant.

    Of course, I could be wrong...
    Dana

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •