Results 1 to 7 of 7

Thread: Connect to server -> You entered an invalid

  1. #1
    Join Date
    Dec 2010
    Beans
    18

    Connect to server -> You entered an invalid

    I have installed netatalk on a Ubuntu Server 10.10 and I am trying to connect to it from a mac client.
    I am 100% positive that this has worked before. It just stopped working during the weekend.
    I have used the Mac's terminal to ssh into the ubuntu server to do all the work and it has worked fine.

    But when I try to connect to it via finder:
    afp://<ip-adress>

    First I get the log in pop-up. No problem.
    "Enter your name and password for the server 'virtserv'"
    It can get the host name so it looks fine.

    I enter same username and password I use to ssh but then I get the error message:
    "You entered an invalid username or password."
    "Please try again."

    Why oh why?

  2. #2
    Join Date
    Dec 2010
    Beans
    18

    Re: Connect to server -> You entered an invalid

    Solved it... somehow.

  3. #3
    Join Date
    Dec 2009
    Location
    NYC
    Beans
    29
    Distro
    Ubuntu

    Re: Connect to server -> You entered an invalid

    Please can you tell me how did you solve it?! I get the same error!

  4. #4
    Join Date
    Dec 2010
    Beans
    18

    Re: Connect to server -> You entered an invalid

    Quote Originally Posted by makaki View Post
    Please can you tell me how did you solve it?! I get the same error!
    Sorry no. It just magically started working again. Try reinstalling, I guess.

  5. #5
    Join Date
    Mar 2008
    Beans
    3

    Re: Connect to server -> You entered an invalid

    I am experiencing the same problem on 10.10. A reinstall did not solve it. Could someone please help me.

  6. #6
    Join Date
    Dec 2010
    Location
    Germany
    Beans
    9
    Distro
    Ubuntu

    Re: Connect to server -> You entered an invalid

    I followed this thread to install Netatalk and Avahi.

    Everything seems to work, I can also see my Ubuntu machine in the Finder. But when I try to "connect as..." I get the error mentioned above. ("You entered an invalid username or password." "Please try again.")

    Using afp://<user>@<ip> doesn't work too.
    SSH login is working fine.

    Any ideas?

    I think something with Netatalk is wrong.

  7. #7
    Join Date
    Dec 2010
    Location
    Germany
    Beans
    9
    Distro
    Ubuntu

    Re: Connect to server -> You entered an invalid

    I found a solution for my problem!

    Step by step

    1) Type in terminal: "sudo nano /etc/netatalk/afpd.conf"
    2) Scroll down to the end of the file using your "down arrow".
    3) Previously I used "- -transall -uamlist uams_randnum.so,uams_dhx.so -nosavepassword"
    4) Changed it to "- -transall -uamlist uams_randnum.so,uams_dhx2.so -nosavepassword" (notice the "2")
    5) Save changes: press CTRL+X, then press Y, then ENTER
    7) Restart your netatalk: "sudo /etc/init.d/netatalk restart"
    8) Done.

    Thank you Ali

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •