Results 1 to 3 of 3

Thread: Package old. What to do?

  1. #1
    Join Date
    Dec 2010
    Location
    Yerevan, Armenia
    Beans
    9
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Package old. What to do?

    Hello,

    I need to compile something. it depends on some packages. But package is old. What to do? Compile? So how to compile that everything installs correctly.

    For example I have dependency package: libsdl-mixer1.2-dev(1.2.8.6) which is old.

    So I need to compile source code
    Code:
    ./configure
    make
    make install
    Is this ok? Will old package reinstalled with compiled one? Will package manager understands that I'm using new version?

    Other applications installed via Package Manager, which depends on that package, will use new compiled version?

    Thank you
    Last edited by Toktikweb; December 16th, 2010 at 01:20 AM.

  2. #2
    Join Date
    Sep 2010
    Location
    Montreal
    Beans
    340
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Package old. What to do?

    It should, but if any error messages pop up post em here
    GOOGLE IS YOUR FRIEND
    restoring grub

  3. #3
    Join Date
    Dec 2010
    Location
    Yerevan, Armenia
    Beans
    9
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Package old. What to do?

    I have compiled new version, this works ok. Other application which was depends on this, compiled. But package manager still shows me old version. Is this ok? This not mean that I have duplicate application installed?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •