Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 43

Thread: Asus N53jq, sound not working

  1. #11
    Join Date
    Dec 2010
    Beans
    Hidden!
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Asus N53jq, sound not working

    Thanks. I was just getting around to looking for a fix for suspend.

  2. #12
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,904
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Asus N53jq, sound not working

    So this is solved then? OP, can you mark it using thread tools up top?

  3. #13
    Join Date
    Oct 2009
    Beans
    2

    Re: Asus N53jq, sound not working

    I am sorry, but it is still not working for me after the suggestions done before. In a French topic I found I should enable a sound option in the bios, but I can't find this option either. Anyone have a clue how to continue from here?

    Edit: This problem was solved by checking Analog output to Analog speakers in Sound preferences/output tab...
    Last edited by Pieterd218; January 11th, 2011 at 01:24 PM.

  4. #14
    Join Date
    Jul 2007
    Beans
    1

    Re: Asus N53jq, sound not working

    Quote Originally Posted by Pieterd218 View Post
    I am sorry, but it is still not working for me after the suggestions done before. In a French topic I found I should enable a sound option in the bios, but I can't find this option either. Anyone have a clue how to continue from here?

    Edit: This problem was solved by checking Analog output to Analog speakers in Sound preferences/output tab...
    I am still having problems getting this to work as well. I've added the snd-hda-intel line to my alsa-base.conf, but (1) sound still not working, and (2) I don't have an analog option in the Sound preferences Output tab. The only radio button there is "Internal Audio Digital Stereo (IEC958)".

    Is there something special I need to do to make the analog option show up in the Output tab?

  5. #15
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,904
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Asus N53jq, sound not working

    Quote Originally Posted by lukfugl View Post
    I am still having problems getting this to work as well. I've added the snd-hda-intel line to my alsa-base.conf, but (1) sound still not working, and (2) I don't have an analog option in the Sound preferences Output tab. The only radio button there is "Internal Audio Digital Stereo (IEC958)".

    Is there something special I need to do to make the analog option show up in the Output tab?
    It would help to see your system status. Use the alsa-info-script to provide detailed information.
    Run this command in a terminal:
    Code:
    wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
    Choose the upload option and provide a link for the output.
    [Terminal="Applications->Accessories->Terminal"]

  6. #16
    Join Date
    Jan 2011
    Beans
    4

    Re: Asus N53jq, sound not working


  7. #17
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,904
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Asus N53jq, sound not working

    Quote Originally Posted by jozwa View Post
    Were you trying to get hdmi audio working? Those edits you made to alsa-base.conf should be removed. Next update your alsa modules.
    Using a Terminal="Applications->Accessories->Terminal"
    Add the ubuntu-audio-dev ppa:
    Code:
    sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
    sudo apt-get update
    Now install:
    Code:
    sudo apt-get install linux-alsa-driver-modules-$(uname -r)
    Reboot
    Check your levels in alsamixer.
    Code:
     alsamixer
    Press <F6> to select the correct soundcard.
    Press <F3> to show playback levels. <F4> selects capture levels [or use <Tab>]
    Use the left/right arrow keys to select and up/down arrow keys to change levels. <M> to mute/unmute.
    Go to "System ->Preferences ->Sound" and make sure the correct soundcard is default and adjust your profile on the hardware tab.
    On the output tab choose the correct device.

  8. #18
    Join Date
    Jan 2011
    Beans
    4

    Re: Asus N53jq, sound not working

    Thax for quick replay.
    but the hdmi audio isn't my first task.
    i'm trying to get sound out of my internal speakers.
    if i now conf my sound and i choice for duplex and output on analoog speakers, i can hear it on my earphone when i plug them in. if if config not to analog speaker but to analog out of analog headphone. there is no sound any where.
    but i didn't try your solution for now because i understand it's for hdmi to get working. i take that for step 2.
    thanks in advantage.

    joachim

    Quote Originally Posted by lidex View Post
    Were you trying to get hdmi audio working? Those edits you made to alsa-base.conf should be removed. Next update your alsa modules.
    Using a Terminal="Applications->Accessories->Terminal"
    Add the ubuntu-audio-dev ppa:
    Code:
    sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
    sudo apt-get update
    Now install:
    Code:
    sudo apt-get install linux-alsa-driver-modules-$(uname -r)
    Reboot
    Check your levels in alsamixer.
    Code:
     alsamixer
    Press <F6> to select the correct soundcard.
    Press <F3> to show playback levels. <F4> selects capture levels [or use <Tab>]
    Use the left/right arrow keys to select and up/down arrow keys to change levels. <M> to mute/unmute.
    Go to "System ->Preferences ->Sound" and make sure the correct soundcard is default and adjust your profile on the hardware tab.
    On the output tab choose the correct device.

  9. #19
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,904
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Asus N53jq, sound not working

    No. Updating the alsa modules provides better support for your codec/s regardless of output. So not just for hdmi. I'm sorry if my wording implied that.

  10. #20
    Join Date
    Jan 2011
    Beans
    4

    Re: Asus N53jq, sound not working

    oke. now i have great news. after al had done by google its working already and without your advice.
    here is what i did. i hope i remember it right.
    1 i tried all options given on page one
    2 even some simulair i dont realy know where i found( see the extra lines in my alsa-base.conf)
    3 next i did: https://wiki.archlinux.org/index.php/Asus_N82JV#Audio except the last part about ´alias´.
    that mean i did this part.( i downloaden link nr 8 and 9 (see below) )
    Code:
    1. Install ALSA drivers available at Realtek [8] 
     tar xvf LinuxPkg_x.x
    tar xvf alsa-driver-1.0.xx
    cd alsa-driver-1.0.xx
    ./configure --with-cards=hda-intel
    make
    make install  Note: Realtek's  ALSA drivers, currently 1.0.23-5.15rc5, aren't compiling properly in  kernel 2.6.35. As an alternative, download the latest alsa-driver  snapshot from here[9] (tested with 01/09/2010 snapshot)
     2. Add options snd-hda-intel index=0 model=auto to /etc/modprobe.d/modprobe.conf. 
    Open /etc/modprobe.d/sound.conf
    4 the last part i did was
    Code:
     sudo apt-get install --reinstall linux-image-2.6.35-24-generic
    (i cant find where i found that could be a solution.)

    now i have a have 4 opties for ubuntu (2 safe mode of course) but the same kernel version.
    only the new one is
    Code:
    menuentry 'Ubuntu, with Linux 2.6.35-24-generic-pae' --class ubuntu --class gnu-linux --class gnu --class os {
        recordfail
        insmod part_msdos
        insmod ext2
        set root='(hd0,msdos6)'
        search --no-floppy --fs-uuid --set 6b6e5b33-f679-4332-8d70-bfe9959384b3
        linux    /boot/vmlinuz-2.6.35-24-generic-pae root=UUID=6b6e5b33-f679-4332-8d70-bfe9959384b3 ro   quiet splash
        initrd    /boot/initrd.img-2.6.35-24-generic-pae
    }
    the old one start only tty1 en the new one start tty8(gui)

    i hope i can help anyone whit this and properly lidex, you can understand what is happening so ubuntu can be growing. Thank you for helping and i hope this will keep working even after kernel updates.
    my next step is updating nvidia driver. because i can't change the visual effects setting whit the recommended nvidia driver provided by "additional drivers".

    even i'm not great whit linux i like to learn and if you like you can explain what could happen by what i have done to let my sound working.(extra, i check if i get sound out of my mini jack plug and even that is working as it should be.)

    maby this olso can be help full: my actualy alsa-base.conf:
    Code:
    # autoloader aliases
    install sound-slot-0 /sbin/modprobe snd-card-0
    install sound-slot-1 /sbin/modprobe snd-card-1
    install sound-slot-2 /sbin/modprobe snd-card-2
    install sound-slot-3 /sbin/modprobe snd-card-3
    install sound-slot-4 /sbin/modprobe snd-card-4
    install sound-slot-5 /sbin/modprobe snd-card-5
    install sound-slot-6 /sbin/modprobe snd-card-6
    install sound-slot-7 /sbin/modprobe snd-card-7
    
    # Cause optional modules to be loaded above generic modules
    install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
    #
    # Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
    install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
    install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
    install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
    #
    install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
    # Cause optional modules to be loaded above sound card driver modules
    install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
    install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }
    
    # Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
    install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
    # Prevent abnormal drivers from grabbing index 0
    options bt87x index=-2
    options cx88_alsa index=-2
    options saa7134-alsa index=-2
    options snd-atiixp-modem index=-2
    options snd-intel8x0m index=-2
    options snd-via82xx-modem index=-2
    options snd-usb-audio index=-2
    options snd-usb-caiaq index=-2
    options snd-usb-ua101 index=-2
    options snd-usb-us122l index=-2
    options snd-usb-usx2y index=-2
    # Ubuntu #62691, enable MPU for snd-cmipci
    options snd-cmipci mpu_port=0x330 fm_port=0x388
    # Keep snd-pcsp from being loaded as first soundcard
    options snd-pcsp index=-2
    # Keep snd-usb-audio from beeing loaded as first soundcard
    options snd-usb-audio index=-2
    #zelf toegevoeg van (http://ubuntuforums.org/showthread.php?t=1646249)
    #options snd-hda-intel model=auto position_fix=0
    #options snd-hda-intel probe_mask=0xffff,0xfff1
    #options snd-hda-intel probe_mask=0xffff,0xfff2
    #options snd-hda-intel index=0 model=auto
    #alias snd-card-0 snd-hda-intel
    #alias sound-slot-0 snd-hda-intel
    options snd-hda-intel model=auto

Page 2 of 5 FirstFirst 1234 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •