Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Unmet dependencies error?

  1. #1
    Join Date
    Dec 2010
    Beans
    20

    Unmet dependencies error?

    Hello,

    I'm relatively new to Ubuntu. I've looked around for problems like mine, but haven't really found one. It's been sort of an evolving process.

    First thing that happened is that I could not use Firefox. Later, other programs would not work. I can't run Software Center and a few other programs. Now, I have a red circle in the top right hand corner that says "An error occurred, please run Package Manager from the right-click menu or apt-get in a terminal to see what is wrong. The error message was: 'Error: Opening the cache (E:Read error - read (5: Input/output error), E:The package lists or status file could not be parsed or opened.)'This usually means that your installed packages have unmet dependencies"

    When I run Synaptic Package Manager, it loads for a while, then displays an error box that says a similar thing to this. When I try apt-get in Terminal, it says it can't do something because of a lock open file. "13: Permission denied"

    Thanks if someone knows about this

  2. #2
    Join Date
    Oct 2009
    Location
    New Hamsha
    Beans
    1,275
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: Unmet dependencies error?

    In a terminal:
    Code:
    sudo apt-get -f check
    Type in your password which will not appear and press enter.
    Read us the output.
    AMD A4-3400 w/ Radeon HD 6410D, 8 GB Corsair Vengeance DDR3 1333Mhz, Kubuntu 14.04, SliTaz 4.0, Windows 8.1, Ubuntu 14.04 VM
    " ... Love your neighbor as you love yourself."

  3. #3
    Join Date
    Dec 2010
    Beans
    20

    Re: Unmet dependencies error?

    Thanks I typed in the command in terminal.

    It said "Reading package lists..." It stopped at 6% for a while. This was followed by an error message:

    "E: Read error - read (5: Input/output error)
    E: The package lists or status file could not be parsed or opened."

  4. #4
    Join Date
    Dec 2010
    Beans
    20

    Re: Unmet dependencies error?

    I don't know if this is relevant, but I have a dual boot... I have Ubuntu and Windows XP. My Windows XP has been showing the blue screen of death lately. It will start up fine, but then freezes up and going to the blue screen and says I should disable my BIOS shadowing or caching... or something like that. I doubt that the two problems are related, but I am not sure.

  5. #5
    Join Date
    Apr 2009
    Location
    Rawalpindi, Pakistan
    Beans
    5,666
    Distro
    Ubuntu Gnome Development Release

    Re: Unmet dependencies error?

    Try using an older status file.

    Backup the existing one:

    Code:
    sudo mv /var/lib/dpkg/status /var/lib/dpkg/status.bad
    Setup the old one to be used:

    Code:
    sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status
    And then post the output of this command.

    Code:
    sudo apt-get update

  6. #6
    Join Date
    Dec 2010
    Beans
    20

    Re: Unmet dependencies error?

    On the second instruction, terminal says that the file /var/lib/dpkg/status doesn't exist.

  7. #7
    Join Date
    Apr 2009
    Location
    Rawalpindi, Pakistan
    Beans
    5,666
    Distro
    Ubuntu Gnome Development Release

    Re: Unmet dependencies error?

    Post the complete output of this one.

    Code:
    ls /var/lib/dpkg

  8. #8
    Join Date
    Dec 2010
    Beans
    20

    Re: Unmet dependencies error?

    "ls /var/lib/dpkg
    alternatives cmethopt info statoverride statusold
    available diversions lock statusoverride-old triggers
    available-old diversions-old parts status.bad updates
    "

  9. #9
    Join Date
    Apr 2009
    Location
    Rawalpindi, Pakistan
    Beans
    5,666
    Distro
    Ubuntu Gnome Development Release

    Re: Unmet dependencies error?

    I don't know why it is named statusold instead of staus-old as it normally does.

    Anyhow, try these commands.

    Code:
    sudo cp /var/lib/dpkg/statusold /var/lib/dpkg/status
    Code:
    sudo apt-get update

  10. #10
    Join Date
    Dec 2010
    Beans
    20

    Re: Unmet dependencies error?

    Well this doesn't seem to make sense, because I saw your logic. After I entered the first line into terminal it said:
    "cp: cannot stat '/var/lib/dpkg/statusold': No such file or directory"

    I tried to go on ahead with the second line you gave me and it didn't work, saying something similar.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •