Page 8 of 8 FirstFirst ... 678
Results 71 to 77 of 77

Thread: E: Sub-process /usr/bin/dpkg returned an error code (1)

  1. #71
    Join Date
    May 2010
    Location
    Tewkesbury uk
    Beans
    7,918
    Distro
    Ubuntu Development Release

    Re: E: Sub-process /usr/bin/dpkg returned an error code (1)

    Hi

    Please post the output of your rc.local file.

    On Ubuntu it's at

    /etc/rc.local

    but i am not sure where it is under debian

    Kind regards
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

  2. #72
    Join Date
    Jan 2008
    Beans
    8

    Re: E: Sub-process /usr/bin/dpkg returned an error code (1)

    Hi guys, been having the same problem after trying to install a specific kernel to work with qemu/gns3 and juniper emulation.
    now when i try to updgrade kernel and software i get the same error as previously stated. ran sudo apt-get -f update and sudo apt-get upgrade and i still get the error.

    Tried a sudo apt-get autoremove and this is what i get:

    phantom@dalila:~$ sudo apt-get autoremove
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these.
    The following packages have unmet dependencies:
    linux-generic : Depends: linux-headers-generic (= 3.2.0.45.54) but 3.2.0.48.58 is installed
    linux-image-generic : Depends: linux-image-3.2.0-45-generic but it is not installed
    E: Unmet dependencies. Try using -f.
    phantom@dalila:~$ sudo apt-get autoremove -f
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Correcting dependencies... Done
    The following extra packages will be installed:
    linux-generic linux-image-3.2.0-48-generic linux-image-generic
    Suggested packages:
    fdutils linux-doc-3.2.0 linux-source-3.2.0 linux-tools
    The following NEW packages will be installed:
    linux-image-3.2.0-48-generic
    The following packages will be upgraded:
    linux-generic linux-image-generic
    2 upgraded, 1 newly installed, 0 to remove and 77 not upgraded.
    9 not fully installed or removed.
    Need to get 0 B/38.5 MB of archives.
    After this operation, 150 MB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    (Reading database ... 486780 files and directories currently installed.)
    Unpacking linux-image-3.2.0-48-generic (from .../linux-image-3.2.0-48-generic_3.2.0-48.74_amd64.deb) ...
    Done.
    dpkg: error processing /var/cache/apt/archives/linux-image-3.2.0-48-generic_3.2.0-48.74_amd64.deb (--unpack):
    failed in write on buffer copy for backend dpkg-deb during `./boot/System.map-3.2.0-48-generic': No space left on device
    No apport report written because MaxReports is reached already
    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
    Examining /etc/kernel/postrm.d .
    run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.2.0-48-generic /boot/vmlinuz-3.2.0-48-generic
    run-parts: executing /etc/kernel/postrm.d/zz-extlinux 3.2.0-48-generic /boot/vmlinuz-3.2.0-48-generic
    P: Checking for EXTLINUX directory... found.
    P: Writing config for /boot/vmlinuz-3.2.0-44-generic...
    P: Writing config for /boot/vmlinuz-3.2.0-41-generic...
    P: Writing config for /boot/vmlinuz-3.2.0-40-generic...
    P: Writing config for /boot/vmlinuz-3.2.0-39-generic...
    P: Writing config for /boot/vmlinuz-3.2.0-38-generic...
    P: Writing config for /boot/vmlinuz-3.2.0-37-generic...
    P: Writing config for /boot/vmlinuz-3.2.0-36-generic...
    P: Writing config for /boot/vmlinuz-3.2.0-35-generic...
    P: Writing config for /boot/vmlinuz-3.2.0-34-generic...
    P: Writing config for /boot/vmlinuz-3.2.0-33-generic...
    P: Writing config for /boot/vmlinuz-3.2.0-32-generic...
    P: Writing config for /boot/vmlinuz-3.2.0-31-generic...
    P: Writing config for /boot/vmlinuz-3.2.0-23-generic...
    P: Writing config for Windows 7 (loader) on /dev/sda1...
    P: Installing debian theme... done.
    run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.2.0-48-generic /boot/vmlinuz-3.2.0-48-generic
    Errors were encountered while processing:
    /var/cache/apt/archives/linux-image-3.2.0-48-generic_3.2.0-48.74_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    phantom@dalila:~$

    Also noticed that /boot has now 0 bytes free space. can you help me out updating to the right kernel please.

    ~$ df -h
    Filesystem Size Used Avail Use% Mounted on
    /dev/sda6 11G 4.4G 5.3G 46% /
    udev 2.0G 12K 2.0G 1% /dev
    tmpfs 791M 928K 790M 1% /run
    none 5.0M 0 5.0M 0% /run/lock
    none 2.0G 84K 2.0G 1% /run/shm
    /dev/sda7 5.7G 194M 5.3G 4% /tmp
    /dev/sda5 388M 383M 0 100% /boot
    /dev/sda8 15G 6.6G 7.4G 48% /usr
    /dev/sda9 11G 4.3G 5.4G 45% /opt
    /dev/sda11 686G 270G 382G 42% /home

    thank you

  3. #73
    Join Date
    Aug 2013
    Beans
    1

    Re: E: Sub-process /usr/bin/dpkg returned an error code (1)

    IS somebody watching?? Please help:





    bimal@QUANTUM:~$ sudo dpkg --configure -a
    [sudo] password for bimal:
    bimal@QUANTUM:~$
    bimal@QUANTUM:~$
    bimal@QUANTUM:~$ sudo apt-get install -f
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 10 not upgraded.
    1 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Setting up oracle-java7-installer (7u3-0~eugenesan~precise4) ...
    Downloading...
    --2013-08-19 02:04:32-- http://download.oracle.com/otn-pub/j...nux-x64.tar.gz
    Resolving download.oracle.com (download.oracle.com)... 202.166.193.8, 202.166.193.6
    Connecting to download.oracle.com (download.oracle.com)|202.166.193.8|:80... connected.
    HTTP request sent, awaiting response... 302 Moved Temporarily
    Location: https://edelivery.oracle.com/otn-pub...nux-x64.tar.gz [following]
    --2013-08-19 02:04:32-- https://edelivery.oracle.com/otn-pub...nux-x64.tar.gz
    Resolving edelivery.oracle.com (edelivery.oracle.com)... 23.35.54.140
    Connecting to edelivery.oracle.com (edelivery.oracle.com)|23.35.54.140|:443... connected.
    HTTP request sent, awaiting response... 302 Moved Temporarily
    Location: http://download.oracle.com/errors/do...l-1505220.html [following]
    --2013-08-19 02:04:33-- http://download.oracle.com/errors/do...l-1505220.html
    Connecting to download.oracle.com (download.oracle.com)|202.166.193.8|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 5307 (5.2K) [text/html]
    Saving to: `./jdk-7u3-linux-x64.tar.gz'


    0K ..... 100% 1.13M=0.004s


    2013-08-19 02:04:33 (1.13 MB/s) - `./jdk-7u3-linux-x64.tar.gz' saved [5307/5307]


    Download done.
    sha256sum mismatch jdk-7u3-linux-x64.tar.gz
    Oracle JDK 7 is NOT installed.
    dpkg: error processing oracle-java7-installer (--configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    oracle-java7-installer
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    bimal@QUANTUM:~$
    bimal@QUANTUM:~$
    bimal@QUANTUM:~$
    bimal@QUANTUM:~$
    bimal@QUANTUM:~$ cat /etc/apt/sources.list
    # deb cdrom:[Ubuntu 12.04.2 LTS _Precise Pangolin_ - Release amd64 (20130213)]/ dists/precise/main/binary-i386/


    # deb cdrom:[Ubuntu 12.04.2 LTS _Precise Pangolin_ - Release amd64 (20130213)]/ dists/precise/restricted/binary-i386/
    # deb cdrom:[Ubuntu 12.04.2 LTS _Precise Pangolin_ - Release amd64 (20130213)]/ precise main restricted


    # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
    # newer versions of the distribution.
    deb http://np.archive.ubuntu.com/ubuntu/ precise main restricted
    deb-src http://np.archive.ubuntu.com/ubuntu/ precise main restricted


    ## Major bug fix updates produced after the final release of the
    ## distribution.
    deb http://np.archive.ubuntu.com/ubuntu/ precise-updates main restricted
    deb-src http://np.archive.ubuntu.com/ubuntu/ precise-updates main restricted


    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team. Also, please note that software in universe WILL NOT receive any
    ## review or updates from the Ubuntu security team.
    deb http://np.archive.ubuntu.com/ubuntu/ precise universe
    deb-src http://np.archive.ubuntu.com/ubuntu/ precise universe
    deb http://np.archive.ubuntu.com/ubuntu/ precise-updates universe
    deb-src http://np.archive.ubuntu.com/ubuntu/ precise-updates universe


    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team, and may not be under a free licence. Please satisfy yourself as to
    ## your rights to use the software. Also, please note that software in
    ## multiverse WILL NOT receive any review or updates from the Ubuntu
    ## security team.
    deb http://np.archive.ubuntu.com/ubuntu/ precise multiverse
    deb-src http://np.archive.ubuntu.com/ubuntu/ precise multiverse
    deb http://np.archive.ubuntu.com/ubuntu/ precise-updates multiverse
    deb-src http://np.archive.ubuntu.com/ubuntu/ precise-updates multiverse


    ## N.B. software from this repository may not have been tested as
    ## extensively as that contained in the main release, although it includes
    ## newer versions of some applications which may provide useful features.
    ## Also, please note that software in backports WILL NOT receive any review
    ## or updates from the Ubuntu security team.
    deb http://np.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
    deb-src http://np.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse


    deb http://security.ubuntu.com/ubuntu precise-security main restricted
    deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
    deb http://security.ubuntu.com/ubuntu precise-security universe
    deb-src http://security.ubuntu.com/ubuntu precise-security universe
    deb http://security.ubuntu.com/ubuntu precise-security multiverse
    deb-src http://security.ubuntu.com/ubuntu precise-security multiverse


    ## Uncomment the following two lines to add software from Canonical's
    ## 'partner' repository.
    ## This software is not part of Ubuntu, but is offered by Canonical and the
    ## respective vendors as a service to Ubuntu users.
    # deb http://archive.canonical.com/ubuntu precise partner
    # deb-src http://archive.canonical.com/ubuntu precise partner


    ## This software is not part of Ubuntu, but is offered by third-party
    ## developers who want to ship their latest software.
    deb http://extras.ubuntu.com/ubuntu precise main
    deb-src http://extras.ubuntu.com/ubuntu precise main
    bimal@QUANTUM:~$
    bimal@QUANTUM:~$

  4. #74
    Join Date
    May 2010
    Location
    Tewkesbury uk
    Beans
    7,918
    Distro
    Ubuntu Development Release

    Re: E: Sub-process /usr/bin/dpkg returned an error code (1)

    Hi

    @Bimal.

    Do you still need help with this ?

    If you do then try purging the oracle installer package.

    Copy and paste this into the terminal.

    Code:
    sudo dpkg -P oracle-java7-installer
    Also have you added any ppas ?

    Please post the output of this command.

    Copy and past it to insure there is no typos.

    Code:
    grep "^[^#]" /etc/apt/sources.list{,.d/*}
    Copy and paste the output from the terminal into your next post.

    Once we have removed java we can look at installing it correctly.

    In future, please start a new thread as this thread is getting old now.

    It's far more likely to be looked at by others if you start a new one.

    Kind regards
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

  5. #75
    Join Date
    Oct 2013
    Beans
    4

    Re: E: Sub-process /usr/bin/dpkg returned an error code (1)

    Hey guys,
    Sorry for bumping into an old thread.. but I'm so tired of these stupid errors now - I really need someone's help to sort this out.

    Please read this http://askubuntu.com/questions/35527...ore-installing

    to know where I'm coming from.. I made it work after hours of research then I faced 'Unable to locate Error' finally solved and now this.. point is my 1tb ext. hdd got into RAW format and I want to recover the data/reapir the partition through Testdisk. It has some really important data and I can't just let it go.. but I keep recieving such error messages one after another.

    Please know that I don't know how to use ubuntu, so guide like you would guide a newbie or a beginner..

    ubuntu@ubuntu:~$ sudo apt-get install testdisk
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    testdisk is already the newest version.
    The following package was automatically installed and is no longer required:
    thunderbird-globalmenu
    Use 'apt-get autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
    1 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Setting up initramfs-tools (0.99ubuntu13.2) ...
    update-initramfs: deferring update (trigger activated)
    lzma: (stdin): Cannot allocate memory
    dpkg: error processing initramfs-tools (--configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    initramfs-tools
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Thank You.

  6. #76
    Join Date
    May 2010
    Location
    Tewkesbury uk
    Beans
    7,918
    Distro
    Ubuntu Development Release

    Re: E: Sub-process /usr/bin/dpkg returned an error code (1)

    Hi

    Are you still having trouble ?

    lzma: (stdin): Cannot allocate memory
    What are the specs of your machine ? It looks like you may be running out of memory.

    Anyway, testdisk is already installed by the looks of it.

    testdisk is already the newest version.
    Please post the output of

    Code:
    dpkg -C
    That is a capital C above. It may return no output. Also post the output of the below.

    Code:
    sudo apt-get check
    and finally...

    Code:
    dpkg -l initramfs-tools
    Kind regards
    Last edited by matt_symes; October 11th, 2013 at 04:07 PM.
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

  7. #77
    Join Date
    Oct 2013
    Beans
    1

    Re: E: Sub-process /usr/bin/dpkg returned an error code (1)

    Quote Originally Posted by matt_symes View Post
    Hi

    Try this. Open a terminal and type

    Code:
    sudo dpkg -i --force-overwrite /var/cache/apt/archives/libogremain-1.7.3_1.7.3-ogredev-natty3_i386.deb

    Kind regards
    Thanks so much. It's work with me.

Page 8 of 8 FirstFirst ... 678

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •