Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: 12.04 changing keyboard layout

  1. #1
    Join Date
    Aug 2009
    Location
    Tromsø
    Beans
    8
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    12.04 changing keyboard layout

    Hello

    Today I have upgraded to 12.04, and I am no longer able to switch between different keyboard layouts. Both layouts I want to use are still present in the panel, but I can't switch between them anymore, neither by using the shortcut not by clicking on them.

    I have the same problem on my netbook, where I am using Lubuntu 12.04 (couldn't find the netbook remix).

    Also I can't make a screenshot while the drop-down menu of the keyboard icon is active.

  2. #2
    Join Date
    Dec 2008
    Location
    Independence, MO
    Beans
    132
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 12.04 changing keyboard layout

    I don't have much experience with keyboard changing, but perhaps the process was changed in 12.04. Have you messed with the settings in "System Settings...-->Keyboard" and then clicking on Layout Settings?
    HP ProBook 4530s - 4GB RAM - 12.04 AMD64

  3. #3
    Join Date
    Aug 2009
    Location
    Tromsø
    Beans
    8
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: 12.04 changing keyboard layout

    I didn't change anything there. There isn't much to change either.
    Attached Images Attached Images

  4. #4
    Join Date
    Aug 2009
    Location
    Tromsø
    Beans
    8
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: 12.04 changing keyboard layout

    Surely I can't be the only one with that bug? Even though I didn't change anything, I find myself all of a sudden stuck with only a US keyboard.

  5. #5
    Join Date
    Mar 2005
    Location
    Ice cold Norway
    Beans
    517

    Re: 12.04 changing keyboard layout

    Same thing happens to me. I have set it to Norwegian but when I type I get English layout. Very frustrating!

  6. #6
    Join Date
    Mar 2006
    Beans
    11

    Exclamation Re: 12.04 changing keyboard layout

    Same thing for me. My norwegian layout is selectable and the keyboard icon shows it`s activated but only US characters appear on screen.

  7. #7
    Join Date
    Aug 2009
    Location
    Tromsø
    Beans
    8
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: 12.04 changing keyboard layout

    I found a temporary fix which also works on my netbook with Lubuntu 12.04

    Code:
    sudo setxkbmap -option grp:alt_shift_toggle no,ru
    However this needs to be repeated every time one logs in.

  8. #8
    Join Date
    Mar 2005
    Location
    Ice cold Norway
    Beans
    517

    Re: 12.04 changing keyboard layout

    Thanks, that works. I hope they get this fixed soon!

  9. #9
    Join Date
    Jun 2011
    Location
    Netherlands
    Beans
    146
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: 12.04 changing keyboard layout

    Try editing /etc/default/keyboard

    mine looks like this:
    Code:
    # Some comments
    
    XKBMODEL="pc105"
    XKBLAYOUT="us"
    XKBVARIANT="altgr-intl"
    XKBOPTIONS="compose:ralt"
    
    # More comments
    I think you need to change yours to

    Code:
    XKBMODEL="pc105"
    XKBLAYOUT="no,ru"
    XKBVARIANT="altgr-intl"
    XKBOPTIONS="grp:alt_shift_toggle"
    You can also specify user specific keyboard options in ~/.Xmodmap
    Mine looks like this for example:
    Code:
    remove Lock = Caps_Lock
    keycode 66 = BackSpace

  10. #10
    Join Date
    Mar 2005
    Location
    Ice cold Norway
    Beans
    517

    Re: 12.04 changing keyboard layout

    Anyone know if a bug has been posted for this? I can't get into my launchpad account atm...

    My /etc/default/keyboard on login says:

    Code:
    XKBMODEL="pc105"
    XKBLAYOUT="no"
    XKBVARIANT=""
    XKBOPTIONS=""

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •